gcc-4.5 does not compile today's wine from git

Bug #704633 reported by Susan Cragin on 2011-01-18
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gcc-4.5 (Debian)
Fix Released
Undecided
Unassigned
gcc-4.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gcc-4.5

I compile wine from the daily git every single day. Today it did not work, and at the same time there is a new gcc-4.5, so I suspect a new bug.

I tried again with the following, and it seemed to work.
./configure CFLAGS="-g -01" && make

$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.5.2/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.5.2-1ubuntu6' --with-bugurl=file:///usr/share/doc/gcc-4.5/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.5 --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.5 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-gold --enable-ld=default --with-plugin-ld=ld.gold --enable-objc-gc --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-1ubuntu6)

I will submit compiler output and the pen.i file.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gcc-4.5 4.5.2-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Jan 18 16:02:36 2011
InstallationMedia: Ubuntu-Studio 11.04 "Natty Narwhal" - Alpha amd64 (20101220)
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: gcc-4.5

Susan Cragin (susancragin) wrote :
Susan Cragin (susancragin) wrote :
Susan Cragin (susancragin) wrote :
Susan Cragin (susancragin) wrote :

I tried re-compiling today (10 February 2011) and the bug seems to be no longer present.
I believe that the bug may have been fixed in the current release, which I used.
gcc (Ubuntu/Linaro 4.5.2-2ubuntu2) 4.5.2

There were 4 other people with my experience.
Have anyone else's problems been solved by 4.5.2-2?

George (tvirin) wrote :

I'm using gcc 4.5.2-2 (Debian) and the problem is not fixed.

Matthias Klose (doko) wrote :

this seems to be fixed in natty

Changed in gcc-4.5 (Ubuntu):
status: New → Fix Released
Matthias Klose (doko) wrote :

and should be fixed in Debian too

Changed in gcc-4.5 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers