internal compiler error: in build_polynomial_chrec, at tree-chrec.h:143

Bug #682333 reported by Alessio Treglia
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gcc-4.5 (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
transcode (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: gcc-4.5

I've been trying to build transcode on Natty with the attached patch and but the building fails with the following error:

/bin/bash ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -D_REENTRANT -I.. -I../src -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -c -o filter_smartyuv.lo filter_smartyuv.c
libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -D_REENTRANT -I.. -I../src -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -c filter_smartyuv.c -fPIC -DPIC -o .libs/filter_smartyuv.o
filter_smartyuv.c: In function 'smartyuv_core':
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 1 of 'Blendline_c' differ in signedness
filter_smartyuv.c:313:20: note: expected 'uint8_t *' but argument is of type 'char *'
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 2 of 'Blendline_c' differ in signedness
filter_smartyuv.c:313:20: note: expected 'uint8_t *' but argument is of type 'char *'
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 3 of 'Blendline_c' differ in signedness
filter_smartyuv.c:313:20: note: expected 'uint8_t *' but argument is of type 'char *'
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 4 of 'Blendline_c' differ in signedness
filter_smartyuv.c:313:20: note: expected 'uint8_t *' but argument is of type 'char *'
filter_smartyuv.c: In function 'tc_filter':
filter_smartyuv.c:1454:11: warning: pointer targets in passing argument 1 of 'smartyuv_core' differ in signedness
filter_smartyuv.c:331:13: note: expected 'char *' but argument is of type 'uint8_t *'
filter_smartyuv.c:1470:6: warning: pointer targets in passing argument 1 of 'smartyuv_core' differ in signedness
filter_smartyuv.c:331:13: note: expected 'char *' but argument is of type 'uint8_t *'
filter_smartyuv.c:1474:6: warning: pointer targets in passing argument 1 of 'smartyuv_core' differ in signedness
filter_smartyuv.c:331:13: note: expected 'char *' but argument is of type 'uint8_t *'
filter_smartyuv.c: In function 'smartyuv_core':
filter_smartyuv.c:331:13: internal compiler error: in build_polynomial_chrec, at tree-chrec.h:143
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.5/README.Bugs> for instructions.
make[4]: *** [filter_smartyuv.lo] Error 1
make[4]: Leaving directory `/tmp/buildd/transcode-1.1.5/filter'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/buildd/transcode-1.1.5/filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/buildd/transcode-1.1.5'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/transcode-1.1.5'

The full buildlog is attached.

Revision history for this message
Alessio Treglia (quadrispro) wrote :
Revision history for this message
Alessio Treglia (quadrispro) wrote :
Changed in gcc-4.5 (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

please could you attach the preprocessed source?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.5 - 4.5.1-12ubuntu1

---------------
gcc-4.5 (4.5.1-12ubuntu1) natty; urgency=low

  * Merge with Debian, remaining changes:
    - Build from the upstream tarball, including GFDL documents.

gcc-4.5 (4.5.1-12) experimental; urgency=low

  * Update to SVN 20101210 (r167686) from the gcc-4_5-branch (4.5.2 rc).
    - Fix PR fortran/45742, PR tree-optimization/46498, PR target/45807,
      PR target/44266, PR rtl-optimization/46315, PR tree-optimization/44545,
      PR tree-optimization/46491, PR rtl-optimization/46571, PR target/31100,
      PR c/46547, PR fortran/46638, PR tree-optimization/46675, PR debug/46258,
      PR ada/40777, PR fortran/46753, PR libgomp/45240, PR target/43897,
      PR rtl-optimization/46777, PR rtl-optimization/46614,
      PR middle-end/46629, PR middle-end/46499, PR tree-optimization/44676,
      PR target/45870, PR middle-end/46534, PR rtl-optimization/46440,
      PR c++/46401, PR tree-optimization/46806, PR tree-optimization/46663,
      PR debug/46123, PR middle-end/46651, PR c++/46538, PR c++/46058,
      PR fortran/46794, PR target/45693, PR libgcj/42986.

  [ Matthias Klose ]
  * Use lib instead of lib64 as the 64bit system dir on biarch
    architectures defaulting to 64bit. Closes: #603597.
  * Fix powerpc and s390 builds when biarch is disabled.
  * Backport PR bootstrap/44768, miscompilation of dpkg on ARM
    with -O2 (Chung-Lin Tang). LP: #674146.
  * Update libgcc2 symbols file. Closes: #602099.
  * Update the Linaro support to the 4.5 2010.12 release.

  [ Marcin Juszkiewicz ]
  * Do not depend on target mpfr and zlib -dev packages for cross builds.
    LP: #676027.
  * Apply ARM target configure options for stage1/stage2 cross builds.
    LP: #684625.
  * Allow to build only the -source package, and include the version
    in the package name. LP: #682333.

  [ Konstantinos Margaritis ]
  * Add support for new target architecture `armhf'. Closes: #603948.

gcc-4.5 (4.5.1-11) experimental; urgency=low

  * Update to SVN 20101114 (r166728) from the gcc-4_5-branch.
    - Fix PR fortran/45742.
  * Don't hardcode debian/patches when referencing patches. Closes: #600502.
 -- Matthias Klose <email address hidden> Fri, 10 Dec 2010 20:19:12 +0100

Changed in gcc-4.5 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Marcin Juszkiewicz (hrw) wrote :

Are you sure that this bug is closed?

"* Allow to build only the -source package, and include the version in the package name. LP: #682333." should mention #682650 instead.

Revision history for this message
Martin (martin-zdila) wrote :

I am still experiencing this error.
gcc-4.5 4.5.2-8ubuntu4

Revision history for this message
Michiel van Wessem (windsunrain) wrote :

Same things here. Transcode is broken in Ubuntu 11.04, so I tried to compile it from source, but gcc is apparently also broken.

Please fix this.

Revision history for this message
Michiel van Wessem (windsunrain) wrote :

Patch is not required. Standard transcode source will cause gcc to report "internal compiler error"

Revision history for this message
Michiel van Wessem (windsunrain) wrote :

Using x86_64

Revision history for this message
Matthias Klose (doko) wrote :

> Please submit a full bug report,
> with preprocessed source if appropriate.

please do so

Changed in gcc-4.5 (Ubuntu):
status: Fix Released → Incomplete
Revision history for this message
Michiel van Wessem (windsunrain) wrote :

Below is some more information. I hope this will help you to come to a solution. I want to thank you for your efforts on this. I realize this is open source and not a commercial product.

I'm not familiar with the bug reporting process. Let me know if you need more information than what is below or if you need this to be in a more formal format .

The transcode package, with the included xvid.stab plug in, is the only good way to stabilize video on Linux and I believe many people would benefit if this worked correctly.

OK. So I'm using Ubuntu 11.04, x86_64 flavor on an AMD Phenom II based system. All package came straight from original installation or regular Ubuntu upgrades (I believe I've had this installation since gutsy).

gcc package version is 4.5.2-8ubuntu4

The transcode package simply came from sudo apt-get source transcode. It's version is transcode_1.1.5-0ubuntu7.

I got build dependencies, made the transcode directory my current and did sudo dpkg-buildpackage

after a while, happy building stops with:

libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -D_REENTRANT -I.. -I../src -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -c filter_smartyuv.c -fPIC -DPIC -o .libs/filter_smartyuv.o
filter_smartyuv.c: In function ‘smartyuv_core’:
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 1 of ‘Blendline_c’ differ in signedness
filter_smartyuv.c:313:20: note: expected ‘uint8_t *’ but argument is of type ‘char *’
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 2 of ‘Blendline_c’ differ in signedness
filter_smartyuv.c:313:20: note: expected ‘uint8_t *’ but argument is of type ‘char *’
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 3 of ‘Blendline_c’ differ in signedness
filter_smartyuv.c:313:20: note: expected ‘uint8_t *’ but argument is of type ‘char *’
filter_smartyuv.c:1130:3: warning: pointer targets in passing argument 4 of ‘Blendline_c’ differ in signedness
filter_smartyuv.c:313:20: note: expected ‘uint8_t *’ but argument is of type ‘char *’
filter_smartyuv.c: In function ‘tc_filter’:
filter_smartyuv.c:1454:11: warning: pointer targets in passing argument 1 of ‘smartyuv_core’ differ in signedness
filter_smartyuv.c:331:13: note: expected ‘char *’ but argument is of type ‘uint8_t *’
filter_smartyuv.c:1470:6: warning: pointer targets in passing argument 1 of ‘smartyuv_core’ differ in signedness
filter_smartyuv.c:331:13: note: expected ‘char *’ but argument is of type ‘uint8_t *’
filter_smartyuv.c:1474:6: warning: pointer targets in passing argument 1 of ‘smartyuv_core’ differ in signedness
filter_smartyuv.c:331:13: note: expected ‘char *’ but argument is of type ‘uint8_t *’
filter_smartyuv.c: In function ‘smartyuv_core’:
filter_smartyuv.c:331:13: internal compiler error: in build_polynomial_chrec, at tree-chrec.h:143
Please submit a full bug report,
with preprocessed source if appropriate.

Chances are, if you have a Natty system you can grab the transcode package and build as I did and you'll see the same issue.

Revision history for this message
Michiel van Wessem (windsunrain) wrote :
Download full text (231.7 KiB)

Precompiled source:

# 1 "filter_smartyuv.c"
# 1 "/usr/src/transcode-1.1.5/filter//"
# 1 "<built-in>"
# 1 "<command-line>"
# 1 "filter_smartyuv.c"
# 28 "filter_smartyuv.c"
# 1 "../src/transcode.h" 1
# 28 "../src/transcode.h"
# 1 "../config.h" 1
# 29 "../src/transcode.h" 2

# 1 "/usr/include/sys/stat.h" 1 3 4
# 27 "/usr/include/sys/stat.h" 3 4
# 1 "/usr/include/features.h" 1 3 4
# 323 "/usr/include/features.h" 3 4
# 1 "/usr/include/bits/predefs.h" 1 3 4
# 324 "/usr/include/features.h" 2 3 4
# 356 "/usr/include/features.h" 3 4
# 1 "/usr/include/sys/cdefs.h" 1 3 4
# 353 "/usr/include/sys/cdefs.h" 3 4
# 1 "/usr/include/bits/wordsize.h" 1 3 4
# 354 "/usr/include/sys/cdefs.h" 2 3 4
# 357 "/usr/include/features.h" 2 3 4
# 388 "/usr/include/features.h" 3 4
# 1 "/usr/include/gnu/stubs.h" 1 3 4

# 1 "/usr/include/bits/wordsize.h" 1 3 4
# 5 "/usr/include/gnu/stubs.h" 2 3 4

# 1 "/usr/include/gnu/stubs-64.h" 1 3 4
# 10 "/usr/include/gnu/stubs.h" 2 3 4
# 389 "/usr/include/features.h" 2 3 4
# 28 "/usr/include/sys/stat.h" 2 3 4

# 1 "/usr/include/bits/types.h" 1 3 4
# 28 "/usr/include/bits/types.h" 3 4
# 1 "/usr/include/bits/wordsize.h" 1 3 4
# 29 "/usr/include/bits/types.h" 2 3 4

typedef unsigned char __u_char;
typedef unsigned short int __u_short;
typedef unsigned int __u_int;
typedef unsigned long int __u_long;

typedef signed char __int8_t;
typedef unsigned char __uint8_t;
typedef signed short int __int16_t;
typedef unsigned short int __uint16_t;
typedef signed int __int32_t;
typedef unsigned int __uint32_t;

typedef signed long int __int64_t;
typedef unsigned long int __uint64_t;

typedef long int __quad_t;
typedef unsigned long int __u_quad_t;
# 131 "/usr/include/bits/types.h" 3 4
# 1 "/usr/include/bits/typesizes.h" 1 3 4
# 132 "/usr/include/bits/types.h" 2 3 4

typedef unsigned long int __dev_t;
typedef unsigned int __uid_t;
typedef unsigned int __gid_t;
typedef unsigned long int __ino_t;
typedef unsigned long int __ino64_t;
typedef unsigned int __mode_t;
typedef unsigned long int __nlink_t;
typedef long int __off_t;
typedef long int __off64_t;
typedef int __pid_t;
typedef struct { int __val[2]; } __fsid_t;
typedef long int __clock_t;
typedef unsigned long int __rlim_t;
typedef unsigned long int __rlim64_t;
typedef unsigned int __id_t;
typedef long int __time_t;
typedef unsigned int __useconds_t;
typedef long int __suseconds_t;

typedef int __daddr_t;
typedef long int __swblk_t;
typedef int __key_t;

typedef int __clockid_t;

typedef void * __timer_t;

typedef long int __blksize_t;

typedef long int __blkcnt_t;
typedef long int __blkcnt64_t;

typedef unsigned long int __fsblkcnt_t;
typedef unsigned long int __fsblkcnt64_t;

typedef unsigned long int __fsfilcnt_t;
typedef unsigned long int __fsfilcnt64_t;

typedef long int __ssize_t;

typedef __off64_t __loff_t;
typedef __quad_t *__qaddr_t;
typedef char *__caddr_t;

typedef long int __intptr_t;

typedef unsigned int __socklen_t;
# 30 "/usr/include/sys/stat.h" 2 3 4
# 39 "/usr/include/sys/stat.h" 3 4
# 1 "/usr/include/time.h" 1 3 4
# 74 "/usr/include/time.h" 3 4

typedef __time_t time_t;

# 120 "/usr/include/time.h" 3 4
struct timespec
  {
    __time_t tv_sec;
    long in...

Revision history for this message
Matthias Klose (doko) wrote :

next time, please *attach* the file, don't paste it.

this is fixed in 4.5.3. for natty, either

 - build using -O1
 - build using gcc-4.4
 - build using gcc-4.5 from the ~ubuntu-toolchain-r PPA

Changed in transcode (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

fixed in oneiric

Changed in gcc-4.5 (Ubuntu):
status: Incomplete → Fix Released
Changed in gcc-4.5 (Ubuntu Natty):
status: New → Won't Fix
Changed in transcode (Ubuntu Natty):
status: New → Confirmed
Revision history for this message
Michiel van Wessem (windsunrain) wrote :

That helped.

Vielen Dank!

Revision history for this message
Alessio Treglia (quadrispro) wrote :

This is fixed since Oneiric.
Closing.

Changed in transcode (Ubuntu):
status: Confirmed → Fix Released
Changed in transcode (Ubuntu Natty):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers