[armel][cross]The cross compiler Build-depends on incorrect version of gcc-4.5-source

Bug #609060 reported by Peter Pearse
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc-4.5 (Ubuntu)
Undecided
Marcin Juszkiewicz

Bug Description

Binary package hint: gcc-4.5

The arml cross compiler packages available from
http://people.canonical.com/~hrw/ubuntu-maverick-armel-cross-compilers
contain
Package: gcc-4.5
which has
Build-Depends:......... , gcc-4.5-source (>= 4.5.1), gcc-4.5-source (<< 4.5.2),.........
However gcc-4.5-source is not available with this version

Revision history for this message
Peter Pearse (peter-pearse) wrote :

Probably arising from the rules.conf entry:

else
# build cross compiler
  CROSS_BUILD_DEP := libc6-dev$(cross_lib_arch), zlib1g-dev$(cross_lib_arch), libmpfr-dev$(cross_lib_arch),
  SOURCE_BUILD_DEP := gcc-$(BASE_VERSION)-source (>= $(GCC_VERSION)), gcc-$(BASE_VERSION)-source (<< $(NEXT_GCC_VERSION)),

Also mentioned in https://bugs.launchpad.net/ubuntu/+source/gcc-4.4/+bug/593187

Marcin Juszkiewicz (hrw)
Changed in gcc-4.5 (Ubuntu):
assignee: nobody → Marcin Juszkiewicz (hrw)
status: New → Confirmed
Revision history for this message
Marcin Juszkiewicz (hrw) wrote :

Fix commited in svn r4617 - will land in next package release

Changed in gcc-4.5 (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.5 - 4.5.1-1ubuntu1

---------------
gcc-4.5 (4.5.1-1ubuntu1) maverick; urgency=low

  * Merge with Debian.

gcc-4.5 (4.5.1-1) experimental; urgency=low

  * GCC-4.5.1 release.
  * Update to SVN 20100731 (r162781) from the gcc-4_5-branch.
    - Fix PR tree-optimization/45052, PR target/43698.
  * Apply proposed fixes for PR c++/45112, PR c/45079.
  * Install config/vxworks-dummy.h in the gcc-4.5-plugin-dev package
    on armel, mips, mipsel, sh4, sparc, sparc64. Closes: #590054.
  * Link executables statically when `static' is passed in DEB_BUILD_OPTIONS
    (Jim Heck). Closes: #590102.
  * Stop building java packages from the gcc-4.5 source package.

gcc-4.5 (4.5.0-10) experimental; urgency=low

  * Update to SVN 20100725 (r162508) from the gcc-4_5-branch.
    - Fix PR tree-optimization/45047, PR c++/43016, PR c++/45008.
  * Disable building gcj/libjava on mips/mipsel (fails to link libgcj).
  * Update libstdc++6 symbols files.

gcc-4.5 (4.5.0-9) experimental; urgency=low

  * Update to SVN 20100723 (r162448) from the gcc-4_5-branch (post
    GCC-4.5.1 release candidate 1).
    - Fix PR debug/45015, PR target/44942, PR tree-optimization/44900,
      PR tree-optimization/44977, PR c++/44996, PR fortran/44929,
      PR fortran/30668, PR fortran/31346, PR fortran/34260,
      PR fortran/40011.

  [ Marcin Juszkiewicz ]
  * Fix dependencies on cross library packages.
  * Copy all debian/rules* files to the -source package.

  [ Matthias Klose ]
  * Fix versioned build dependency on gcc-4.x-source package for cross builds.
    LP: #609060.
  * Set Vcs attributes in control file.
 -- Matthias Klose <email address hidden> Sat, 31 Jul 2010 16:46:14 +0200

Changed in gcc-4.5 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers