Ubuntu

ICE building qt4-x11 in IA64

Reported by Scott Kitterman on 2010-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc
Fix Released
Medium
gcc-4.4 (Ubuntu)
High
Unassigned
Lucid
High
Matthias Klose
qt4-x11 (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: gcc-4.4

https://launchpad.net/ubuntu/+source/qt4-x11/4:4.6.2-0ubuntu1/+build/1532313/+files/buildlog_ubuntu-lucid-ia64.qt4-x11_4:4.6.2-0ubuntu1_FAILEDTOBUILD.txt.gz

g++ -c -include .pch/release-shared/QtWebKit -g -O2 -I/usr/include/freetype2 -Wreturn-type -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-stack-protector -O2 -I/usr/include/freetype2 -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_SHARED -DBUILDING_QT__=1 -DNDEBUG -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DHAVE_STDINT_H -DBUILD_WEBKIT -DENABLE_JAVASCRIPT_DEBUGGER=1 -DENABLE_DATABASE=1 -DENABLE_EVENTSOURCE=1 -DENABLE_OFFLINE_WEB_APPLICATIONS=1 -DENABLE_DOM_STORAGE=1 -DENABLE_ICONDATABASE=1 -DENABLE_CHANNEL_MESSAGING=1 -DENABLE_ORIENTATION_EVENTS=0 -DENABLE_SQLITE=1 -DENABLE_DASHBOARD_SUPPORT=0 -DENABLE_FILTERS=0 -DENABLE_XPATH=1 -DENABLE_WCSS=0 -DENABLE_WML=0 -DENABLE_SHARED_WORKERS=1 -DENABLE_WORKERS=1 -DENABLE_XHTMLMP=0 -DENABLE_DATAGRID=0 -DENABLE_SVG=1 -DENABLE_SVG_FONTS=1 -DENABLE_SVG_FOREIGN_OBJECT=1 -DENABLE_SVG_ANIMATION=1 -DENABLE_SVG_AS_IMAGE=1 -DENABLE_SVG_USE=1 -DENABLE_RUBY=1 -DENABLE_VIDEO=1 -DENABLE_DATALIST=1 -DENABLE_NETSCAPE_PLUGIN_API=1 -DENABLE_WEB_SOCKETS=0 -DENABLE_XSLT=1 -DWTF_USE_JAVASCRIPTCORE_BINDINGS=1 -DWTF_CHANGES=1 -DBUILDING_QT__ -DBUILDING_JavaScriptCore -DBUILDING_WTF -DXP_UNIX -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../../../mkspecs/linux-g++ -I. -I../../../../include/QtCore -I../../../../include/QtNetwork -I../../../../include/QtGui -I../../../../include/QtXmlPatterns -I../../../../include -Ibridge/qt -Ipage/qt -Iplatform/graphics/qt -Iplatform/network/qt -Iplatform/qt -I../WebKit/qt/WebCoreSupport -I. -Iaccessibility -Ibindings/js -Ibridge -Ibridge/c -Icss -Idom -Idom/default -Iediting -Ihistory -Ihtml -Ihtml/canvas -Iinspector -Iloader -Iloader/appcache -Iloader/archive -Iloader/icon -Inotifications -Ipage -Ipage/animation -Iplatform -Iplatform/animation -Iplatform/graphics -Iplatform/graphics/filters -Iplatform/graphics/transforms -Iplatform/image-decoders -Iplatform/mock -Iplatform/network -Iplatform/sql -Iplatform/text -Iplugins -Irendering -Irendering/style -Istorage -Isvg -Isvg/animation -Isvg/graphics -Isvg/graphics/filters -Iwebsockets -Iwml -Iworkers -Ixml -Igenerated -I../JavaScriptCore -I../../webkit -I../JavaScriptCore/assembler -I../JavaScriptCore/bytecode -I../JavaScriptCore/bytecompiler -I../JavaScriptCore/debugger -I../JavaScriptCore/interpreter -I../JavaScriptCore/jit -I../JavaScriptCore/parser -I../JavaScriptCore/profiler -I../JavaScriptCore/runtime -I../JavaScriptCore/wrec -I../JavaScriptCore/wtf -I../JavaScriptCore/wtf/unicode -I../JavaScriptCore/yarr -I../JavaScriptCore/API -I../JavaScriptCore/ForwardingHeaders -Igenerated -I../WebKit/qt/Api -I../../../../include/QtWebKit -I.rcc/release-shared -I../JavaScriptCore/pcre -I/build/buildd/qt4-x11-4.6.2/src/3rdparty/webkit/WebKitBuild/Release/JavaScriptCore/tmp -I../../../../include/phonon -I/usr/X11R6/include -I.moc/release-shared -o obj/release/SerializedScriptValue.o bindings/js/SerializedScriptValue.cpp
bindings/js/SerializedScriptValue.cpp: In function 'typename TreeWalker::OutputType WebCore::walk(TreeWalker&, typename TreeWalker::InputType) [with TreeWalker = WebCore::SerializingTreeWalker]':
bindings/js/SerializedScriptValue.cpp:343: error: could not split insn
(call_insn 4851 22712 22713 359 ../JavaScriptCore/wtf/Vector.h:284 (parallel [
            (call (mem:DI (const_int 0 [0x0]) [0 S8 A64])
                (const_int 1 [0x1]))
            (clobber (reg:DI 320 b0))
            (clobber (scratch:DI))
            (clobber (scratch:DI))
        ]) 354 {call_gp} (expr_list:REG_DEAD (reg:DI 1 r1)
        (expr_list:REG_EH_REGION (const_int 124 [0x7c])
            (nil)))
    (expr_list:REG_DEP_TRUE (use (reg:DI 1 r1))
        (nil)))
bindings/js/SerializedScriptValue.cpp:343: internal compiler error: in final_scan_insn, at final.c:2604
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.4/README.Bugs> for instructions.

I don't have access to IA64 hardware, so I've no ability to troubleshoot this further/provide pre-processed source.

Changed in gcc-4.4 (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
tags: added: regression-potential
Changed in gcc-4.4 (Ubuntu Lucid):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

Matthias,

This bug has been targeted to beta-1 - do you have time to look into this?

Changed in gcc-4.4 (Ubuntu Lucid):
assignee: nobody → Matthias Klose (doko)
Matthias Klose (doko) wrote :

started a local build

Matthias Klose (doko) wrote :

works without -fno-strict-aliasing, or with changing optimization to -O1 or -Os, not seen with the trunk (4.5), or 4.3.

Changed in qt4-x11 (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
Matthias Klose (doko) wrote :

how to change the optimization for a single file in the qt build?

Changed in qt4-x11 (Ubuntu Lucid):
status: New → Triaged
Changed in gcc:
status: Unknown → New
Kees Cook (kees) wrote :

Fix for bug 538237 attached there (stack-protector).

Matthias Klose (doko) wrote :

won't update gcc-4.4 before the beta

Changed in qt4-x11 (Ubuntu Lucid):
status: Triaged → In Progress
Changed in gcc-4.4 (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.6.2-0ubuntu2

---------------
qt4-x11 (4:4.6.2-0ubuntu2) lucid; urgency=low

  [ Matthias Klose ]
  * 90_ia64_opts.diff: Build with -Os on ia64, to work around
    PR target/43348. LP: #531697.
  * debian/rules (clean): Use find/xargs for a small speedup.

  [ Kees Cook ]
  * Add kubuntu_12_fix_stack_protector.diff: restore the stack protector
    compiler flag (LP: #538237).
 -- Matthias Klose <email address hidden> Sun, 14 Mar 2010 13:58:43 +0100

Changed in qt4-x11 (Ubuntu Lucid):
status: In Progress → Fix Released
Matthias Klose (doko) wrote :

still ftbfs, this time a problem with the precompiled header files. introduced with the stack protector changes?

Changed in qt4-x11 (Ubuntu Lucid):
status: Fix Released → Confirmed
Matthias Klose (doko) wrote :

now built on the second buildd

Changed in qt4-x11 (Ubuntu Lucid):
status: Confirmed → Fix Released
Matthias Klose (doko) on 2010-03-18
Changed in gcc-4.4 (Ubuntu Lucid):
status: New → In Progress
Steve Langasek (vorlon) wrote :

is there any reason to consider the gcc side of this a release-targeted bug, if a workaround for qt4-x11 is now in place?

On 19.03.2010 05:48, Steve Langasek wrote:
> is there any reason to consider the gcc side of this a release-targeted
> bug, if a workaround for qt4-x11 is now in place?

no, ia64 isn't a release arch in this sense. the fix is pending, and ia64 only.

Steve Langasek (vorlon) wrote :

'wontfix'ing the lucid task, tracked with the default Ubuntu task.

Changed in gcc-4.4 (Ubuntu Lucid):
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.4 - 4.4.3-4ubuntu1

---------------
gcc-4.4 (4.4.3-4ubuntu1) lucid; urgency=low

  * Merge with Debian.
  * Upstream changes compared to 4.4.3-3ubuntu3:
    - Fix PR libfortran/43265, PR rtl-optimization/43360, PR target/43348,
      PR middle-end/43323.

gcc-4.4 (4.4.3-4) unstable; urgency=low

  * Update to SVN 20100320 from the gcc-4_4-branch (r157597).
    - Fix PR c/43248, PR middle-end/42233, PR bootstrap/43121,
      PR tree-optimization/43220, PR ada/42253, PR fortran/43303,
      PR fortran/43228, PR libfortran/43265, PR rtl-optimization/43360,
      PR libfortran/43265.
  * gcj-4.4-jre-headless: Stop providing java-virtual-machine.
  * Backport plugin support from the trunk:
    - Configure with --enable-plugin --disable-browser-plugin.
    - Add build support for a gcc-4.4-plugin-dev package.
  * Apply proposed fix for PR target/43348. LP: #531697.
  * Apply proposed patch for PR middle-end/43323.
  * libstdc++-arm-ldbl-compat.diff: On ARM provide the long double versions
    of "C" math functions in libstdc++; these are dropped when built
    against glibc-2.11.
  * ARM: Backport rev148072 from the trunk.
  * Backport proposed patch to enable both gold and ld in a single toolchain.
    New option -fuse-ld=ld.bfd, -fuse-ld=gold.
 -- Matthias Klose <email address hidden> Sun, 21 Mar 2010 09:01:29 +0100

Changed in gcc-4.4 (Ubuntu Lucid):
status: Won't Fix → Fix Released
Changed in gcc:
status: New → Fix Released
Loïc Minier (lool) wrote :

I'm closing the gcc-4.4 development task since qt4-x11 4:4.7.0~beta2-0ubuntu2 built successfully in Maverick.

Changed in gcc-4.4 (Ubuntu):
assignee: Matthias Klose (doko) → nobody
status: In Progress → Fix Released
Changed in gcc:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.