[armel] duplicate label created with current gcc-4.4

Bug #490440 reported by Matthias Klose on 2009-11-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc-4.4 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gcc-4.4

4.4.2-3ubuntu1 fails to build eglibc; building with -marm works fine.

gcc-4.4 -fno-stack-protector -U_FORTIFY_SOURCE ether_hton.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fstrict-aliasing -g -pipe -Wstrict-prototypes -I../include -I/build/buildd/eglibc-2.10.2/build-tree/armel-libc/inet -I/build/buildd/eglibc-2.10.2/build-tree/armel-libc -I../ports/sysdeps/arm/elf -I../ports/sysdeps/unix/sysv/linux/arm/eabi/nptl -I../ports/sysdeps/unix/sysv/linux/arm/eabi -I../ports/sysdeps/unix/sysv/linux/arm/nptl -I../ports/sysdeps/unix/sysv/linux/arm -I../ports/sysdeps/unix/sysv/linux -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../ports/sysdeps/unix/arm -I../ports/sysdeps/unix -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../ports/sysdeps/arm/eabi -I../ports/sysdeps/arm/fpu -I../ports/sysdeps/arm/nptl -I../ports/sysdeps/arm -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../ports -I../nptl -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/arm-linux-gnueabi/4.4.2/include -isystem /usr/lib/gcc/arm-linux-gnueabi/4.4.2/include-fixed -isystem /build/buildd/eglibc-2.10.2/debian/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h -o /build/buildd/eglibc-2.10.2/build-tree/armel-libc/inet/ether_hton.o -MD -MP -MF /build/buildd/eglibc-2.10.2/build-tree/armel-libc/inet/ether_hton.o.dt -MT /build/buildd/eglibc-2.10.2/build-tree/armel-libc/inet/ether_hton.o
{standard input}: Assembler messages:
{standard input}:185: Error: symbol `.LPIC0' is already defined
make[3]: *** [/build/buildd/eglibc-2.10.2/build-tree/armel-libc/inet/ether_hton.o] Error 1

Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :
Dave Martin (dave-martin-arm) wrote :

util-linux 2.16-1ubuntu5 seems to have a similar problem, using gcc-4.4 4.4.2-3ubuntu1. See the attached patch and script to reproduce.

Dave Martin (dave-martin-arm) wrote :

As with with Matthias' bug, -marm causes the problem to disappear.

-O1 also causes the problem to disappear.

Matthias Klose (doko) wrote :

in eglibc the following files are affected:

  inet/ether_hton.c
  inet/ether_ntoh.c
  sunrpc/publickey.c

Matthias Klose (doko) wrote :

unable to reproduce with trunk 20091204, with or without -mthumb.

Matthias Klose (doko) wrote :

no difference with gcc-4.4 4.4.2-3ubuntu2 compared to gcc-4.4 4.4.2-3ubuntu1

Matthias Klose (doko) on 2009-12-08
Changed in gcc-4.4 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Matthias Klose (doko) wrote :

fixed in 4.4.2-5ubuntu1

Changed in gcc-4.4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers