gcc-4.2.4 update for hardy-proposed

Bug #264515 reported by Matthias Klose on 2008-09-03
8
Affects Status Importance Assigned to Milestone
gcc-4.2 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
gcc-defaults (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
gcj-4.2 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
gdc-4.2 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
gnat-4.2 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: gcc-4.2

planning an update of gcc-4.2 for hardy-proposed. there are some wrong-code bugs for the current gcc-4.2 release, which are fixed in the upstream 4.2.4 release. plus two other wrong-code reports are fixed on the 4.2 branch.

proposing to fix these for hardy.

debian/changelog:

gcc-4.2 (4.2.4-3ubuntu1.8.04.1) hardy-proposed; urgency=low

  * Upload to hardy-proposed.
  * Fixes included in the 4.2.4 upstream release (compared to 4.2.3-3ubuntu7):
    - Fix LP: #256797, wrong-code on ia32, taken from the gcc-4_2-branch.
    - Fix PR middle-end/36093, wrong-code, taken from the gcc-4_2-branch.
    - Fix PR bootstrap/35169, PR c/35744, PR c/35436, PR c++/35578.
  * Fix PR target/36634, wrong-code on powerpc, taken from the gcc-4_2 branch.
  * Fix PR middle-end/35432, ice-on-valid-code, taken from the gcc-4_2-branch.
  * Fix PR target/37101, wrong-code, taken from the gcc-4_2-branch.
  * Re-add the libffi4 symbol files.

Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :

packages are prepared in the ubuntu-toolchain PPA

 - the compiler testsuites don't show regressions compared to the current
   version in hardy. checked in amd64, i386, lpia.

some packages were built using this compiler in my personal PPA (doko); some things fail, but are unrelated to the gcc-4.2 update (amd64 and i386):

 - apache2; built, doesn't have a testsuite which is run during the build

 - glib2.0; the testsuite doesn't show regressions.

 - mysql-dfsg-5.0: no regressions in the testsuite.

 - perl: one test fails in the testsuite (hostname lookup), although it succeeds
   with a local build. suspecting a setup problem with the buildd.

 - php5: one regression (IPv6 Loopback test [ext/sockets/tests/ipv6loop.phpt]),
   succeeds with a local build, suspecting a setup problem with the buildd.

 - postgresql-8.3: no regressions on amd64, on i386 the testsuite is not run.

 - pygtk2.0: build fails on amd64, seen as well with the current gcc version in hardy.
   no regressions on i386.

 - python2.5: no regressions in the testsuite.

 - glibc: no regressions in the testsuite

Matthias Klose (doko) wrote :

these are the current changes (minus the svn-update diffs), now reducing. some changes are not needed for our architectures.

Matthias Klose (doko) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gcc-4.2:
status: New → Fix Committed
Steve Beattie (sbeattie) wrote :

Marking fix released for intrepid after targeting for hardy, as it looks like 4.2.4 already went in to intrepid. Please reopen that task if that's incorrect.

Changed in gcc-4.2:
status: New → Fix Committed
status: Fix Committed → Fix Released
Steve Beattie (sbeattie) wrote :

gcc-4.2 and associated packages versioned 4.2.4-1ubuntu3 were moved to hardy-updates on 2008.10.22. Intrepid looks to have gotten 4.2.4 versions of everything before that, closing all tasks.

I didn't see a related update for gcc-defaults go through, marking those tasks invalid.

Changed in gcc-4.2:
status: Fix Committed → Fix Released
Changed in gcc-defaults:
status: New → Invalid
status: New → Invalid
Changed in gcj-4.2:
status: New → Fix Released
status: New → Fix Released
Changed in gdc-4.2:
status: New → Fix Released
status: New → Fix Released
Changed in gnat-4.2:
status: New → Fix Released
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers