FTBFS: Link tests are not allowed after GCC_NO_EXECUTABLES

Bug #24223 reported by Debian Bug Importer on 2005-10-19
12
Affects Status Importance Assigned to Milestone
gcc-4.0 (Debian)
Fix Released
Unknown
gcc-4.0 (Ubuntu)
High
Matthias Klose

Bug Description

Automatically imported from Debian bug report #334626 http://bugs.debian.org/334626

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #334626 http://bugs.debian.org/334626

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 18 Oct 2005 13:45:09 -0700
From: Matt Kraai <email address hidden>
To: <email address hidden>
Subject: FTBFS: Link tests are not allowed after GCC_NO_EXECUTABLES

--cNdxnHkX5QqsyA0e
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: gcc-4.0
Version: 4.0.2-2
Severity: serious

gcc-4.0 fails to build:

> checking for library containing gettext... configure: error: Link tests a=
re not allowed after GCC_NO_EXECUTABLES.
> make[3]: *** [configure-target-libstdc++-v3] Error 1
> make[3]: Leaving directory `/tmp/buildd/gcc-4.0-4.0.2/build'
> make[2]: *** [bootstrap] Error 2
> make[2]: Leaving directory `/tmp/buildd/gcc-4.0-4.0.2/build'
> s=3D`cat status`; rm -f status; test $s -eq 0
> make[1]: *** [stamps/05-build-stamp] Error 1
> make[1]: Leaving directory `/tmp/buildd/gcc-4.0-4.0.2'
> make: *** [stamps/05-build-stamp] Error 2

--=20
Matt

--cNdxnHkX5QqsyA0e
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDVV7VfNdgYxVXvBARAiWyAJ95lg5U886DBdwmASNQNZ27FwJhWQCeJNpM
pRPSvukpeMmTJmFXgsC2o30=
=4gtN
-----END PGP SIGNATURE-----

--cNdxnHkX5QqsyA0e--

reassign 334626 binutils
reassign 334627 binutils
thanks

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 19 Oct 2005 10:02:46 +0200
From: Matthias Klose <email address hidden>
To: <email address hidden>
Subject: needs updated ld, see #334013

reassign 334626 binutils
reassign 334627 binutils
thanks

merge 334626 334627
thanks

cu
Adrian

--

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 22 Oct 2005 00:21:06 +0200
From: Adrian Bunk <email address hidden>
To: <email address hidden>
Subject: this is the same issue

merge 334626 334627
thanks

cu
Adrian

--

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Debian Bug Importer (debzilla) wrote :

*** Bug 24224 has been marked as a duplicate of this bug. ***

Download full text (4.9 KiB)

Source: binutils
Source-Version: 2.16.1cvs20051109-1

We believe that the bug you reported is fixed in the latest version of
binutils, which is due to be installed in the Debian FTP archive:

binutils-dev_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils-dev_2.16.1cvs20051109-1_i386.deb
binutils-doc_2.16.1cvs20051109-1_all.deb
  to pool/main/b/binutils/binutils-doc_2.16.1cvs20051109-1_all.deb
binutils-multiarch_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils-multiarch_2.16.1cvs20051109-1_i386.deb
binutils_2.16.1cvs20051109-1.diff.gz
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1.diff.gz
binutils_2.16.1cvs20051109-1.dsc
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1.dsc
binutils_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1_i386.deb
binutils_2.16.1cvs20051109.orig.tar.gz
  to pool/main/b/binutils/binutils_2.16.1cvs20051109.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
James Troup <email address hidden> (supplier of updated binutils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 11 Nov 2005 20:38:22 +0000
Source: binutils
Binary: binutils-dev binutils-hppa64 binutils-multiarch binutils binutils-doc
Architecture: source i386 all
Version: 2.16.1cvs20051109-1
Distribution: unstable
Urgency: low
Maintainer: James Troup <email address hidden>
Changed-By: James Troup <email address hidden>
Description:
 binutils - The GNU assembler, linker and binary utilities
 binutils-dev - The GNU binary utilities (BFD development files)
 binutils-doc - Documentation for the GNU assembler, linker and binary utilities
 binutils-multiarch - Binary utilities that support multi-arch targets
Closes: 326103 327780 333980 334626 334673 336175 336939
Changes:
 binutils (2.16.1cvs20051109-1) unstable; urgency=low
 .
   * New upstream CVS snapshot.
    * Fixes broken PLT handling on m68k. Closes: #327780
    * Don't compile flex files with -Werror, fixing mips builds.
      Closes: #333980
    * Don't check undefined symbols introduced by "ld -u" for TLS. Closes:
      #326103
 .
   * 117_mips_symbolic_link.dpatch: merged upstream - removed.
 .
   * debian/rules: pass --disable-werror on ia64 as current gcc generates
     too many false positives. Closes: #336939
 .
   * 125_fix_tc_arm_cast.dpatch: new patch from Lennert Buytenhek to fix
     cast warning and arm builds. Closes: #336175
 .
   * 121_i386_x86_64_biarch.dpatch: imported from Ubuntu at request of
     Daniel Jacobwitz to fix biarch linking on i386/amd64. Closes:
     #334626, #334673
 .
   * debian/rules: remove any reference to pkgstriptranslations - an
     Ubuntu-ism that shouldn't have been in the Debian package in the first
  ...

Read more...

Debian Bug Importer (debzilla) wrote :
Download full text (5.2 KiB)

Message-Id: <email address hidden>
Date: Sat, 12 Nov 2005 04:02:10 -0800
From: James Troup <email address hidden>
To: <email address hidden>
Subject: Bug#334626: fixed in binutils 2.16.1cvs20051109-1

Source: binutils
Source-Version: 2.16.1cvs20051109-1

We believe that the bug you reported is fixed in the latest version of
binutils, which is due to be installed in the Debian FTP archive:

binutils-dev_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils-dev_2.16.1cvs20051109-1_i386.deb
binutils-doc_2.16.1cvs20051109-1_all.deb
  to pool/main/b/binutils/binutils-doc_2.16.1cvs20051109-1_all.deb
binutils-multiarch_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils-multiarch_2.16.1cvs20051109-1_i386.deb
binutils_2.16.1cvs20051109-1.diff.gz
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1.diff.gz
binutils_2.16.1cvs20051109-1.dsc
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1.dsc
binutils_2.16.1cvs20051109-1_i386.deb
  to pool/main/b/binutils/binutils_2.16.1cvs20051109-1_i386.deb
binutils_2.16.1cvs20051109.orig.tar.gz
  to pool/main/b/binutils/binutils_2.16.1cvs20051109.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
James Troup <email address hidden> (supplier of updated binutils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 11 Nov 2005 20:38:22 +0000
Source: binutils
Binary: binutils-dev binutils-hppa64 binutils-multiarch binutils binutils-doc
Architecture: source i386 all
Version: 2.16.1cvs20051109-1
Distribution: unstable
Urgency: low
Maintainer: James Troup <email address hidden>
Changed-By: James Troup <email address hidden>
Description:
 binutils - The GNU assembler, linker and binary utilities
 binutils-dev - The GNU binary utilities (BFD development files)
 binutils-doc - Documentation for the GNU assembler, linker and binary utilities
 binutils-multiarch - Binary utilities that support multi-arch targets
Closes: 326103 327780 333980 334626 334673 336175 336939
Changes:
 binutils (2.16.1cvs20051109-1) unstable; urgency=low
 .
   * New upstream CVS snapshot.
    * Fixes broken PLT handling on m68k. Closes: #327780
    * Don't compile flex files with -Werror, fixing mips builds.
      Closes: #333980
    * Don't check undefined symbols introduced by "ld -u" for TLS. Closes:
      #326103
 .
   * 117_mips_symbolic_link.dpatch: merged upstream - removed.
 .
   * debian/rules: pass --disable-werror on ia64 as current gcc generates
     too many false positives. Closes: #336939
 .
   * 125_fix_tc_arm_cast.dpatch: new patch from Lennert Buytenhek to fix
     cast warning and arm builds. Closes: #336175
 .
   * 121_i386_x86_64_biarch.dpatch: imported from Ubuntu at request of
     Daniel Jacobwitz t...

Read more...

Matthias Klose (doko) wrote :

not in breezy's binutils

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.