Ubuntu

libg2c missing in intrepid?

Reported by Katrina Niolet on 2008-07-18
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gcc-3.4 (Debian)
Fix Released
Unknown
gcc-3.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libg2c0-dev

This package seems to be missing in intrepid and no other packages seem to provide libg2c.so

==================
Draft Text for Release notes

It is no longer possible to run Fortran binaries compiled with g77 (unless compiled with the -no-f2c option). This is due to the removal of g77 and libg2c from the gcc-3.4 package. You are advised to recompile the Fortran program with gfortran. If this is not possible stay with Ubuntu 8.04.1

Matthias Klose (doko) wrote :

won't fix, please use gfortran.

Changed in gcc-4.3:
status: New → Won't Fix
Adam Reeve (adreeve) wrote :

What are we supposed to do for binaries that require libg2c?

sam tygier (samtygier) wrote :

Installing gfortran does not help with running existing binaries.

If this is not going to be fixed please can you point me to the discussion where it was decided to drop support for running old fortran binaries.

Changed in gcc-3.4:
status: Won't Fix → New
sam tygier (samtygier) wrote :

installing
libg2c0 from http://packages.ubuntu.com/hardy-updates/libg2c0
using
sudo dpkg -i --force-depends-version libg2c0_3.4.6-6ubuntu5_i386.deb
makes my program work, but apt remains upset but the version missmatch

Changed in gcc-3.4:
status: Unknown → Won't Fix
sam tygier (samtygier) on 2008-10-23
description: updated
Steve Langasek (vorlon) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
sam tygier (samtygier) wrote :

I have been trying to reenable g77 in gcc-3.4 by comparing the etch (3.4.6ds1-5) and lenny (3.4.6ds1-8). but the change happened in 3.4.6ds1-7, so there are many other changes. If anyone knows how to get a diff between the x-6 and x-7 versions that would be handy.

the line that stops fortran being built is in debian/rules.defs line 325
with_fortran := disabled for the gcc-3.4 build

commenting it lets fortran be built.

the build then fails due to missing parts of the debian/control file.

dh_gencontrol: package g77-3.4-doc is not in control info
dpkg-gencontrol: error: package g77-3.4-doc not in control info
dh_gencontrol: command returned error code 65280
make[1]: *** [stamps/08-binary-stamp-fortran-doc] Error 1
make[1]: Leaving directory `/home/sam/fortran/gcc-3.4-3.4.6'
make: *** [binary] Error 2
dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-3.4 - 3.4.6-8ubuntu2

---------------
gcc-3.4 (3.4.6-8ubuntu2) intrepid; urgency=low

  * Build g77 runtime package again, except for hppa. LP: #249991.

 -- Matthias Klose <email address hidden> Thu, 23 Oct 2008 10:04:58 +0000

Changed in gcc-3.4:
status: New → Fix Released
Steve Langasek (vorlon) wrote :

sigh, ok, reverting the release notes.

sam tygier (samtygier) wrote :

Thanks for fixing this. Sorry if i was a bit hasty getting this into the release notes. I thought the issue had already been decided. Thanks again.

Changed in gcc-3.4:
status: Won't Fix → Fix Released
osman (osmangultekinsrp) on 2012-05-30
Changed in gcc-3.4 (Ubuntu):
assignee: nobody → osman (osmangultekinsrp)
assignee: osman (osmangultekinsrp) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.