Ubuntu

removal request

Reported by Matthias Klose on 2009-08-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gcc-3.3 (Ubuntu)
Undecided
Unassigned
gcc-3.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gcc-3.3

please remove gcc-3.3 and gcc-3.4 from karmic. the packages are removed from debian unstable as well.

Steve Langasek (vorlon) wrote :

The following packages are broken by removing gcc-3.3:

-- karmic/universe i386 deps on libstdc++5:
ichthux-desktop
-- karmic/multiverse build deps on libstdc++5:
glassfishv2
wink
-- karmic/multiverse amd64 deps on libstdc++5:
libamdxvba1
-- karmic/multiverse i386 deps on libstdc++5:
atokx2
glassfishv2-bin
libamdxvba1
vmware-package
wink
-- karmic/multiverse ia64 deps on libstdc++5:
basilisk2

What should we do with these?

Changed in gcc-3.3 (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

In turn, gcc-3.3 build-depends on gcc-3.4 (!), so is unbuildable if we remove gcc-3.3.

Other reverse-deps of gcc-3.4:

-- karmic/universe build deps on libg2c0:
mpich2

Changed in gcc-3.4 (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

-- karmic/multiverse build deps on libstdc++5:
[...]
wink

This one's removed in unstable, and I've just removed it from karmic.

Matthias Klose (doko) wrote :

mpich2 is removed in unstable as well

Changed in gcc-3.3 (Ubuntu):
status: Incomplete → New
Changed in gcc-3.4 (Ubuntu):
status: Incomplete → New
Matthias Klose (doko) wrote :

glassfishv2 should be removed as well, there's a newer version in universe

Matthias Klose (doko) wrote :

the ia64 packages are not available in unstable, maybe remove in karmic as well?

Matthias Klose (doko) wrote :

filed bug #432018 for ichthux-desktop

Matthias Klose (doko) wrote :

filed bug #432021 for libamdxvba1

Matthias Klose (doko) wrote :

about atokx2: that's an installer for commercial software, just ignore the dependency?

Description: Installer for "ATOK for Linux" Japanese input method
 This package helps users to install popular commercial non-free
 Japanese input method "ATOK for Linux" to Debian system. You have to
 buy it to use this installer.

Matthias Klose (doko) wrote :

vmware-package: please ignore? that's an installer for older vmware versions:

 The following products are supported:
 .
   * VMware Workstation 6.0 (includes VMware Player).
   * VMware Player 2.0.
   * VMware Server 1.0.
   * VMware Server Console 1.0.
   * VMware Server Management Interface 1.0.
   * any-any kernel modules.

Mathieu Comandon (strycore) wrote :

libstdc++5 is needed by Unreal Tournament 2004 and this game won't be patched.

John B. (jbuncher) wrote :

libstdc++5 is also needed by Mathematica 6, and I don't think wolfram is letting us at the source to patch that any time soon...

Hugo (hugomartiniano-gmail) wrote :

The intel compilers also depend on libstdc++5 ...

Martin Pitt (pitti) wrote :

Seems these got removed from karmic a while ago, so I close this bug.

$ rmadison -s karmic gcc-3.3 gcc-3.4
$

Changed in gcc-3.4 (Ubuntu):
status: New → Fix Released
Changed in gcc-3.3 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers