Ubuntu

gcalctool should calculate the result when the = key is pressed

Reported by peterzay on 2011-04-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GCalctool
Confirmed
Medium
gcalctool (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gcalctool

When I use a mouse pointer to do 2+2= I get 4, but when I use a keyboard I get 2+2= as per attached screenshot. In basic mode (default), I expect normal calculator behaviour, not algebraic behaviour. After this, you have to press Enter to display the result.

The expected result would be to display the result when pressing the = key, just as when you press the Enter key.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gcalctool 5.91.93-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Sat Apr 9 02:28:31 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110402)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gcalctool
UpgradeStatus: No upgrade log present (probably fresh install)

peterzay (peterzay) wrote :
peterzay (peterzay) wrote :

To combine bugs for sake of simplicity, select the Show thousands separators in Preferences. Then use the mouse to perform the following keystrokes: 5 x2 = x2 = and get ,625 (see attached screenshot). Note the extraneous comma and the pink colorization corruption from the screenshot tool.

Robert Roth (evfool) wrote :

Thanks for taking the time to report this bug. I have tried to reproduce the issues on Natty with all updates, gcalctool 6.0.1~git20110421-0ubuntu1, and the issue from comment #2 does not happen anymore, only 625 is displayed, so let's keep this bug tracking the issue you have reported in the description, about the = sign from keyboard not displaying the results.

In the future, try to report only one bug /issue, because reporting multiple ones in the same bug usually leads to difficulties in tracking which have been fixed and which have not been fixed, so usually people will either split the bug into separate ones, or mark it as Fix released when one of the issues has been fixed, which is obviously wrong.

Changed in gcalctool (Ubuntu):
status: New → Confirmed
summary: - gcalctool takes keyboard input literally
+ gcalctool should calculate the result when the = key is pressed
description: updated
peterzay (peterzay) wrote :

This bug is still unresolved in 11.10 Oneiric.

Robert Roth (evfool) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=662451

Changed in gcalctool:
importance: Unknown → Medium
status: Unknown → New
Robert Roth (evfool) on 2011-10-22
Changed in gcalctool (Ubuntu):
status: Confirmed → Triaged
Changed in gcalctool:
status: New → Confirmed
peterzay (peterzay) wrote :

This bug is still not fixed in 12.04 beta Precise Pangolin.

Since this is an LTS build, I think basic calculator functions should all work.

PioneerAxon (arth-svnit) wrote :

Hi peterzay,
This is not possible to be done, because gcalctool supports storing results as variable (e.g. "a = 123+34") and then use them in another expressions (e.g. "b = 123+a").

And, if this request is implemented, it will be impossible to enter something like "a = 123+34".

Even if we implement it by checking that if "=" is entered after numbers, then evaluate. And if "=" is entered after characters, then don't evaluate. This, then it brings more problems, as it won't work when entering something like "123+ans =" or with hexadecimal digits (e.g. "123abc + 1b =").

peterzay (peterzay) wrote :

What you describe in comment #7 is normally considered advanced calculator function.

In basic (default) mode, a calculator should always behave symmetrically between mouse action and keyboard action. If I click on the = sign on screen and get a result, then pressing the = key should give the same result.

In a basic calculator, we expect basic behaviour.

In prior versions of gcalctool, this has always been this way.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.