gcalctool fails to resize down when a mode that requires less space is selected

Bug #486359 reported by Erik B. Andersen on 2009-11-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GCalctool
Fix Released
Medium
gcalctool (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gcalctool

In the calculator, when you change the mode (financial, for example) to something that takes less space (basic mode, for example), the window does not shrink. This used to work, I just tried it on my Karmic computer and it worked.
By modes, I mean whatever you are changing when you go to the View (menu) > Advanced (for example).
I might try making a video of it so that it is easy to see what I am saying.
Here's the requested details:
bjorn@bjorn-laptop:~$ lsb_release -rd
Description: Ubuntu lucid (development branch) <--I'm using the 11-20-2009 daily Lucid build
Release: 10.04
bjorn@bjorn-laptop:~$ apt-cache policy gcalctool
gcalctool:
  Installed: 5.29.1-0ubuntu1
  Candidate: 5.29.1-0ubuntu1
  Version table:
 *** 5.29.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
bjorn@bjorn-laptop:~$

ProblemType: Bug
Architecture: amd64
Date: Sat Nov 21 09:08:40 2009
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gcalctool
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091120)
Package: gcalctool 5.29.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-4.5-generic
SourcePackage: gcalctool
Uname: Linux 2.6.32-4-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:1650): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1650): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1730): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1709): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (nautilus:1998): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Erik B. Andersen (azendale) wrote :
Erik B. Andersen (azendale) wrote :

In the video, I:

1. Open a calculator in basic mode for comparison
2. Open a second calculator and put it in programmer mode, which makes it use a bigger window
3. Open a third calculator and change the mode from programmer to basic. Notice that the window does not size back down to the size of the first calculator I opened, which is also in basic mode.
4. I take third calculator (the one I changed from programmer to basic) and compare it's size to the second calculator (which is in programmer mode), notice that the sizes are exactly the same.

If there is anything I can do to make this bug report more clear, just ask.

Philip Muškovac (yofel) wrote :

Confirmed in Lucid.

Changed in gcalctool (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) wrote :

I have reported the bug to the Gnome developers. You can follow the bug there at https://bugzilla.gnome.org/show_bug.cgi?id=602591

MarcRandolph (mrand) on 2009-11-21
Changed in gcalctool (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gcalctool (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 5.29.91-0ubuntu1

---------------
gcalctool (5.29.91-0ubuntu1) lucid; urgency=low

  * New upstream release:
    * Fix bug where backspace deletes all input in locales with no thousands
      separator (LP: #521038)
    * Make boolean operations work with zero, e.g. "0 XOR 5" (LP: #496235)
    * Don't override space and return when display area not selected
    * Make window non-resizable (LP: #486359) (LP: #501680)
    * Change boolean functions to uppercase (xor -> XOR)
    * Documentation rewritten (LP: #521396)
    * Modernised build system
  * debian/control:
    - Build-depend on gnome-common
    - Remove build-depend on scrollkeeper
  * debian/rules:
    - Run autoreconf on build
    - Don't need to clean /var anymore (no scrollkeeper)
    - Don't need to disable scrollkeeper on build
    - Don't need to delete libparser.a anymore
  * debian/install:
  * debian/links:
  * debian/rules:
    - Install gcalctool.xpm from debian/install
    - Make gnome-calculator man page link in debian/links
  * debian/patches/01_lpi.patch:
    - Updated
  * debian/patches/99_autoconf.patch:
    - Not required, autoconf now run from debian/rules
 -- Robert Ancell <email address hidden> Mon, 22 Feb 2010 11:22:07 +1100

Changed in gcalctool (Ubuntu):
status: Fix Committed → Fix Released
Erik B. Andersen (azendale) wrote :

I can confirm this is fixed with 5.29.91-0ubuntu1. Thank you Robert Ancell.

Changed in gcalctool:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.