Doesn't update bit editor when a number is shifted

Bug #394375 reported by Ning Ke on 2009-07-01
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GCalctool
Fix Released
Low
gcalctool (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gcalctool

Description: Ubuntu 9.04
Release: 9.04

gcalctool:
  Installed: 5.26.0-0ubuntu1
  Candidate: 5.26.0-0ubuntu1
  Version table:
 *** 5.26.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Under View, select Programming.

Enter number 1, Then select "<" and 3 places.

Number 8 appears. Which is correct. However, the bit editor still shows: 0000 0001.

It should have been: 0000 1000

In fact any shifts (left and right) doesn't cause the bit editor to update.

Regular arithmetic (addition, e.x.) does cause the the bit editor to update.

Changed in gcalctool (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in gcalctool:
status: Unknown → New
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 5.27.4-0ubuntu1

---------------
gcalctool (5.27.4-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #399160)
    - Update bit editor after shifting (Robert Ancell, Bug #587545) (LP: #394375)
    - Use a base-10 internal representation (Robert Ancell, bug #585813, bug #585931, bug #560802) (LP: #375356) (LP: #387070)
    - Make padding consistent in GUI (Jerry Casiano, Bug #587292)
    - Support implicit multiply before functions, e.g. "6 log 3" (Robert Ancell, Bug #586812) (LP: #389533)
    - Use inverse notation for trigonometric functions, i.e. "asin" -> "sin⁻¹"
    - Use lowercase notation for trigonometric and logarithm functions to look
      more like standard mathematical notation
    - Put spacing around functions, i.e. "sin" -> " sin "
    - Use subscript for logarithm base two, i.e. "log2" -> "log₂"
    - Added etched border around display (Robert Ancell, Bug #140836)
    - Rewrote out of date man page (Robert Ancell, Bug #585997)
  * debian/watch:
    - Watch for unstable versions

 -- Robert Ancell <email address hidden> Tue, 14 Jul 2009 17:41:36 +1000

Changed in gcalctool (Ubuntu):
status: Confirmed → Fix Released
Changed in gcalctool:
status: New → Fix Released

This defect appeared again in August!

Changed in gcalctool (Ubuntu):
status: Fix Released → New
Robert Ancell (robert-ancell) wrote :

Andreas, what version are you using? It is fixed for me in 5.27.92, can you provide steps to reproduce?

Changed in gcalctool (Ubuntu):
status: New → Incomplete
summary: - calculator doesn't update bits when a number is shifted
+ Doesn't update bit editor when a number is shifted
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gcalctool:
status: Fix Released → Invalid
Changed in gcalctool (Ubuntu):
status: Incomplete → Invalid
Changed in gcalctool:
importance: Unknown → Low
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.