Errors in fractional addition

Bug #375356 reported by Shawe Ewahs on 2009-05-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GCalctool
Fix Released
Medium
gcalctool (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gcalctool

It don't ocurred ever, only in some cases.

With 2.0-0.5-0.5-0.5-0.5=0

What happened? It isn't a logical bug.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gcalctool
Package: gcalctool 5.26.0-0ubuntu1
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: gcalctool
Uname: Linux 2.6.28-12-generic i686

Shawe Ewahs (shawe-ewahs) wrote :
Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in gcalctool (Ubuntu):
status: New → Incomplete

*1. the specific steps or actions you took that caused you to encounter the
problem,*

Doing this operation: 1.0-0.2-0.2-0.2-0.2-0.2 the result is -0.

* 2. the behavior you expected, and*

  Must do 0.

* 3. the behavior you actually encountered (in as much detail as possible).*

It don't ocurred with all posibiliies but occure in any others.

I haven't more info that this, this bug causes that any time the result 0 is
changed by -0 without reason for the user. I can't give you more detailes
that sended the first time, because I don't have more, only this.
Also, the info send this time, is the same to first time, only different is
that is responding your steps.

By §h@wæ
http://www.islatux.es

2009/5/12 Chris Coulson <email address hidden>

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Unfortunately, we can't fix it because your description
> didn't include enough information. You may find it helpful to read "How
> to report bugs effectively"
> http://www.chiark.greenend.org.uk/~sgtatham/bugs.html<http://www.chiark.greenend.org.uk/%7Esgtatham/bugs.html>.
> We'd be grateful
> if you would then provide a more complete description of the problem.
>
> We have instructions on debugging some types of problems at
> http://wiki.ubuntu.com/DebuggingProcedures
>
> At a minimum, we need:
> 1. the specific steps or actions you took that caused you to encounter the
> problem,
> 2. the behavior you expected, and
> 3. the behavior you actually encountered (in as much detail as possible).
> Thanks!
>
> ** Changed in: gcalctool (Ubuntu)
> Status: New => Incomplete
>
> --
> 1.0-0.2-0.2-0.2-0.2-0.2=-0 ¿?¿?
> https://bugs.launchpad.net/bugs/375356
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I have notified upstream developers of this problem : http://bugzilla.gnome.org/show_bug.cgi?id=582310

Changed in gcalctool (Ubuntu):
status: Incomplete → Confirmed
summary: - 1.0-0.2-0.2-0.2-0.2-0.2=-0 ¿?¿?
+ Errors in fractional addition
Changed in gcalctool (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gcalctool:
status: Unknown → Confirmed
Changed in gcalctool (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 5.27.4-0ubuntu1

---------------
gcalctool (5.27.4-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #399160)
    - Update bit editor after shifting (Robert Ancell, Bug #587545) (LP: #394375)
    - Use a base-10 internal representation (Robert Ancell, bug #585813, bug #585931, bug #560802) (LP: #375356) (LP: #387070)
    - Make padding consistent in GUI (Jerry Casiano, Bug #587292)
    - Support implicit multiply before functions, e.g. "6 log 3" (Robert Ancell, Bug #586812) (LP: #389533)
    - Use inverse notation for trigonometric functions, i.e. "asin" -> "sin⁻¹"
    - Use lowercase notation for trigonometric and logarithm functions to look
      more like standard mathematical notation
    - Put spacing around functions, i.e. "sin" -> " sin "
    - Use subscript for logarithm base two, i.e. "log2" -> "log₂"
    - Added etched border around display (Robert Ancell, Bug #140836)
    - Rewrote out of date man page (Robert Ancell, Bug #585997)
  * debian/watch:
    - Watch for unstable versions

 -- Robert Ancell <email address hidden> Tue, 14 Jul 2009 17:41:36 +1000

Changed in gcalctool (Ubuntu):
status: Triaged → Fix Released
Changed in gcalctool:
status: Confirmed → Fix Released
Changed in gcalctool:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.