gcalctool 5.24.1, won't switch to rad

Bug #306702 reported by seanmft on 2008-12-09
16
Affects Status Importance Assigned to Milestone
gcalctool (Ubuntu)
Low
Ubuntu Desktop Bugs
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: gcalctool

When In scientific mode with radians selected I expected to be able to use multiples of pi/radians to plug into trig functions (i.e. COS, SIN, TAN) and get the same values for trig functions as when I converted radians to degrees and used the same trigonometric functions. Instead the calculator still gives degree values for all trigonometric functions so that pi a 180 degree value, gives values for 3.141 degrees!

I'm using the constants drop down selector to select pi as there is no "pi button" and also tried entering it manually.

 I'm using gcalctool 5.24.1 on ubuntu 8.10 i686, with kernel 2.6.27-9. On an Hp Pavilion ze 4300 lap top with AMD Athlon xp 2200+

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/gcalctool
Package: gcalctool 5.24.1-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gcalctool
Uname: Linux 2.6.27-9-generic i686

Related branches

seanmft (seanmft) wrote :
Pedro Villavicencio (pedro) wrote :

this is likely to be fixed with 5.24.2 update, could you try to do the same as soon as the update is available and comment back ?thanks.

Changed in gcalctool:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Fix Committed
Kadu Diógenes (kdiogenes) wrote :

When this will be available throw the update system?

Evan Huus (eapache) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=559575

Definitely fixed upstream.

I too would like to know when this is going to make it into updates?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 5.25.3-0ubuntu1

---------------
gcalctool (5.25.3-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #312125).
    - Bitcalculating extension calculate value properly (LP: #200590).
    - Usage of correct operator precedence (LP: #302115).
    - Allow switch to rad (LP: #306702).

 -- Christophe Sauthier <email address hidden> Fri, 26 Dec 2008 16:20:06 +0100

Changed in gcalctool:
status: Fix Committed → Fix Released

After discussiong with pitti and seb128, I re-asking for a SRU for that bug.

Please sponsor gcalctool 5.24.2 into intrepid. It is a SRU.

gcalctool (5.24.2-0ubuntu1) intrepid-proposed; urgency=low

  * New upstream version (LP: #302915).
    - Remember setting to ignore change mode warning between instance
    (LP: #281541).
    - Removed double conversion in boolean and 32 bit and 16 bit to handle
      larger numbers (LP: #181763).
    - Update on the build-depends from the 2.11.6 to 2.14.0
      + Update of debian/configure.in and debian/configure to reflect that.
      + Update of debian/patches/01_lpi.patch since it patches
        debian/configure.in.
      + Update of debian/patches/02_autoconf.patch since it patches
        debian/configure.

 -- Christophe Sauthier <email address hidden> Thu, 27 Nov 2008 20:46:19 +0100

Various bugs are adressed by that update:
    -> bug 181763. Users cannot use the unsigned integer value (u16 or u32) with big numbers.
    -> bug 281541. User choice of not displaying a warning is not remembered on restart of the application.
    -> bug 306702. Gcalctool is not switching correctly to radians.

These bugs are adressed from the 5.24.2 stable version of gcalctool.

TEST CASE: Bug 181763.
Launch the application, click View -> Scientific. Then click &16 (or the &32) button and enter the number 1111111111111111, and close the function call with the closing ')'. Hit enter. The result will be 0 while it should be 29127 (resp. 3047977415). It is corrected in the proposed package version.

TEST CASE: Bug 281541.
Launch the application, click View -> Scientific (if you are already in that view pick another one). Check "Do not warn me again" and then "Change Mode". Close the application, and then relaunch it. Click on View -> Basic, you will get again the warning window, while you shouldn't. It is not the case anymore with the proposed package.

TEST CASE: Bug 306702.
Launch the application, click View -> Scientific.
Then the Degrees button and calcultate sin(180). Hit enter. The result will be 0.
Switch to the Radians button and then calculate sin(180). Hit enter. The result will be 0 while it should be -0.801152636. It is corrected in the proposed package version.

Martin Pitt (pitti) wrote :

If the new upstream version does not change anything else, it's bearable for an SRU. There need to be some people willing to test it, though.

Please prepare an update and upload it to the queue.

Changed in gcalctool:
assignee: nobody → christophe.sauthier
status: New → In Progress

The new upstream (5.24.3) is only a documentation update to the 5.24.2 that was put here.

I'll prepare the update today.

Thanks martin.

gcalctool (5.24.3-0ubuntu1) intrepid-proposed; urgency=low

  * New upstream version (LP: #302915).
    - Remember setting to ignore change mode warning between instance
      (LP: #281541).
    - Removed double conversion in boolean and 32 bit and 16 bit to handle
      larger numbers (LP: #181763).
    - Fix the trigonometric functions (LP: #306702)
    - Update on the build-depends from the 2.11.6 to 2.14.0
      + Update of debian/configure.in and debian/configure to reflect that.
      + Update of debian/patches/01_lpi.patch since it patches
        debian/configure.in.
      + Update of debian/patches/02_autoconf.patch since it patches
        debian/configure.

 -- Christophe Sauthier <email address hidden> Mon, 19 Jan 2009 23:49:11 +0100

Martin Pitt (pitti) wrote :

This is the debdiff with autoconf and po updates removed, thus the actually important bits.

Which of those fixes already meet the SRU criteria, i. e. fix regressions from hardy? The other need to be trivial.

The changes generally look good to me, and incorrect calculations are indeed a nuisance, so this looks acceptable to me. However, we should clarify the regression status.

Here are the various regressions status :

Bug 181763 : it is a regression, since it was working correctly on hardy (gcalctool 5.22.3)

Bug 281541 : was already present on hardy.

Bug 306702 : it is a regression, since it was working correctly on hardy (gcalctool 5.22.3)

Changed in gcalctool (Ubuntu Intrepid):
assignee: Christophe Sauthier (huats) (christophe.sauthier) → nobody
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.