Bitcalculating extension doesn't properly calculate value.

Bug #200590 reported by Jordan Bradley on 2008-03-10
2
Affects Status Importance Assigned to Milestone
GCalctool
Fix Released
Medium
gcalctool (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gcalctool

I was playing around with the software preloaded in Ubuntu and I decided to play with Calculator. I switched it to Scientific mode, then went View -> Show Bitcalculating extension.

I switched the 8(2^3), 4(2^2) and 1(2^0) positions to 1 and it showed 13 (no problem yet), then I switched the 2^63 position to 1 and it changed to 9223372036854775808 (I'm not checking if that's right). I change the 2^63 position back to 0 and it says 0 instead of thirteen. I click on the 8 position again and it says 8 instead of 5.

I'm using Ubuntu Desktop 7.10

ProblemType: Bug
Architecture: i386
Date: Mon Mar 10 10:36:46 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gcalctool
Package: gcalctool 5.20.2-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gcalctool
ProcCwd: /home/jordanwb
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gcalctool
Uname: Linux JORDAN-LAPTOP 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Related branches

This is bug is still present in the current hardy version (5.21.92).

Changed in gcalctool:
status: New → Confirmed

A new upstream version is due today.

As soon as it is released, I'll make create the package to incorporate it in hardy. And test this bug, to figure out if it is still present. If so, i'll add a bug upstream.

Thanks for the bug report...

I'm new to Linux so you had me up to "This is bug is still present in the current", other than that you lost me.

> If so, i'll add a bug upstream.
As you know, ubuntu does not create every software that are provided with the distribution. The huge majority of them are created by other people, and the ubuntu community integrates them in the distribution (and sometime fixes them also..). The creator of the software is called upstream.
So if this bug is still present, in the current version (2.22.0-0ubuntu2), which is the latest that upstrem has released, it means that the still have that bug.
And thus I'll let them know about that by creating a bug report in their own bug report system...

Ok Gotcha.

The bug is tsill present in the Hardy current version (2.22.1-0ubuntu1). The only difference is that at the end the switch back of the 8 position again and it says 0 instead of 5.

I'll report it upstream right now. Thanks for you help to make ubuntu better.

Changed in gcalctool:
assignee: nobody → desktop-bugs
Changed in gcalctool:
status: Unknown → New
Changed in gcalctool:
status: New → Confirmed
Changed in gcalctool:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gcalctool:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in gcalctool:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcalctool - 5.25.3-0ubuntu1

---------------
gcalctool (5.25.3-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #312125).
    - Bitcalculating extension calculate value properly (LP: #200590).
    - Usage of correct operator precedence (LP: #302115).
    - Allow switch to rad (LP: #306702).

 -- Christophe Sauthier <email address hidden> Fri, 26 Dec 2008 16:20:06 +0100

Changed in gcalctool:
status: Fix Committed → Fix Released
Changed in gcalctool:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.