Please merge gbgoffice 1.4-5 (universe) from Debian unstable (main).

Bug #503789 reported by Bhavani Shankar on 2010-01-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gbgoffice (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/gbgoffice
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync gbgoffice 1.4-5 (universe) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:

Debian has fixed FTBFS with gcc 4.4 by incorporating ubuntu patch. so
package can be synced

Changelog since current lucid version 1.4-4ubuntu1:

gbgoffice (1.4-5) unstable; urgency=low

  * Acknowledge NMU. Thanks gregor!

  * control: put me in Maintainer: instead of a dead mailing list
  * add README.source documenting quilt usage
  * rules: convert to minimalistic debhelper v7 style
  * control: remove binary package Section (duplicating source one)
  * replace re-autogen.patch with a call of ./autogen.sh
  * merge prepare-configure-for-multidir.patch into multidir.patch
  * refresh all patches with --no-timestamps --no-index -p ab --strip-
    trailing-whitespace
  * describe all patches
  * Bump standards-version to 3.8.3

 -- Damyan Ivanov <email address hidden> Mon, 28 Dec 2009 14:41:40 +0200

gbgoffice (1.4-4.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix "FTBFS: invalid const conversion", apply patch from Ubuntu, thanks to
    Jon Bernard (closes: #550115).

 -- gregor herrmann <email address hidden> Fri, 25 Dec 2009 19:05:39 +0100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFLRJI2NrEIsZrsMaARAn+wAKCTVN62EM7HDh2v1pF2sI/Lta0XgQCcCEm1
LH/TQjN+CF8qHq9I8zyHjjY=
=Rg2C
-----END PGP SIGNATURE-----

Related branches

Fabrice Coutadeur (fabricesp) wrote :

FTBFS in lucid:
g++ -DHAVE_CONFIG_H -I. -DDATA_DIR_CONFIG=\"/usr/share/bgoffice/\" -pthread -D_REENTRANT -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/gtk-2.0 -I/usr/include/gtk-unix-print-2.0 -I/usr/include/atkmm-1.6 -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/cairomm-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -Wall -g -O2 -MT workhelper.o -MD -MP -MF .deps/workhelper.Tpo -c -o workhelper.o workhelper.cpp
workhelper.cpp: In constructor 'WorkHelper::WorkHelper()':
workhelper.cpp:42: error: invalid conversion from 'Gtk::ButtonBox*' to 'Gtk::HButtonBox*'

Can you have a look?

Thanks,
Fabrice

Changed in gbgoffice (Ubuntu):
status: New → Incomplete
Bhavani Shankar (bhavi) wrote :

Hmm strange enough

it built fine on my PPA

http://launchpadlibrarian.net/37504052/buildlog_ubuntu-lucid-i386.gbgoffice_1.4-5ubuntu1_FULLYBUILT.txt.gz

awaiting further comments

Regards

Benjamin Drung (bdrung) wrote :

I tried to build it with an up-to-date pbuilder environment on amd64 and it failed with the same error message.

Unsubscribing ubuntu-universe-sponsors. Please resubscribe u-u-s, when this issue is resolved.

Bhavani Shankar (bhavi) wrote :

okay forwarding to debian

Regards

Bhavani Shankar (bhavi) wrote :

I ve notified the debian maintainer about the FTBFS

waiting for a reply from him

Regards

Benjamin Drung (bdrung) wrote :

According to the log it looks like an issue with gtkmm 2.19 (more specific: 1:2.19.2-0ubuntu1).

Ilya Barygin (randomaction) wrote :

It's trivial to fix. The patch works with older gtkmm as well so should be upstreamed.

Bhavani Shankar (bhavi) wrote :

Thanks Ilya

will convert it to a diff

Regards

Bhavani Shankar (bhavi) wrote :
Changed in gbgoffice (Ubuntu):
status: Incomplete → Confirmed
Murray Cumming (murrayc) wrote :

Yes, this was a small API change (changing the return type) of get_action_area(), because Maemo's version of GTK+ started returning a VButtonBox, so we needed to make it more general. It's not an ABI break.

Changed in gbgoffice (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Uploaded: thanks for your work, both of you :-)

I've updated the changelog entry to make clear the modified files and keep the previous changelog entry.

Thanks,
Fabrice

Changed in gbgoffice (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gbgoffice - 1.4-5ubuntu1

---------------
gbgoffice (1.4-5ubuntu1) lucid; urgency=low

  * Merge with debian testing (LP: #503789): No remaining changes
  * 09_gtkmm2.19.patch: Fix Invalid conversion error and hence FTBFS. Thanks to
    Ilya Barygin for the patch.
 -- Bhavani Shankar <email address hidden> Thu, 07 Jan 2010 22:27:15 +0530

Changed in gbgoffice (Ubuntu):
status: Fix Committed → Fix Released
summary: - Please sync gbgoffice 1.4-5 (universe) from Debian unstable (main).
+ Please merge gbgoffice 1.4-5 (universe) from Debian unstable (main).
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers