overwrites files in libfam0

Bug #15256 reported by Eduard Bloch
8
Affects Status Importance Assigned to Milestone
gamin (Debian)
Fix Released
Unknown
gamin (Ubuntu)
Medium
Adam Conrad

Bug Description

Unpacking libgamin0 (from .../libgamin0_0.0.26-0ubuntu3_i386.deb) ...
dpkg: error processing
/var/cache/apt/archives/libgamin0_0.0.26-0ubuntu3_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libfam.so.0.0.0', which is also in package libfam0
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgamin0_0.0.26-0ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The usual FOE with:
ii libfam0 2.6.6.1-5.2
                  client library to control the FAM daemon

Revision history for this message
In , Adam Conrad (adconrad) wrote : tries to overwrite files in libfam0 when upgrading from woody

Package: libgamin0
Version: 0.0.26-1
Severity: serious

libgamin0 currently "Replaces: libfam0c102", but doesn't replace libfam0,
despite the fact that libfam0 shipped with woody and has conflicting
files.

See: https://bugzilla.ubuntu.com/show_bug.cgi?id=8946

... Adam

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11.10
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages libgamin0 depends on:
pn gamin Not found.
ii libc6 2.3.2.ds1-22 GNU C Library: Shared libraries an

Revision history for this message
In , Sjoerd Simons (sjoerd) wrote : Bug#311000: fixed in gamin 0.1.0-1

Source: gamin
Source-Version: 0.1.0-1

We believe that the bug you reported is fixed in the latest version of
gamin, which is due to be installed in the Debian FTP archive:

gamin_0.1.0-1.diff.gz
  to pool/main/g/gamin/gamin_0.1.0-1.diff.gz
gamin_0.1.0-1.dsc
  to pool/main/g/gamin/gamin_0.1.0-1.dsc
gamin_0.1.0-1_powerpc.deb
  to pool/main/g/gamin/gamin_0.1.0-1_powerpc.deb
gamin_0.1.0.orig.tar.gz
  to pool/main/g/gamin/gamin_0.1.0.orig.tar.gz
libgamin-dev_0.1.0-1_powerpc.deb
  to pool/main/g/gamin/libgamin-dev_0.1.0-1_powerpc.deb
libgamin0_0.1.0-1_powerpc.deb
  to pool/main/g/gamin/libgamin0_0.1.0-1_powerpc.deb
python2.3-gamin_0.1.0-1_powerpc.deb
  to pool/main/g/gamin/python2.3-gamin_0.1.0-1_powerpc.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sjoerd Simons <email address hidden> (supplier of updated gamin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 7 Jun 2005 00:27:11 +0200
Source: gamin
Binary: gamin python2.3-gamin libgamin0 libgamin-dev
Architecture: source powerpc
Version: 0.1.0-1
Distribution: unstable
Urgency: low
Maintainer: Debian GNOME Maintainers <email address hidden>
Changed-By: Sjoerd Simons <email address hidden>
Description:
 gamin - File and directory monitoring system
 libgamin-dev - Development files for the gamin client library
 libgamin0 - Client library for the gamin file and directory monitoring system
 python2.3-gamin - Python binding for the gamin client library
Closes: 311000 312250
Changes:
 gamin (0.1.0-1) unstable; urgency=low
 .
   * New upstream release
   * Also Provide/Replace and Conflict with libfam0, just like libfam0c102
     does. (Closes: #311000)
   * Use DEB_CONFIGURE_SCRIPT_ENV += instead of := (Thanks to Michael Bank for
     catching this) (Closes: #312250)
   * debian/patches/01_no_auto_deregister.patch
     + Removed. Can't reproduce the problem anymore with the new upstream
       release.
Files:
 6182fcf93fd38029f4d36b47ca7fa129 1508 admin optional gamin_0.1.0-1.dsc
 282f34278af3367150e163136382d22d 498055 admin optional gamin_0.1.0.orig.tar.gz
 21a3612c331027feb556c3f564e9a142 2782 admin optional gamin_0.1.0-1.diff.gz
 17ca62e0c7c4e45fbabc8b6d16f3e8f3 39990 admin optional gamin_0.1.0-1_powerpc.deb
 7202a67c2d25cba038bee808a9e4dd75 27926 libs optional libgamin0_0.1.0-1_powerpc.deb
 7da1dd4b896a1de9a70d397151e0fc68 46222 libdevel optional libgamin-dev_0.1.0-1_powerpc.deb
 f43287d5dfbd29d3ab735d19a691bcec 21366 python optional python2.3-gamin_0.1.0-1_powerpc.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFCpNCsgTd+SodosdIRAnWxAKC157HCgcvWvEFJO2Tir4UM8xq+JQCdEqYP
4Zg1NQxvP3IB11soO693QC8=
=I8nT
-----END PGP SIGNATURE-----

Revision history for this message
Adam Conrad (adconrad) wrote :

Fixed in breezy now that we've synced with Debian's 0.1.0 packages.

Changed in gamin:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.