Dependency not installed when installing gambas3

Bug #1876450 reported by suKo on 2020-05-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gambas3 (Ubuntu)
Undecided
Unassigned

Bug Description

Running 'sudo apt-get install gambas3' does not install all the packages required to run the program. It will not launch from the GUI, and when running it from the console the following error is reported:

gbr3: unable to load component: gb.form.print

The following package when installed fixes the error and allows gambas3 to launch: gambas3-gb-form-print

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I get the same error message when attempting to run gambas3 3.14.3-2ubuntu3.1 on Ubuntu 20.04 (or Groovy)

Looks like this might have been fixed in version of 3.14.3-3 the Debian package, so I suppose we are waiting for a sync/merge of that to Ubuntu. See https://tracker.debian.org/media/packages/g/gambas3/changelog-3.14.3-3 for details.

tags: added: focal groovy packaging
Changed in gambas3 (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gambas3 - 3.14.3-4ubuntu1

---------------
gambas3 (3.14.3-4ubuntu1) groovy; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/patches/git_poppler_update.patch: update for new poppler
    - d/p/mysql8_my_bool.patch: fix build with mysql8

gambas3 (3.14.3-4) unstable; urgency=medium

  * Patch: nonverbose build
  * Move gb.desktop files to the right pkg
  * Move templates to gambas3-ide
  * Remove gbh3 from gambas3-runtime

gambas3 (3.14.3-3) unstable; urgency=medium

  * Add Debian CI pipelines
  * Update Standards-Version; no changes required
  * gambas3-gb-web-form is deprecated
  * Drop gambas3-gb-gtk and gambas3-gb-gtk-opengl (Closes: #947655)
  * Default dh_install
  * Remove David Paleino from Uploaders
  * Let gambas3-ide depend on gambas3-gb-form-print (LP: #1876450)
  * Move gb.desktop.gambas to the right package (LP: #1877042)
  * Fix watch file according to new GitLab URL

 -- Gianfranco Costamagna <email address hidden> Mon, 22 Jun 2020 13:18:17 +0200

Changed in gambas3 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers