Ubuntu

wrong package name "gambas2-gb-db-sqlite"

Reported by JGuardon on 2010-05-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gambas2 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by JGuardon
Nominated for Karmic by JGuardon
Nominated for Lucid by JGuardon
Nominated for Maverick by JGuardon

Bug Description

Binary package hint: gambas2-gb-db-sqlite

jesus@jesus:~$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

Package gambas2-gb-db-sqlite have a wrong name itself. It must be "gambas2-gb-db-sqlite3", as the author of Gambas2 confirms to us.

Correct package doesn't exists:

jesus@jesus:~$ apt-cache policy gambas2-gb-db-sqlite3
gambas2-gb-db-sqlite3:
  Instalados: (ninguno)
  Candidato: (ninguno)
  Tabla de versión:

Instead, the wrong package is there:

gambas2-gb-db-sqlite:
  Instalados: (ninguno)
  Candidato: 2.19.0-2
  Tabla de versión:
     2.19.0-2 0
        500 http://es.archive.ubuntu.com/ubuntu/ lucid/universe Packages

Let me include the conversation with the Gambas2 support, which is determinant to taking action on this report:

[quote]
Hi

Gambas2 SVN #2972, Ubuntu 10.04

I think this is an old bug, or perhaps a regression?

When a project which uses the gb.db.sqlite3 component, generated deb
packages (at least the Ubuntu ones) has a typo in such dependency in the
"control" file:

gambas2-gb-db-sqlite3 (>= 1.9.48), gambas2-gb-db-sqlite3 (<< 2.90)

Of course, when trying to install it fails because there is not such
package.

The correct name must be gambas2-gb-db-sqlite3, and it is not listed in
the repositories.

I don't know if other packages (tar, rpm, etc) are also affected.

Benoît, is there a chance to fix it?

Thanks in advance

------
> ouch old bug from the ubuntu staff... tell them
> >
Yes. The name of a package is "gambas2" followed by the name of the component,
the points being replaced by dashes.

So: gb.db.sqlite3 => gambas2-gb-db-sqlite3.

Without following that scheme, the IDE packager cannot work. The names must
match between the IDE and the package repository!

And, for once, everything is clearly documented at
http://gambasdoc.org/help/howto/package for packagers with a link on the wiki
main page. So I don't know why the Ubuntu packager made that mistake. Gambas
Ubuntu packages have never been correct until now, and you or another Ubuntu
user must report the bug.

Regards,

-- Benoît Minisini
[/quote]

(Benoît Minisini is the Gambas2 project leader)

Hope this clarifies the issue.

Best regards,

Jesus

Changed in gambas2 (Ubuntu):
status: New → Confirmed
Jussi (jussi-lahtinen-gmail) wrote :

Confirmed with Ubuntu 10.04 64bit.

I'm having this problem as well.

The developer of Gambas2 has confirmed that the fault lies with the package maintainer.

The package gambas2-gb-db-sqlite should be renamed to gambas2-gb-db-sqlite3 for compatibility purposes.

JGuardon (jguardon) wrote :

Today I managed to talk with the maintainer of Debian packages of
"Gambas" regarding the wrong package name of gambas-gb-db-sqlite3, which
is now finally settled for the latest version 2.21

http://ftp-master.debian.org/new/gambas2_2.21.0-1.html

We only have to wait until ftpmasters will upload to Debian repos.

So now, it needs to be upstreamed to the Ubuntu repositories.

Anyone?

Changed in gambas2 (Ubuntu):
status: Confirmed → In Progress

We just need Ubuntu to accept the changes downstream now.

gambas2 (2.21.0-1) unstable; urgency=low

  * New upstream release.
  * Rename binary package gambas2-gb-db-sqlite to gambas2-gb-db-sqlite3 for a
    better compatibility with the gambas2 ide packager.
  * Bumped standards version to 3.9.1, no changes required
 -- Bhavani Shankar <email address hidden> Mon, 26 Jul 2010 14:01:49 +0200

Changed in gambas2 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers