package gallery2 2.3-1ubuntu4 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1

Bug #660495 reported by Jim Ancona on 2010-10-14
120
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gallery2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gallery2

Occurred as part of the Ubuntu 10.10 upgrade

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: gallery2 2.3-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Oct 14 07:52:29 2010
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
SourcePackage: gallery2
Title: package gallery2 2.3-1ubuntu4 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1

Jim Ancona (jimancona) wrote :
tags: added: dist-upgrade
Changed in gallery2 (Ubuntu):
status: New → Confirmed
Alan Porter (alan.porter) wrote :
Download full text (3.6 KiB)

Upgraded my server from Lucid to Maverick. Encountered several small errors during the upgrade of gallery2, and was left with a pretty botched installation. I ended up installing gallery2 from a tarball, outside of the normal packaging process.

Details here. I usually run 'do-release-upgrade' from within a 'script' session -- highly recommended! These lines have line numbers from my script output log.

4786 Setting up apache2-mpm-prefork (2.2.16-1ubuntu3.1) ...
4787 * Starting web server apache2
   Warning: DocumentRoot [/usr/share/gallery2/] does>
4788 [ OK ]
4789 Setting up apache2 (2.2.16-1ubuntu3.1) ...

5013 Setting up gallery2 (2.3-1ubuntu6) ...
5014 ln: creating symbolic link `/usr/share/gallery2/lib/smarty': No such file or directory
5015 dpkg: error processing gallery2 (--configure):
5016 subprocess installed post-installation script returned error exit status 1

5253 Errors were encountered while processing:
5254 apticron (<-- my bad)
5255 gallery2

After the bulk of the upgrade was finished, I tried 'dpkg --configure -a' to see what I could fix with the gallery2 upgrade. Again, same problem:

5376 Setting up gallery2 (2.3-1ubuntu6) ...
5377 ln: creating symbolic link `/usr/share/gallery2/lib/smarty': No such file or directory
5378 dpkg: error processing gallery2 (--configure):
5379 subprocess installed post-installation script returned error exit status 1
5380 Errors were encountered while processing:
5381 gallery2

I saw that I was complaining about /usr/share/gallery2/lib/smarty and that /usr/share/gallery2 did not exist. So I did a 'mkdir -p /usr/share/gallery2/lib/smarty' and retried 'dpkg --configure -a'.

5418 Setting up gallery2 (2.3-1ubuntu6) ...
.... (curses dialog box asking to restart apache)
>> Configuring gallery2
>> Remember that in order to activate the new configuration,
>> apache2 has to be restarted. You can also restart apache2
>> by manually executing 'invoke-rc.d apache2 restart'.
5467 touch: cannot touch `/etc/gallery2/config.php': No such file or directory
5468 dpkg: error processing gallery2 (--configure):
5469 subprocess installed post-installation script returned error exit status 1
5470 Errors were encountered while processing:
5471 gallery2

OK, so it's looking for a config file. I did 'touch /etc/gallery2/config.php' and 'dpkg --configure -a'.

5477 Setting up gallery2 (2.3-1ubuntu6) ...
.... (curses dialog box asking for database credentials)
5574 Restarting web server apache2 ... waiting [ OK ]

I went to my gallery URL, and it showed me a fresh installation setup screen... I had no idea whether it knew about my existing photos or not.

I think at this stage, it had basically clobbered the existing installation with a brand new one.

--

I did some searching and found others that had this problem (http://ubuntuforums.org/showthread.php?t=1535034 and http://gallery.menalto.com/node/97041), along with some pretty strong-worded advice:

nivekiam> The Ubuntu maintainers apparently don't use, test, install or even
nivekiam> know of Gallery but still try to put it into their repository and screw
nivekiam> it up every damn time.
nivekiam>
nivekiam> apt-get remove gallery2
nivekiam>
niveki...

Read more...

Alan Porter (alan.porter) wrote :

This seems to be two separate issues: (1) the missing files/directories that needed to be mkdir'ed & touched before the upgrade would proceed (2) the somewhat destructive upgrade that orphaned all of my existing photos. They may be related, or not. #1 is an annoyance. But #2 is the one that drives me to install gallery manually, outside of the packaging process.

Alan

ops0603 (mike-perkins) wrote :

Alan, did you ever get this problem resolved with Gallery2 ? I just did an upgrade from 10.4 to 12.04, and sure enough, it blew away my existing photos (at least I think it has).

Just wondering what you did in the end to resolve, and if you can point me to the steps I need to follow to restore / recover ?

Cheers,
Mike

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers