[Edgy] Consistent Crash while query plugins with Java Script

Bug #58682 reported by Jeremy Austin-Bardo on 2006-09-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
galeon (Ubuntu)
Undecided
Unassigned

Bug Description

The root cause of the crashing is a google analytics script. This script is querying the installed plugins which is crashing galeon.

Galeon needs to gracefully handle these erorrs while querying the plugins and not crash. It is not the end of the world when plugins return with errors during this process.

Andy Price (andy-price) wrote :

Thanks for your bug report. I'm having difficulty reproducing it on edgy. Are you using any plugins which might be causing the problem (browse to "about:plugins")?

Also, if you start galeon from a terminal does it give any information about the crash? Do all the pages that cause the crash contain flash animations or have something else in common? Thanks

Changed in galeon:
status: Unconfirmed → Needs Info

There is no output on the command line... Even the about plugins page
crashes... so I cannot tell you. I know from attempting to browse with
Galeon on Edgy that I believe it is not plugin related, because it has
happened on pages that do not have plugins. My feeling leans toward a
crash caused by complex tables or something of that beast. Although some
tabled sites do work.... hmmmm.
Any other bugging hints??? I do believe my problems started after XUL
was updated though.

Please could you obtain a backtrace using the steps shown at https://wiki.ubuntu.com/Backtrace - this should help to narrow down where the bug is occuring.

Download full text (5.3 KiB)

I have attached the backtrace. This time it did not even get to display
the homepage.

GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) hanbdle sig33SIG33 pass nonstop noprint
Unrecognized or ambiguous flag word: "nonstop".
(gdb) handle SIG33 pass nostop noprint
Signal Stop Print Pass to program Description
SIG33 No No Yes Real-time event 33
(gdb) set pagination 0
(gdb) runb
Starting program: /usr/bin/galeon
[Thread debugging using libthread_db enabled]
[New Thread -1227721040 (LWP 17176)]
[New Thread -1246549072 (LWP 17197)]
[New Thread -1269003344 (LWP 17212)]
[New Thread -1277391952 (LWP 17213)]
[Thread -1277391952 (LWP 17213) exited]
[New Thread -1277391952 (LWP 17214)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1227721040 (LWP 17176)]
0xb6a810e3 in NSGetModule () from /usr/lib/firefox/components/libi18n.so
(gdb) backtrace
#0 0xb6a810e3 in NSGetModule () from /usr/lib/firefox/components/libi18n.so
#1 0xb66bec13 in NSGetModule () from /usr/lib/firefox/components/libgklayout.so
#2 0xb64e4f8f in NSGetModule () from /usr/lib/firefox/components/libgklayout.so
#3 0xb646e0eb in NSGetModule () from /usr/lib/firefox/components/libgklayout.so
#4 0xb6537453 in NSGetModule () from /usr/lib/firefox/components/libgklayout.so
#5 0xb6534e8a in NSGetModule () from /usr/lib/firefox/components/libgklayout.so
#6 0xb68eb3e3 in ?? () from /usr/lib/firefox/components/libhtmlpars.so
#7 0x08a53260 in ?? ()
#8 0x08a62a40 in ?? ()
#9 0xbfcd35e8 in ?? ()
#10 0xb68eb6a3 in ?? () from /usr/lib/firefox/components/libhtmlpars.so
#11 0xb693a53c in ?? () from /usr/lib/firefox/components/libhtmlpars.so
#12 0x08a60748 in ?? ()
#13 0xbfcd35e8 in ?? ()
#14 0xb68eb43c in ?? () from /usr/lib/firefox/components/libhtmlpars.so
#15 0x08a60588 in ?? ()
#16 0x08a62a40 in ?? ()
#17 0xbfcd3698 in ?? ()
#18 0xb6916dba in NSGetModule () from /usr/lib/firefox/components/libhtmlpars.so
Previous frame inner to this frame (corrupt stack?)
(gdb) gdthread apply alll backtrace

Thread 5 (Thread -1277391952 (LWP 17214)):
#0 0xb7e1c602 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0xb7e46303 in PRP_NakedNotify () from /usr/lib/libnspr4.so
#2 0xb7e47191 in PR_WaitCondVar () from /usr/lib/libnspr4.so
#3 0xb69bb5f5 in NSGetModule () from /usr/lib/firefox/components/libnecko.so
#4 0xb7e4d13d in PR_JoinThread () from /usr/lib/libnspr4.so
#5 0xb7e190fb in start_thread () from /lib/libpthread.so.0
#6 0x00000002 in ?? ()
#7 0x00000002 in ?? ()
#8 0x00000000 in ?? ()

Thread 3 (Thread -1269003344 (LWP 17212)):
#0 0xb7e1c602 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0xb7e46303 in PRP_NakedNotify () from /usr/lib/libnspr4.so
#2 0xb7e47191 i...

Read more...

A heads up galeon 2.0.1-3ubuntu1 still is has having the problem that parsing certain pages crash it.

Jeremy Austin-Bardo (ausimage) wrote :

I ran valgrind on galeon. It stalled on bring up a webpage for over a half-hour. I ended up halting the program. The output follows

Jeremy Austin-Bardo (ausimage) wrote :

I reran a backtrace on galeon after the recent package updates. It appears the same.

Andy Price (andy-price) wrote :

As galeon seems to use some firefox libraries, please could you install the firefox-dbg package and see if a new galeon backtrace gives more detail? Thanks.

Jeremy Austin-Bardo (ausimage) wrote :

Here is a new backtrace with firefox-dbg installed...

Jeremy Austin-Bardo (ausimage) wrote :

I just completed some web page surgery on a crashing page in Galeon on Edgy. The lines that crashed are....

<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
</script>
<script type="text/javascript">
_uacct = "XX-XXXXXX-X";
urchinTracker();
</script>

This is the first example I have found....

Jeremy Austin-Bardo (ausimage) wrote :

I want to mention that over the Oct 1 weekend after updates . I checked the status of the bug with galeon. It worked fine on Sunday when I tried with a known page with the script. BUT now today Monday Oct 2 after updates I tried the same and it is broken once more.

This goes to my feeling that this lib support issue and not Galeon perse. PLEASE check the lib interfaces for subtle variations from what was before.

Jeremy Austin-Bardo (ausimage) wrote :

this page is another one that crashes now.... https://www.google.com/analytics/home/

Jeremy Austin-Bardo (ausimage) wrote :

I am trying to triage this languishing issue without a full understanding, but batting in the dark. I understand that the google analytics script cycles through the installed plugins now. A suggestion was to disable compositing... I used `XLIB_SKIP_ARGB_VISUALS=1` and ran galeon from the command line... Attached is what happened...

Jeremy Austin-Bardo (ausimage) wrote :

I am digging into the cause of the galeon crash. The crash happens only on galeon. I ran epiphany from the command line on a page that crashes in galeon and got more details...

LoadPlugin: failed to initialize shared library /usr/lib/netscape/plugins-libc6/nsdejavu.so [/usr/lib/netscape/plugins-libc6/nsdejavu.so: undefined symbol: XtShellStrings]

description: updated
Jeremy Austin-Bardo (ausimage) wrote :

I am continuing testing and now gdb gives no real output except "Program exited with code 0377."

Do you still have this bug with the latest versions of Ubuntu ? Could you please also try with Epiphany which has now replaced Galeon (not developped anymore) ? Thank you.

Sorry for the lateness of this. The problem does not exist in Epiphany
and is why I switched. Yes, the issue still exists in Galeon...

On Fri, 2007-05-18 at 19:45 +0000, Jérôme Guelfucci wrote:
> Do you still have this bug with the latest versions of Ubuntu ? Could
> you please also try with Epiphany which has now replaced Galeon (not
> developped anymore) ? Thank you.
>

Ok I'm closing this bug because it doesn't it will get fixed one day, bug has been reported upstream 8 months ago and hasn't been answered yet, so I think we can say that Galeon will not get a fix for that, moreover you don't have this problem with its "successor".

Changed in galeon:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers