Ubuntu

System.DllNotFoundException: libgalago

Reported by Brian J. Murrell on 2008-01-25
40
Affects Status Importance Assigned to Milestone
galago-sharp (Debian)
Fix Released
Unknown
galago-sharp (Ubuntu)
Undecided
Thomas Ohms
Hardy
Undecided
Thomas Ohms
libgalago (Ubuntu)
Undecided
Thomas Ohms
Hardy
Undecided
Thomas Ohms

Bug Description

Binary package hint: beagle

Trying to run beagle-search on an up-to-date hardy system:

$ beagle-search
Debug: Done reading conf from /home/brian/.beagle/config/BeagleSearch.xml
Debug: Done reading conf from /etc/beagle/config-files/BeagleSearch.xml
Debug: Done reading conf from /home/brian/.beagle/config/Daemon.xml
Debug: Done reading conf from /etc/beagle/config-files/Daemon.xml
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.DllNotFoundException: libgalago
  at (wrapper managed-to-native) Galago.Global:galago_init (intptr,int)
  at Galago.Global.Init (System.String name, InitFlags flags) [0x00000]
  at Galago.Global.Init (System.String name) [0x00000]
  at Beagle.Util.GalagoTools.GetPresence (System.String service_id, System.String username) [0x00000]
  at Search.Tiles.IMLog.GetBuddyStatus () [0x00000]
  at Search.Tiles.IMLog.GetDetails () [0x00000]
  at Search.Tiles.Tile.get_Details () [0x00000]
  at Search.MainWindow.ShowInformation (Search.Tiles.Tile tile) [0x00000]
  at Search.GroupView.OnTileSelected (System.Object tile, System.EventArgs args) [0x00000]
  at Search.Tiles.Tile.OnFocusInEvent (Gdk.EventFocus f) [0x00000]
  at Gtk.Widget.focusinevent_cb (IntPtr widget, IntPtr evnt) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.focusinevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Widget.focusinevent_cb(IntPtr , IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.GrabFocus()
   at Search.Category.Select(Boolean focus, Boolean extended)
   at Search.GroupView.Finished(Boolean grabFocus)
   at Search.MainWindow.OnFinished(Beagle.FinishedResponse response)
   at Beagle.Query.OnFinished(Beagle.ResponseMessage r)
   at Beagle.RequestMessage.OnAsyncResponse(Beagle.ResponseMessage response)
   at Beagle.Transport+EventThrowingClosure.ThrowEvent()
   at GLib.Idle+IdleProxy.Handler()
   at GLib.Idle+IdleProxy.Handler()
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Search.MainWindow.Main(System.String[] args)

Sachin Garg (ascii79) wrote :

This is fixed in Debian .. Can it be ported to Hardy ..

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460751.

Vadim Peretokin (vperetokin) wrote :

What beagle version is the OP using? That debian bug report mentions 0.3.2, while here on the left the latest release is "0.3.3-1ubuntu1".

Download full text (6.2 KiB)

It was 0.3.2 when I tried. I can't say how it's behaving currently because beagled won't run:

20080226 15:26:00.1684 05068 Beagle INFO: Starting Beagle Daemon (version 0.3.3)
20080226 15:26:00.2056 05068 Beagle INFO: Running on Mono 1.2.6
20080226 15:26:00.2061 05068 Beagle INFO: Command Line: /usr/lib/beagle/BeagleDaemon.exe --bg

** (/usr/lib/beagle/BeagleDaemon.exe:5068): WARNING **: The following assembly referenced from /usr/lib/beagle/Filters/Filters.dll could not be loaded:
     Assembly: taglib-sharp (assemblyref_index=8)
     Version: 2.0.2.0
     Public Key: db62eba44689b5b0
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib/beagle/Filters).

** (/usr/lib/beagle/BeagleDaemon.exe:5068): WARNING **: Could not load file or assembly 'taglib-sharp, Version=2.0.2.0, Culture=neutral, PublicKeyToken=db62eba44689b5b0' or one of its dependencies.
Stacktrace:

  at (wrapper managed-to-native) System.MonoCustomAttrs.GetCustomAttributesInternal (System.Reflection.ICustomAttributeProvider,System.Type,bool) <0x00004>
  at (wrapper managed-to-native) System.MonoCustomAttrs.GetCustomAttributesInternal (System.Reflection.ICustomAttributeProvider,System.Type,bool) <0xffffffff>
  at System.MonoCustomAttrs.GetCustomAttributesBase (System.Reflection.ICustomAttributeProvider,System.Type) <0x0001e>
  at System.MonoCustomAttrs.GetCustomAttributes (System.Reflection.ICustomAttributeProvider,System.Type,bool) <0x0001d>
  at System.Reflection.Assembly.GetCustomAttributes (System.Type,bool) <0x00012>
  at System.Attribute.GetCustomAttribute (System.Reflection.Assembly,System.Type,bool) <0x00024>
  at System.Attribute.GetCustomAttribute (System.Reflection.Assembly,System.Type) <0x0000f>
  at Beagle.Util.ReflectionFu.GetTypesFromAssemblyAttribute (System.Reflection.Assembly,System.Type) <0x0004d>
  at Beagle.Daemon.QueryDriver.ReadKeywordMappings () <0x000c3>
  at Beagle.Daemon.QueryDriver.Start () <0x00180>
  at Beagle.Daemon.BeagleDaemon.StartupProcess () <0x0016b>
  at IdleProxy.Handler () <0x0002e>
  at (wrapper native-to-managed) IdleProxy.Handler () <0xffffffff>
  at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0x00004>
  at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0xffffffff>
  at GLib.MainLoop.Run () <0x0000d>
  at Beagle.Daemon.BeagleDaemon.DoMain (string[]) <0x00b71>
  at Beagle.Daemon.BeagleDaemon.Main (string[]) <0x00014>
  at (wrapper runtime-invoke) Beagle.Daemon.BeagleDaemon.runtime_invoke_void_string[] (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

 beagled [0x81aa596]
 beagled [0x808bd63]
 beagled [0x818d74a]
 [0xb7fd4440]
 beagled(mono_class_get_full+0x90) [0x812ce81]
 beagled [0x8118635]
 beagled [0x812aabb]
 beagled(mono_class_init+0x33f) [0x8129588]
 beagled [0x81c0d17]
 beagled [0x81c1082]
 beagled [0x81c0b8b]
 beagled(mono_reflection_type_from_name+0x62) [0x81c1305]
 beagled [0x81c19c5]
 beagled [0x81c1f33]
 beagled [0x81c2484]
 beagled [0x81c30ad]
 beagled(mono_reflection_get_custom_attrs_by_type+0x33) [0x81c3ecb]
 beagled [0x80c629a]
 [0xb67af897]...

Read more...

dBera (dbera-web) wrote :

About the taglib-sharp, it was reported in https://bugs.launchpad.net/ubuntu/+source/beagle/+bug/194608
Debian-0.3.3-2 might have fixed it, not sure.

Download full text (4.5 KiB)

On Tue, 2008-02-26 at 21:04 +0000, dBera wrote:
> About the taglib-sharp, it was reported in https://bugs.launchpad.net/ubuntu/+source/beagle/+bug/194608
> Debian-0.3.3-2 might have fixed it, not sure.

Ah, yes. Indeed. Installing libtaglib2.0-cil seems to have solved it.
I looked for a taglib package for Ubuntu but failed to see that.

Now back to the original problem, current Hardy still has this problem
with beagle 0.3.3-1ubuntu1:

  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.DllNotFoundException: libgalago
  at (wrapper managed-to-native) Galago.Global:galago_init (intptr,int)
  at Galago.Global.Init (System.String name, InitFlags flags) [0x00000]
  at Galago.Global.Init (System.String name) [0x00000]
  at Beagle.Util.GalagoTools.GetPresence (System.String service_id, System.String username) [0x00000]
  at Search.Tiles.IMLog.GetBuddyStatus () [0x00000]
  at Search.Tiles.IMLog.GetDetails () [0x00000]
  at Search.Tiles.Tile.get_Details () [0x00000]
  at Search.MainWindow.ShowInformation (Search.Tiles.Tile tile) [0x00000]
  at Search.GroupView.OnTileSelected (System.Object tile, System.EventArgs args) [0x00000]
  at Search.Tiles.Tile.OnFocusInEvent (Gdk.EventFocus f) [0x00000]
  at Gtk.Widget.focusinevent_cb (IntPtr widget, IntPtr evnt) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.focusinevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Widget.focusinevent_cb(IntPtr , IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.GrabFocus()
   at Search.Tiles.Tile.OnButtonPressEvent(Gdk.EventButton b)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Widget.buttonpressevent_cb(IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Search.MainWindow.Main(System.String[] args)

I'm also seeing from beagled:

20080226 16:24:55.4296 10477 Beagle WARN EX: Caught exception trying to execute Beagle.Daemon.DaemonInformationExecutor. Sending error response
20080226 16:24:55.4296 10477 Beagle WARN EX: System.InvalidOperationException: List has changed.
20080226 16:24:55.4296 10477 Beagle WARN EX: at System.Collections.ArrayList+SimpleEnumerator.MoveNext () [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.EvolutionMailQueryable.EvolutionMailQueryable.get_ProgressPercent () [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.LuceneQueryable.GetQueryableStatus () [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.Queryable.GetQueryableStatus () [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.QueryDriver+<>c__CompilerGenerated4.MoveNext () [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.DaemonInformationExecutor.Execute (Beagle.RequestMessage request) [0x00000]
20080226 16:24:55.4296 10477 Beagle WARN EX: at Beagle.Daemon.ConnectionHandler.HandleConnection (System.IO.Stream buffer_stream) [0x00000]
2008022...

Read more...

Jorge O. Castro (jorge) on 2008-02-26
Changed in beagle:
status: New → Confirmed
Changed in beagle:
status: Unknown → New
Jan Michael Ibanez (jmibanez) wrote :

It seems that the problem is in libgalago1.0-cil -- the package doesn't include the .installcligac needed, and so the package doesn't install into the GAC. The quick fix is to copy an existing .installcligac in /usr/share/cli-common/package.d, edit to point to the galago-sharp DLL, then run gac-package-install as root.

This bug should be moved to a the package libgalago1.0-cil.

dBera (dbera-web) wrote :

Moving the bug to galago-sharp since thats where the bug actually is.

Colin Watson (cjwatson) wrote :

If this is completely breaking beagle in Hardy, it seems worth dealing with for 8.04.1.

Changed in galago-sharp:
milestone: none → ubuntu-8.04.1
Chris Cheney (ccheney) wrote :

I haven't tested this myself but arstechnica mentioned this bug report specifically:

http://arstechnica.com/reviews/os/hardy-heron-review.ars/3

rafaelb (rafaelbco) wrote :

I'd like to confirm this bug. I'm running an up-to-date Debian Lenny/Testing. After doing a search using "beagle-search", when I click on a result item of type "IM conversation" (a conversation from Pidgin) I get the following error output:

Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.DllNotFoundException: libgalago
  at (wrapper managed-to-native) Galago.Global:galago_init (intptr,int)
  at Galago.Global.Init (System.String name, InitFlags flags) [0x00000]
  at Galago.Global.Init (System.String name) [0x00000]
  at Beagle.Util.GalagoTools.GetPresence (System.String service_id, System.String username) [0x00000]
  at Beagle.Search.Tiles.IMLog.GetBuddyStatus () [0x00000]
  at Beagle.Search.Tiles.IMLog.GetDetails () [0x00000]
  at Beagle.Search.Tiles.Tile.get_Details () [0x00000]
  at Beagle.Search.SearchWindow.ShowInformation (Beagle.Search.Tiles.Tile tile) [0x00000]
  at Beagle.Search.GroupView.OnTileSelected (System.Object tile, System.EventArgs args) [0x00000]
  at Beagle.Search.Tiles.Tile.OnFocusInEvent (Gdk.EventFocus f) [0x00000]
  at Gtk.Widget.focusinevent_cb (IntPtr widget, IntPtr evnt) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.focusinevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Widget.focusinevent_cb(IntPtr , IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.gtk_widget_grab_focus(IntPtr )
   at Gtk.Widget.GrabFocus()
   at Beagle.Search.Tiles.Tile.OnButtonPressEvent(Gdk.EventButton b)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Widget.buttonpressevent_cb(IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Beagle.Search.Driver.Main(System.String[] args)

Thomas Ohms (tohms) wrote :

I'll have a look on that!

Thomas Ohms (tohms) wrote :

Because bug is in galago-sharp changed package here.

Changed in galago-sharp:
assignee: nobody → launchpad-ohms-nm
status: Confirmed → In Progress
assignee: nobody → launchpad-ohms-nm
status: New → In Progress

Tested on clean and updated installation of Ubuntu 8.04 Hardy final
Used packages for testing:
- libavahi1.0-cil (0.6.19-1)
- libgalago3 (0.5.2-2)
- libgsf0.0-cil (0.8-1ubuntu1)
- libtaglib2.0 (2.0.3.0-1)
- beagle (0.3.3-2ubuntu1)
- mono-gmcs (1.2.6+dfsg-6ubuntu3)

using testfile.txt, double/right clicking and open file works

Thomas Ohms (tohms) wrote :

Seems it works for an updated, clean Hardy. What versions are you using (see mentioned packages in 1st test)?

Changed in libgalago:
status: In Progress → Incomplete
status: In Progress → Incomplete
dBera (dbera-web) wrote :

I didnt try but based on the above information, this problem will happen if you try to open a chat search result. Thats when libgalago is called. Also take a look at the duplicate bugs for more information.

Thomas Ohms (tohms) wrote :

Well, maybe I got something wrong here, because I am not that pidgin user. I've started a conversation for testing and let pidgin log everything. The logfile itself is a text file where I get the same result as with my testfile.txt
What exactly are you doing?

Thomas Ohms (tohms) wrote :

Okay, forget the comment above. Seems beagle needed a while to get the log into right category. Now I receive the same error and have something to work on :)

Changed in libgalago:
status: Incomplete → In Progress
status: Incomplete → In Progress
Thomas Ohms (tohms) wrote :

Just to let you all know: I'm getting forward. At least beagle-search is not crashing any more. There's just one more little bug and I guess I'm finished.

The bug in libgalago1.0-cil is fixed. I'm attaching a debdiff for the maintainers and either you can use this one or if you are not familiar with diffs and don't like to wait till package is upgraded you can use my PPA repository:

deb http://ppa.launchpad.net/tohms/ubuntu hardy main
deb-src http://ppa.launchpad.net/tohms/ubuntu hardy main

Greets,
Thomas

Changed in libgalago:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Thomas Ohms (tohms) on 2008-06-21
Changed in galago-sharp:
status: New → Fix Committed
assignee: nobody → tohms
Steve Langasek (vorlon) wrote :

Sebastien, would you have time to look at this patch today and see whether it's an appropriate fix for 8.04.1?

Sebastien Bacher (seb128) wrote :

thank you for your work there, the changes look alright, could you update the changelog entry to be a correct stable update though and mentions the bug number to close too? you might want to send the change to the debian bts too

Changed in galago-sharp:
assignee: tohms → nobody
status: Fix Committed → Unknown
Changed in galago-sharp:
status: Unknown → New
Thomas Ohms (tohms) wrote :

You mean with stable a version like 0.5.0-2.2? Should I add both bug numbers (debian/launchpad)? Sorry for this stupid question, but I am quite new to packaging.

Sebastien Bacher (seb128) wrote :

you can read https://wiki.ubuntu.com/StableReleaseUpdates to get details, the version is correct but you need to use hardy-proposed as upload target and close the launchpad bug number in the changelog, having a testcase on the bug would be nice too

Thomas Ohms (tohms) wrote :

Test Case:
- open Pidgin, run a chat and log everything.
- run beagle-search and search for "*"
- your logfile should be shown and now click on it (here the current version crashes)

Attached new debdiff (hope now it's ok!?)

Changed in libgalago:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Thomas Ohms (tohms) wrote :

by the way: why is there no nomination for Hardy?

Steve Langasek (vorlon) wrote :

if you mean, why is there no option to nominate the bug for hardy, it's because this was already done and the bug is being tracked as a hardy candidate.

Steve Langasek (vorlon) wrote :

Why has this bug been marked as 'fix released' for hardy? There has definitely not been an SRU of libgalago accepted into hardy that fixes this issue.

Changed in libgalago:
milestone: ubuntu-8.04.1 → ubuntu-8.04.2
status: Fix Released → In Progress
Thomas Ohms (tohms) wrote :

Sorry, but I only was following the instructions on the site Sebastien gave me. Maybe I misunderstood something, then please let me know!

I tested Thomas's last patch and it works here with latest up-to-date hardy.

Only caveat: metainformation for searchresults, which hung beagle-search previously, isn't filled in automatically and metainfo for a searchresult only appears after a click on the searchresult.

> Only caveat: metainformation for searchresults, which hung beagle-search
> previously, isn't filled in automatically and metainfo for a
> searchresult only appears after a click on the searchresult.

I think thats a known bug/feature of beagle-search - that the
information is only shown after clicking on the search result.

Thomas Ohms (tohms) on 2008-07-13
Changed in galago-sharp:
assignee: nobody → tohms
status: New → Fix Released
Changed in libgalago:
status: In Progress → Fix Committed
Changed in galago-sharp:
assignee: nobody → tohms
status: New → Fix Committed
Waldir Leoncio (wleoncio) wrote :

I just wanted to register that I got that problem fixed by following Diego Urrelo's tip (https://bugs.launchpad.net/ubuntu/+source/beagle/+bug/213477/comments/1).

marco.pizziol (marco-pizziol) wrote :

I confirm the problem in Ubuntu 8.04 AMD64.
The trick:

cd /usr/lib
sudo ln -s libgalago.so.3 libgalago.so

worked for me.

Steve Langasek (vorlon) wrote :

Now this bug is marked as 'fix committed' for hardy, but no packages have been uploaded to the hardy-proposed queue. Setting back to 'in progress'.

Thomas, do you have good packages that address this bug for Ubuntu 8.04? Do you need upload sponsorship for these?

Changed in libgalago:
status: Fix Committed → In Progress
Changed in galago-sharp:
status: Fix Committed → In Progress
Thomas Ohms (tohms) wrote :

Sure - I still have the package in my PPA. And yes - I would need sponsorship.

Steve Langasek (vorlon) wrote :

The packages in the PPA are for libgalago 0.5.0-2.1ubuntu1 (same as the patch isn this bug), whereas hardy currently has 0.5.2-2. This patch definitely doesn't apply cleanly to 0.5.2-2 - is it certain that it's still needed, and has anyone tested it against the final hardy version of libgalago?

The same version of libgalago is also present in intrepid and jaunty.

Steve Langasek (vorlon) wrote :

Correction; the PPA has libgalago 0.5.0-2.1ubuntu2 rather than -2.1ubuntu1. In any case, the package in the PPA differs from the diff provided in https://bugs.launchpad.net/ubuntu/hardy/+source/libgalago/+bug/186049/comments/24, so I have no diff on which to base an upload of a fixed 0.5.2 package.

It looks like both patched packages also add a galago-sharp.dll.config.in which is subsequently postprocessed by autoconf, but the postprocessing is a null op because the config.in doesn't contain any variables. It would be simpler if the patch created galago-sharp.dll.config directly and added

 dist_noinst_SCRIPTS = galago-sharp.dll.config

in libgalago/Makefile.am.

If you can provide a patch against 0.5.2-1, please do so and subscribe ubuntu-universe-sponsors to this bug afterwards.

Steve Langasek (vorlon) wrote :

Correction; the PPA has libgalago 0.5.0-2.1ubuntu2 rather than -2.1ubuntu1. In any case, the package in the PPA differs from the diff provided in https://bugs.launchpad.net/ubuntu/hardy/+source/libgalago/+bug/186049/comments/24, so I have no diff on which to base an upload of a fixed 0.5.2 package.

It looks like both patched packages also add a galago-sharp.dll.config.in which is subsequently postprocessed by autoconf, but the postprocessing is a null op because the config.in doesn't contain any variables. It would be simpler if the patch created galago-sharp.dll.config directly and added

 dist_noinst_SCRIPTS = galago-sharp.dll.config

in libgalago/Makefile.am.

If you can provide a patch against 0.5.2-2, please do so and subscribe ubuntu-universe-sponsors to this bug afterwards.

Changed in libgalago:
milestone: ubuntu-8.04.2 → none
status: In Progress → Triaged
Steve Langasek (vorlon) on 2009-01-26
Changed in libgalago:
status: Fix Released → Triaged
Thomas Ohms (tohms) wrote :

Now I'm a bit confused. As you can see in the patch https://bugs.launchpad.net/ubuntu/hardy/+source/libgalago/+bug/186049/comments/24 there is data in the galago-sharp.dll.config.in:

only in patch2:
unchanged:
--- galago-sharp-0.5.0.orig/galago/galago-sharp.dll.config.in
+++ galago-sharp-0.5.0/galago/galago-sharp.dll.config.in
@@ -0,0 +1,3 @@
+<configuration>
+ <dllmap dll="libgalago" target="libgalago.so.3"/>
+</configuration>

Changed in galago-sharp:
status: New → Fix Released
Thomas Ohms (tohms) wrote :

Can anyone confirm released fix? I cannot try as I don't have any Hardy system anymore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.