[lucid] icon in status bar not correctly transparent

Bug #545062 reported by Valentin on 2010-03-23
136
This bug affects 28 people
Affects Status Importance Assigned to Milestone
gajim (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
gnome-python-extras (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: gajim

As you can see in the screenshot included, transparency fails in the notification var (Lucid Beta 1)

gajim:
  Installé : 0.13-0ubuntu2

Description: Ubuntu lucid (development branch)
Release: 10.04

Valentin (vsurrel) wrote :
Andreas Modinos (blueturtl) wrote :

Does not appear to happen in Karmic, so marking as a potential regression

tags: added: lucid regression-potential
Changed in gajim (Ubuntu):
status: New → Confirmed
Changed in gajim (Ubuntu):
status: Confirmed → New
Dmitry Tantsur (divius) wrote :

Andreas Modinos, it was valid under Karmic and afaik even under Jaunty.

Rush Tonop Online (rush-online) wrote :

Seems like bug is not in gajjim itself, but is in python-eggtrayicon package, is not it ?

Rush Tonop Online (rush-online) wrote :

Sorry, I've pressed enter before ending.

If you run python-eggtrayicon example, you wil see the same effect as in gajim:

$ python /usr/share/doc/python-eggtrayicon/examples/trayicon.py

Dmitry Tantsur (divius) wrote :

You're right!

Dmitry Tantsur (divius) wrote :

I have a workaround (dpatch). It enables GtkStatusIcon frontend. Transparency is ok, bug the will be some regression with tooltips and possibly with animation.

Dmitry Tantsur (divius) wrote :

Forgot to say: it's a workaround for Gajim.

Dmitry Tantsur (divius) wrote :

I don't have any regressions with this patch.

Дима, выложи пожалуйста пакет в ppa, он всё равно у тебя есть. Если хочешь - я выложу.

Divus, please put package with your patch to ppa. If you want I'll made it for you.

Dmitry Tantsur (divius) wrote :

Rush, уже в процессе, пока собирается.

I have created a package with this patch and update to 0.13.4.
Changelog for 0.13->0.13.4:

Что нового по сравнению с 0.13.3:
Fix some TLS connection
Don't raise a lot of "DB Error" dialog
Fix contact synchronisation
Add japanese translation
Minor fixes

Выпущена версия Gajim 0.13.3.
Что нового по сравнению с 0.13.2:
Fix facebook xmpp server connection
Fix copy / paste with Ctrl+C on non-latin keyboard
Fix sending PEP information when connecting
Fix parsing HTML messages that have ascii markup

Выпущена версия Gajim 0.13.2.
Что нового по сравнению с 0.13.1:
Fix some translations
Fix string comparison according to locales
Fix some gnomekeyring glitches
Copy emoticons when we copy / paste in conversations

Выпущена версия Gajim 0.13.1.
Что нового по сравнению с 0.13:
Fix a bug when no account exists and bonjour is not available
Fix a bug when opening advanced option in MUC
Fix a bug when using non-BOSH proxies

The "copy / paste" fix is VERY important for Russian users! Is there any chance that FE will be granted?

My package builds:
https://launchpad.net/~divius/+archive/ppa/+build/1704130
https://launchpad.net/~divius/+archive/ppa/+build/1704129

Dmitry Tantsur (divius) wrote :

All packages are ready. Please, grant FFE.

Package is in my ppa: https://launchpad.net/~divius/+archive/ppa/+packages

Dmitry Tantsur (divius) wrote :

Damn, it needs one more fix!

Dmitry Tantsur (divius) wrote :

Better fix, updated packages are being built

Dmitry Tantsur (divius) wrote :

Hell, sent wrong file!!!

Divius, please stop rush and remove deprecated patches. А то уже можно запутаться накуй.

Dmitry Tantsur (divius) wrote :

Done. BTW, new packages are ready!

Andreas Modinos (blueturtl) wrote :

Divius,

I have one machine running Karmic that uses the English language settings and another that runs Lucid in Finnish language and locale settings.
In Karmic, I don't get the problem. In Lucid I get the problem in regardless which locale or language I select.

Dmitry Tantsur (divius) wrote :

Andreas, It's very strange becuase in Gajim hasn't changed that much since Karmic. But I no longer have Karmic machine so I can't be sure.

Gajim tray icon from Divius PPA look transparent, good job dude !

Jonathan Michalon (johndescs) wrote :

I'm experiencing the bug since jaunty too (I think), and with karmic for sure. As it seems to be a fix here, why is all this stalled? In addition it is strange that lucid had been shipped with 0.13 as 0.13.3 is available in testing for a while now.
A bug report is even opened here: https://bugs.launchpad.net/ubuntu/+source/gajim/+bug/506049
May this be a target to ubuntu 10.04.1 ?

Steve Langasek (vorlon) wrote :

To target this to 10.04.1, please follow the process described at <https://wiki.ubuntu.com/StableReleaseUpdates#Procedure>.

Jonathan Michalon (johndescs) wrote :

Hum. I thought 10.04.1 was a "normal" update of 10.04, so not as "unusual and not-clean" as updating a software in a stable release. I re-read this bug description and the fix seems not trivial... so if I understand correctly, the "please merge" is the right way of making the fact known. Sorry for the noise, then...

Ilya Konyakhin (ilyakon) wrote :

Confirm this bug on my two stations (desktop&laptop). It appears only ubuntu 10.04. In all previous ubuntu distros with gajim worked flawless.
And so Divius's PPA fixed this issue.

Sebastien Bacher (seb128) wrote :

could be the similar to bug #545062

Changed in gnome-python-extras (Ubuntu):
importance: Undecided → Low

I have switched to lucid-default empaty. Seems it is only way to resolve this bug in current (lucid, 3y support!) and future releases. Sad but true.

Timo Reimerdes (timorei) wrote :

The package "gajim_0.13.4-0divius2~lucid0_i386" by divius fixes the background issues in lucid. However it will get overwritten by an upgrade if not kept explicitly.

Works like a charm for me, though. Thanks Divius.

Should be merged, if no severe problems found, imho.

Timo Reimerdes (timorei) wrote :

I have to correct myself - it will not be overwritten by the lucid repositories version, only by the one from the gajim ppa, wich I had in my sources because this error was supposedly fixed.

Seeing as this might be originating in the python part for notifications... might be taking a look at the code.

Not quite shure where to start. Any pointers?

Dmitry Tantsur (divius) wrote :

Timo, upstream developers claim that the error will be fixed in 0.14.

Timo Reimerdes (timorei) wrote :

I had the packages from the gajim ppa installed. It was not fixed in these packages. (so they are .13.4 if I recall correctly).

https://launchpad.net/~gajim/+archive/gajim-ppa

I will wait and see and for now I appreciate your work, bringing me / us a working gajim notification that looks as smooth as the desktop deserves. ;)

C de-Avillez (hggdh2) on 2010-08-26
tags: added: regression-release
removed: regression-potential
Dmitry Tantsur (divius) wrote :

Creating package for Maverick...

Changed in gajim (Ubuntu):
importance: Undecided → Low
Andreas Baumgartner (abaumg) wrote :

The issue is fixed in upstream 0.14, which you can get from the official Gajim PPA: https://launchpad.net/~gajim/+archive/gajim-ppa/+packages

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gajim (Ubuntu):
status: New → Confirmed
Changed in gnome-python-extras (Ubuntu):
status: New → Confirmed
Daniel (wurstsalat3000) on 2019-07-08
Changed in gajim (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-python-extras (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments