[jaunty] Use indicator-applet for new messages

Bug #340213 reported by Tomasz Dominikowski on 2009-03-09
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gajim
Fix Released
Unknown
NULL Project
Undecided
Unassigned
gajim (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gajim

Since Gajim has been fixed to utilize the new actionless notifications of Ubuntu one cannot just click on the notification bubble when a message is received to open it up. One needs to click the notification area icon to open up the roster window, find the person who sent the messege on the roster and click that contact to read the message.

Please integrate indicator-applet so that it can be used to open up new messages from gajim.

Related branches

Ted Gould (ted) wrote :

Removing indicator-applet as there is nothing that needs to be done in the applet to implement this.

Changed in gajim:
status: Unknown → New
Ken VanDine (ken-vandine) wrote :

I already have a patch for this, will submit it once indicate-python is actually uploaded.

Changed in gajim (Ubuntu):
assignee: nobody → ken-vandine
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Patch submitted upstream

http://trac.gajim.org/ticket/4942

Ken VanDine (ken-vandine) wrote :

Attached debdiff

Changed in gajim (Ubuntu):
status: Confirmed → In Progress
Changed in gajim (Ubuntu):
assignee: ken-vandine → nafallo
importance: Undecided → Wishlist
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gajim - 0.12.1-0ubuntu3

---------------
gajim (0.12.1-0ubuntu3) jaunty; urgency=low

  [ Ken VanDine ]
  * debian/patches/patches/add-indicator-support.patch:
    - Add support for the message indicator (LP: #340213)
  * debian/control:
    - Added a Recommends for indicate-python, to take advantage of
      the message indicator patch

  [ Nafallo Bjälevik ]
  * Convert all other patches to dpatches as well:
    - notify-osd.patch from James Westby
    - ubuntu-keyring.patch from Nafallo Bjälevik
  * debian/control:
    - Rework the package relations between Depends,
      Recommends and Suggestions a bit (LP: #348793)
  * debian/patches/config-write-sync.patch:
    - Make the explicit configuration file removal
      only happen on Windows. Thanks Jamin W. Collins.
      (LP: #349661)

 -- Nafallo Bjaelevik <email address hidden> Thu, 02 Apr 2009 16:15:05 +0100

Changed in gajim (Ubuntu):
status: Fix Committed → Fix Released
Florian Zeitz (florian-zeitz) wrote :

FWIW: I don't think this is really fixed already, because it depends on #344936. And as discussion in that Bug report indicates the Recommends filed should say python-indicate and not indicate-python.

Nafallo Bjälevik (nafallo) wrote :

Good catch Florian. Re-opened and being pushed to Bazaar now.

Changed in gajim (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gajim - 0.12.1-0ubuntu4

---------------
gajim (0.12.1-0ubuntu4) jaunty; urgency=low

  * debian/control:
    - Change the binary package name from indicate-python
      to python-indicate (LP: #340213)

 -- Nafallo Bjaelevik <email address hidden> Fri, 03 Apr 2009 13:20:42 +0100

Changed in gajim (Ubuntu):
status: Fix Committed → Fix Released
Nafallo Bjälevik (nafallo) wrote :

The current patch does seems to break with libindicate 0.1.5. We will need to find out why and fix it.

Changed in gajim (Ubuntu):
assignee: Nafallo Bjälevik (nafallo) → Ken VanDine (ken-vandine)
status: Fix Released → Incomplete
status: Incomplete → Confirmed
Changed in gajim:
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Unsubscribing UUS as there does not appear to be anything that needs sponsoring right now.

So, this still doesn't work. Any progress?

wiz (wiz) wrote :

It does appear in applet, but messages aren't shown.

wiz (wiz) wrote :

Noticed that notifications actually appear - for a while and instantly blinking off, leaving gajim part indicator-applet empty of new messages.

Dmitry Tantsur (divius) wrote :

Still no progress. Gajim itself is shown in the indicator menu, new messages aren't.

William Grant (wgrant) on 2009-07-23
Changed in null:
status: New → Invalid
Changed in gajim (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Nigel Babu (nigelbabu) on 2010-08-25
tags: added: patch-forwarded-upstream
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.