Gajim freezes whole system on start

Bug #1452006 reported by Lesik on 2015-05-05
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gajim (Ubuntu)
Undecided
Unassigned

Bug Description

I could reproduce this on Ubuntu 15.04 and Ubuntu MATE 15.04, so the bug is independent of desktop environment.
I first experienced this bug on Ubuntu MATE, then did a fresh reinstall of Ubuntu (Unity), which worked fine until I installed Gajim again.
If Gajim is installed, then run, it freezes the entire system. You are not able to move the mouse cursor or change to TTY. A hard reboot is necessary, but after logging in again, the system freezes again. I presume this is because Gajim is autostarted on login, but I am not sure.
Expected result: Gajim starts fine, like it does on Debian Jessie for example.
One could switch to TTY before logging in with LightDM, but since I've done multiple reinstalls to find out what package is causing this bug, I can also say that sometimes, you are not even able to login via TTY. You type in your username and password, and it kicks you back out and asks for username again. So uninstalling Gajim is unpossible, maybe through chroot, otherwise a complete reinstall is required.
Gajim is v0.16-1 according to apt.

Please tell me if I can provide more system information or any debug information to solve this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gajim (Ubuntu):
status: New → Confirmed

Same here, since upgrade to 15.04. I dont have Gajim autostarted but everytime i start it manually, the system freeze as described by Lesik.
I'm using Cinnamon.so it seems to confirm its not related to desktop env.

Download full text (4.7 KiB)

It trigger a kernel oops:
Note the: "CPU: 0 PID: 2354 Comm: gajim Tainted: P OE 3.19.0-16-generic #16-Ubuntu"

May 7 10:50:40 Laptop-cm kernel: [ 28.446592] BUG: unable to handle kernel NULL pointer dereference at 0000000000000293
May 7 10:50:40 Laptop-cm kernel: [ 28.447134] IP: [<ffffffff817c6ef8>] __down+0x48/0xe0
May 7 10:50:40 Laptop-cm kernel: [ 28.447677] PGD 1ee073067 PUD 1ee033067 PMD 0▓
May 7 10:50:40 Laptop-cm kernel: [ 28.448241] Oops: 0002 [#1] SMP▓
May 7 10:50:40 Laptop-cm kernel: [ 28.448765] Modules linked in: ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 pci_stub nf_defrag_ipv4 vboxpci(OE) vboxnetadp(OE) nf_nat_ipv4 vboxnetflt(OE) nf_nat nf_conntrack ip_tables x_tables vboxdrv(OE) binfmt_misc rfcomm bnep nls_iso8859_1 dell_wmi sparse_keymap dell_laptop snd_hda_codec_hdmi dcdbas snd_hda_codec_idt snd_hda_codec_generic i8k intel_rapl iosf_mbi x86_pkg_temp_thermal intel_powerclamp kvm_intel kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd wl(POE) snd_hda_intel snd_hda_controller snd_hda_codec snd_hwdep snd_pcm btusb bluetooth snd_seq_midi snd_seq_midi_event snd_rawmidi joydev snd_seq serio_raw snd_seq_device cfg80211 snd_timer hid_logitech_hidpp lpc_ich i915 snd soundcore shpchp mei_me drm_kms_helper mei drm i2c_algo_bit wmi 8250_fintek dell_smo8800 video mac_hid coretemp parport_pc ppdev lp parport autofs4 hid_logitech_dj usbhid hid psmouse e1000e ahci sdhci_pci libahci sdhci ptp pps_core
May 7 10:50:40 Laptop-cm kernel: [ 28.453288] CPU: 0 PID: 2354 Comm: gajim Tainted: P OE 3.19.0-16-generic #16-Ubuntu
May 7 10:50:40 Laptop-cm kernel: [ 28.453976] Hardware name: Dell Inc. Latitude E6330/030XCG, BIOS A10 05/20/2013
May 7 10:50:40 Laptop-cm kernel: [ 28.454674] task: ffff880211793110 ti: ffff880211744000 task.ti: ffff880211744000
May 7 10:50:40 Laptop-cm kernel: [ 28.455377] RIP: 0010:[<ffffffff817c6ef8>] [<ffffffff817c6ef8>] __down+0x48/0xe0
May 7 10:50:40 Laptop-cm kernel: [ 28.456082] RSP: 0018:ffff880211747e18 EFLAGS: 00010086
May 7 10:50:40 Laptop-cm kernel: [ 28.456780] RAX: 0000000000000293 RBX: ffff880211747f78 RCX: ffff880211747f80
May 7 10:50:40 Laptop-cm kernel: [ 28.457510] RDX: ffff880211747e18 RSI: 0000000002b91754 RDI: ffff880211747f78
May 7 10:50:40 Laptop-cm kernel: [ 28.458221] RBP: ffff880211747e58 R08: ffff8800d3189900 R09: 0000000000000000
May 7 10:50:40 Laptop-cm kernel: [ 28.458934] R10: 0000000000000292 R11: 0000000000000293 R12: 7fffffffffffffff
May 7 10:50:40 Laptop-cm kernel: [ 28.459638] R13: ffff880211793110 R14: 0000000000000002 R15: 00000000026320a0
May 7 10:50:40 Laptop-cm kernel: [ 28.460339] FS: 00007f59a22ba700(0000) GS:ffff88021e200000(0000) knlGS:0000000000000000
May 7 10:50:40 Laptop-cm kernel: [ 28.461050] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
May 7 10:50:40 Laptop-cm kernel: [ 28.461786] CR2: 0000000000000293 CR3: 00000001ee076000 CR4: 00000000001407f0
May 7 10:50:40 Laptop-cm kernel: [ 28.462510] Stack:
May 7 10:50:40 Laptop-cm kernel: [ 28.463231] ffff880211747f80 0000000000000293 0000000011747e88...

Read more...

tristank (tristank) wrote :

I can confirm that my Ubuntu 15.04 installation freezes as well after starting gajim. I also tried the latest version 0.16.3 from source. Still freezes the system.

unrud (unrud) wrote :

Gajim tries to read all files in /proc, /proc/net and /proc/self to collect entropy for OpenSSL. (See function add_entropy_sources_OpenSSL() in file src/common/crypto.py)

This can cause problems with buggy drivers. (e.g. https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1450825 )

Jeremy Kessler (jeremy-kcsrnd) wrote :

I'm still having this issue in Linux Mint 18 x64 Cinnamon, Gajim 0.16.5 on an Acer Aspire V5-531.

Alexander Dietrich (adietrich) wrote :

I'm encountering this on Ubuntu 16.04.1 with the default Gajim package.

If there is information that could be helpful for the investigation, please tell me how to save it before the whole system crashes.

Simon Lutz (splutz) wrote :

Same problem over here after I upgraded to 16.04.01.

Alexander Dietrich (adietrich) wrote :

The bug linked by unrud (#5) seems to describe the cause (at least in my case). I was able to make Gajim start without freezing the system by removing read access to the /proc file:

sudo chmod o-r /proc/brcm_monitor0

Matthias Homann (palto) wrote :

Same problem on Acer One 722 running Ubuntu Mate 16.04
The workaround in #9 worked for me.

m.Wegener (martinmw12wegener) wrote :

Can confirm this, same problem here, Ubuntu 16.04.1 LTS.
Workaround, #9, did work for me too.

Valkoinen (valkoinen) wrote :

Same problem, Linux Mint 18.

Clément Février (clement) wrote :

Same here on Ubuntu 16.04.1 (fresh install) and I confirm as well that workaround #9 is solving the issue.

J E (ptwobenis) wrote :

Confirm on ubuntu 16.04 up to date, full system freeze requiring hard reboot. Can unonstall after reboot, however.

Levente Torok (toroklev) wrote :

Workaround, #9, did work for me too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers