"Tools>Filters" makes gaim crash

Bug #10490 reported by Marc REYNES
Affects Status Importance Assigned to Milestone
gaim (Ubuntu)
Sebastien Bacher

Bug Description


I'm using gaim with an msn account. When lauching the "Filter" account, gaim
just disappears.
I can't provide you with cores or such as nothing is dumped.
I tried to launch it with strace but everything goes smoothly and normally when

let me know what can i do to help you to investigate further this bug.


Revision history for this message
Sebastien Bacher (seb128) wrote :

no problem here. Could you get a backtrace ?
run gaim from a gnome-terminal:
$ gdb gaim
(gdb) run
... crash...
(gdb) thread apply all bt

Revision history for this message
Marc REYNES (marc-reynes) wrote :

Hi seb,
thanks for your reply,

here's the requested backtace :

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 1083716448 (LWP 3840)]
0x080e7d0f in gaim_gtk_privacy_is_showable ()
(gdb) thread apply all bt

Thread 1 (Thread 1083716448 (LWP 3840)):
#0 0x080e7d0f in gaim_gtk_privacy_is_showable ()
#1 0x080e7fa7 in gaim_gtk_privacy_dialog_show ()
#2 0x40230608 in gtk_item_factory_new () from /usr/lib/libgtk-x11-2.0.so.0
#3 0x405162d2 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#4 0x405037eb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#5 0x40515e02 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#6 0x40514e5c in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#7 0x40515140 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#8 0x40337dd7 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#9 0x40258a46 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x40257ecf in _gtk_menu_shell_activate () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x4025117f in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x40249a7e in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#13 0x40503b18 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#14 0x405037eb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#15 0x40515854 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#16 0x40514c3f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x40515140 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#18 0x40337c09 in gtk_widget_send_expose () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x4024823a in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x4024710a in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x4042f1ab in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#22 0x4055ba7d in g_main_depth () from /usr/lib/libglib-2.0.so.0
#23 0x4055caa8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0x4055cdca in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x4055d3a3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#26 0x40246a56 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x080f5c6f in main ()

Revision history for this message
Sebastien Bacher (seb128) wrote :

do you still get this crash ? what version of gaim are you using ?

Revision history for this message
Sebastien Bacher (seb128) wrote :

no reply, bug closed. Feel free to reopen if that's still an issue with the
current versions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.