g15daemon does not start (/dev/input/uinput not found)

Bug #570245 reported by Dmitry Maruschenko on 2010-04-26
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
g15daemon (Debian)
New
Unknown
g15daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: g15daemon

Ubuntu Version: Ubuntu 10.04 (Linux 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux), fresh install from daily snapshot iso.
Package version: g15daemon 1.9.5.3-8ubuntu

Daemon hangs up my system on startup (I see "ubuntu loading" logo, but nothing else happens), the only way to stop it is to boot into single mode and execute "update-rc.d -f g15daemon remove".

When trying to start daemon manually (sudo /etc/init.d/g15daemon start) I get a message "Starting g15daemon: .../dev/input/uinput not found ...".
/dev/input/uinput really not found =) But there is a /dev/uinput instead.

Dmitry Maruschenko (yojick) wrote :

Changing "/dev/input/uinput" to "/dev/uinput" in /etc/g15daemon.conf does not help: Starting g15daemon: .../dev/input/uinput not found ...

It seems that g15daemon does not read /etc/g15daemon.conf at all.

Martin Weißhaupt (mweisshaupt) wrote :

It seems that in the file /etc/init.d/g15daemon in lines 66 and 68 uinput is hard coded to "/dev/input/uinput".

After I replaced this I could start the g15daemon but my display-script could not write to the LCD, will have to investigate further...

description: updated
Joachim R. (jro) wrote :

Strange, the change you suggest remove the error message "/dev/input/uinput not found" but the extra G* keys doesn't work when hit. Instead, all action bound to every G* key is launched when stopping g15daemon.
Steps to reproduce :
 - apply the suggested change to /etc/init.d/g15daemon
 - stop - start g15daemon
 - hit a G* key bound to an action you know (me : G2 launches gnome-calculator
 - nothing happens
 - stop g15aemon : the action is launched (me: gnome-calculator appears)

guivho (guivho) wrote :

Editing /etc/init.d/g15daemon as suggested gets rid of the
'/dev/input/uinput not found' message. But unfortunately, none of the
G15 keys work. (As expected, not even after stopping the daemon).

These keys are fully dead. When launching xev, there is no event
whatsoever for any of these keys.

guivho (guivho) wrote :

The fact that these keys do not work after the correction in /etc/init.d/g15daemon is probably caused by the error described in Bug #538259

Changed in g15daemon (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in g15daemon (Ubuntu):
status: Triaged → Fix Released
Changed in g15daemon (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.