g15daemon doesn't start correctly at boot

Bug #1441365 reported by Roberto Leinardi on 2015-04-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
g15daemon (Ubuntu)
Medium
Unassigned

Bug Description

In Ubuntu 15:04 the clock in the LCD does not update and time remains to when the daemon is loaded. It worked correctly in previous versions of Ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: g15daemon 1.9.5.3-8.3ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-12.12-generic 3.19.3
Uname: Linux 3.19.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 7 23:29:36 2015
InstallationDate: Installed on 2015-03-28 (10 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
SourcePackage: g15daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Roberto Leinardi (leinardi) wrote :
toams (toams) wrote :

Same problem here. I think the daemon starts at boot, but immediately stops/crashes. The logs however do not show anything useful. starting the daemon manually solves this issue for me. Maybe systemd is to blame?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in g15daemon (Ubuntu):
status: New → Confirmed
Changed in g15daemon (Ubuntu):
importance: Undecided → Medium
toams (toams) wrote :

I removed de init.d script and created a g15daemon service file. i saved it in /lib/systemd/system and ran
"systemctl enable g15daemon.service". now g15daemon starts correctly at every boot.
I'm not sure what the correct way is to get these changes in ubuntu? and this should probably be changed upstream in debian?
the service file is based on one i found on google. (from arch if i remember correctly)

summary: - Clock doesn't update
+ g15daemon doesn't start correctly at boot
Roberto Leinardi (leinardi) wrote :

@toams Thanks, that fixed the problem :-)

Alexander Ponyatykh (lazyranma) wrote :

I've created a PPA with a new version of package that fixes a few bugs and has native systemd service unit for g15daemon. Please try it and tell if this fixes the problem.
https://launchpad.net/~lazyranma/+archive/ubuntu/g15daemon/

Thanks Alexander.
Your version fixed the problem on my computer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers