Does not stop/restart service when system sleeps

Bug #1357556 reported by Necrolyte2 on 2014-08-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
g15daemon (Ubuntu)
Low
Unassigned
libg15 (Ubuntu)
Low
Unassigned

Bug Description

Release Info
#> lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

Package Info
#> dpkg -l | grep g15daemon
ii g15daemon 1.9.5.3-8.2ubuntu3 amd64 Screen multiplexer for Logitech G15 Keyboard

Issue
G15 Keyboard daemon loses connectivity to the g15daemon after the system resumes from sleeping

Resolution:
Adding a /etc/pm/sleep.d rule such as
https://gist.github.com/rriemann/2947810
seems to fix the issue

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in g15daemon (Ubuntu):
status: New → Confirmed
Alexander Ponyatykh (lazyranma) wrote :

There are actually 3 different issues in g15daemon, libg15 and libusb (LP: #1455924) preventing correct recovery after suspend. Patch for libusb is available, and I'll post patches for libg15 and g15daemon soon.

Alexander Ponyatykh (lazyranma) wrote :

I've created a PPA with a new version of g15daemon, libg15 and libusb that fixes this bug. Feel free to use it.
https://launchpad.net/~lazyranma/+archive/ubuntu/g15daemon/

Martin Pitt (pitti) wrote :

Please forward the patches to upstream (http://sourceforge.net/projects/g15tools). Thanks!

Alexander Ponyatykh (lazyranma) wrote :

Upstream seems to be dead - last release was in 2007, and last commit was in 2011, but I've posted it anyway.
https://sourceforge.net/p/g15tools/patches/5/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libg15 - 1.2.7-2ubuntu2

---------------
libg15 (1.2.7-2ubuntu2) wily; urgency=medium

  * debian/patches/00-fix-reinit.patch: fixed re_initLibG15() to properly reset
    internal state, allowing g15daemon to continue working after keyboard was
    replugged and after suspend or hibernate. (LP: #1357556)

 -- Alexander Ponyatykh <email address hidden> Sun, 17 May 2015 21:35:48 +0300

Changed in libg15 (Ubuntu):
status: New → Fix Released
tags: added: trusty
no longer affects: libusb (Ubuntu)
Changed in g15daemon (Ubuntu):
importance: Undecided → Low
Changed in libg15 (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers