fwupd translations are missing from langpacks

Bug #1946347 reported by Pavel Borecki
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
langpack-o-matic
Fix Released
High
Sebastien Bacher
fwupd (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Hello,

if you compare list of files in Debian package:
https://packages.ubuntu.com/impish/amd64/fwupd/filelist

and in Ubuntu package:
https://packages.ubuntu.com/impish/amd64/fwupd/filelist

you will notice, that anything related to localization is missing, for example:

/usr/share/locale/af/LC_MESSAGES/fwupd.mo

it seems, that localization data are not part of any other fwupd related Ubuntu package, thus they are completely missing.

Would it be possible to bring localization (which exists for long time and is very complete in upstream) to packaging please?

Thanks

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fwupd (Ubuntu):
status: New → Confirmed
Revision history for this message
Mario Limonciello (superm1) wrote :
Changed in fwupd (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Pavel Borecki (pavel-borecki) wrote :

Thanks for pointing to this documentation, but if understood correctly, fwupd.mo should be part of lang-pack-* package(s), right?

But looking in (for example):

https://packages.ubuntu.com/impish/all/language-pack-cs-base/filelist
(language-pack-cs is empty package)

There is no such file as /usr/share/locale/cs/LC_MESSAGES/fwupd.mo

It seems, that translations are imported in Rosetta (Ubuntu translation system):
https://translations.launchpad.net/ubuntu/+source/fwupd,
but not part of build process of lang-pack-* packages.

In mentioned documentation
https://wiki.ubuntu.com/UbuntuDevelopment/Internationalisation/Packaging
there are no hints regarding meson build system (which upstream fwupd is using) - maybe problem with integration there?

In any case, would it be possible to look at it please? It is really unfortunate, that Ubuntu users are prevented to benefit from translations, which in situation, when firmware updates are offered to inexperienced (and non-English speakers) trough Gnome Software / KDE Discover and they don't understand instructions, they get (and possibly will brick their devices).
Thanks for all your work on lvfs infrastructure (and growing list of vendors/devices, you managed to onboard) and fwupd tools - greatly appreciated! - but missing localization (which is done) is the last thing remaining to perfection :-)

Changed in fwupd (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

FYI @seb128 asked on #launchpad about this, and I checked that the base language pack exported by Launchpad does contain .po files for fwupd, so it looks like this may be something that needs to be fixed in langpack-o-matic.

Revision history for this message
Mario Limonciello (superm1) wrote :

Thanks for the comments. Added a task for `langpack-o-matic`.

Changed in fwupd (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Sebastien Bacher (seb128) wrote :

I've found the issue and I'm going to propose a fix, we missed impish but it will be fixed for the LTS

Changed in langpack-o-matic:
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → High
status: New → In Progress
summary: - Translations are missing
+ fwupd translations are missing from langpacks
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue there is that the langpack category is determined by checking for keywords in the description/section/build-depends, gnome or gtk aren't mentioned but it build-depends on 'umockdev' which includes 'kde' and makes it sorted as a kde component. Those langpacks aren't built anymore so the template is simply ignore.

I've proposed a fix now
https://code.launchpad.net/~seb128/langpack-o-matic/fwupd-category-override/+merge/410545

As well as some extra logging that would have made clearer the issue there
https://code.launchpad.net/~seb128/langpack-o-matic/import-extra-log/+merge/410543

Revision history for this message
Sebastien Bacher (seb128) wrote :

it's fixed now and the current tarball export on https://translations.launchpad.net/ubuntu/jammy/+language-packs includes fwupd

Changed in langpack-o-matic:
status: In Progress → Fix Released
Revision history for this message
Pavel Borecki (pavel-borecki) wrote :

Great! Many thanks for fixing this :-)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers