Logitech K780 Firmware Update Fails

Bug #1740889 reported by Kenny Stier on 2018-01-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fwupd
Fix Released
Unknown
fwupd (Ubuntu)
Low
Unassigned

Bug Description

I initially tried to update the firmware of my Logitech K780 Wireless Keyboard via Gnome Software, and it acted like it was pushing the update, but then threw an error.

"Unable to update "Logitech K780 Multi-Device Wireless Keyboard" failed to write @0x10260: failed to get event after timeout"

So I turned my keyboard (which still wasn't working after the update failed and the LED was flashing green and red) off and back on and tried the update again. Only this time, it threw a different error. "no method to detach"

It did the same thing when running the fwupdmgr update command.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: fwupd 0.9.7-2
ProcVersionSignature: Ubuntu 4.13.0-21.24-generic 4.13.13
Uname: Linux 4.13.0-21-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Jan 2 10:20:20 2018
InstallationDate: Installed on 2017-12-28 (4 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/usr/bin/fish
SourcePackage: fwupd
UpgradeStatus: No upgrade log present (probably fresh install)

Kenny Stier (kestier19) wrote :
Mario Limonciello (superm1) wrote :

Thanks for filing. Would you mind filing this report upstream though? It's an upstream issue and should be debugged there: https://github.com/hughsie/fwupd/

Changed in fwupd (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in fwupd:
status: Unknown → New
Mario Limonciello (superm1) wrote :

Per upstream bug, they would like this checked on the 1.x.x release or master. Can you please try that?

Changed in fwupd (Ubuntu):
status: Triaged → Incomplete
Mario Limonciello (superm1) wrote :

A comment on the upstream bug indicates this is still a problem in Ubuntu 18.04 beta 2 which contains fwupd 1.0.6.

Changed in fwupd (Ubuntu):
status: Incomplete → Confirmed
Mario Limonciello (superm1) wrote :

The Logitech plugin was re-written in fwupd 1.1.2. can you please re-retry this again?

You can install a snap now to easily try:
1) apt remove fwupd
2) snap install fwupd --classic

Changed in fwupd (Ubuntu):
status: Confirmed → Incomplete
Changed in fwupd:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.