fwupd: Error message due to invalid AppStream file

Bug #1575248 reported by Wise Melon on 2016-04-26
304
This bug affects 65 people
Affects Status Importance Assigned to Milestone
fwupd (Debian)
Fix Released
Unknown
fwupd (Ubuntu)
Medium
Mario Limonciello
Xenial
High
Unassigned

Bug Description

[Impact]

 * Checks for apt updates using apt or apt-get also update the appstream cache. Some of the appstream metadata installed locally isn't strictly valid as it's missing two fields.

[Test Case]

 * fwupdmgr refresh
 * apt update
 * check for errors about metadata being ignored

[Regression Potential]

 * This is just changing the XML metadata locally, I don't see any regression potential.

[Other Info]

 * This fix has been applied upstream: https://github.com/hughsie/fwupd/commit/f4e0e88f7cba833a4badc1a3d62f1a08dd1bfd96

[Original report]

I have found that when there are new packages available which my machine doesn't know about yet, if I run "sudo apt-get update" this is the output:

    Get:1 http://gb.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
    Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease
    Get:3 http://gb.archive.ubuntu.com/ubuntu xenial-updates InRelease [82.2 kB]
    Get:4 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [28 B]
    Get:5 http://gb.archive.ubuntu.com/ubuntu xenial-backports InRelease [82.2 kB]
    Get:6 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [28 B]
    Get:7 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [28 B]
    Get:8 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [28 B]
    Get:9 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [28 B]
    Get:10 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [28 B]
    Get:11 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201 kB]
    Get:12 http://gb.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196 kB]
    Get:13 http://gb.archive.ubuntu.com/ubuntu xenial/main Translation-en_GB [426 kB]
    Get:14 http://gb.archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
    Get:15 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
    Get:16 http://gb.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
    Get:17 http://gb.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages [8,344 B]
    Get:18 http://gb.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages [8,684 B]
    Get:19 http://gb.archive.ubuntu.com/ubuntu xenial/restricted Translation-en_GB [2,556 B]
    Get:20 http://gb.archive.ubuntu.com/ubuntu xenial/restricted Translation-en [2,908 B]
    Get:21 http://gb.archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata [186 B]
    Get:22 http://gb.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7,532 kB]
    Get:23 http://gb.archive.ubuntu.com/ubuntu xenial/universe i386 Packages [7,512 kB]
    Get:24 http://gb.archive.ubuntu.com/ubuntu xenial/universe Translation-en_GB [3,040 kB]
    Get:25 http://gb.archive.ubuntu.com/ubuntu xenial/universe Translation-en [4,354 kB]
    Get:26 http://gb.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [3,410 kB]
    Get:27 http://gb.archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7,448 kB]
    Get:28 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [144 kB]
    Get:29 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [140 kB]
    Get:30 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en_GB [88.1 kB]
    Get:31 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en [106 kB]
    Get:32 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata [63.8 kB]
    Get:33 http://gb.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons [230 kB]
    Get:34 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [28 B]
    Get:35 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [28 B]
    Get:36 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [28 B]
    Get:37 http://gb.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [28 B]
    Get:38 http://gb.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [28 B]
    Get:39 http://gb.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [28 B]
    Get:40 http://gb.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [28 B]
    Get:41 http://gb.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [28 B]
    Get:42 http://gb.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [28 B]
    Get:43 http://gb.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [28 B]
    Get:44 http://gb.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [28 B]
    Get:45 http://gb.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [28 B]
    Get:46 http://gb.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [28 B]
    Get:47 http://gb.archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages [28 B]
    Get:48 http://gb.archive.ubuntu.com/ubuntu xenial-backports/main Translation-en [28 B]
    Get:49 http://gb.archive.ubuntu.com/ubuntu xenial-backports/restricted amd64 Packages [28 B]
    Get:50 http://gb.archive.ubuntu.com/ubuntu xenial-backports/restricted i386 Packages [28 B]
    Get:51 http://gb.archive.ubuntu.com/ubuntu xenial-backports/restricted Translation-en [28 B]
    Get:52 http://gb.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [28 B]
    Get:53 http://gb.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [28 B]
    Get:54 http://gb.archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [28 B]
    Get:55 http://gb.archive.ubuntu.com/ubuntu xenial-backports/multiverse amd64 Packages [28 B]
    Get:56 http://gb.archive.ubuntu.com/ubuntu xenial-backports/multiverse i386 Packages [28 B]
    Get:57 http://gb.archive.ubuntu.com/ubuntu xenial-backports/multiverse Translation-en [28 B]
    Fetched 39.0 MB in 7min 59s (81.3 kB/s)
    AppStream cache update completed, but some metadata was ignored due to errors.
    Reading package lists... Done

And when running "sudo appstreamcli refresh --force --verbose" the output is as follows:

    ** (appstreamcli:2227): DEBUG: Refreshing AppStream cache
    ** (appstreamcli:2227): DEBUG: Reading: /usr/share/app-info/xmls/org.freedesktop.fwupd.xml
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial_universe_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial_multiverse_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial_main_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial_restricted_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial-updates_restricted_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/gb.archive.ubuntu.com_ubuntu_dists_xenial-updates_multiverse_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/security.ubuntu.com_ubuntu_dists_xenial-security_main_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/security.ubuntu.com_ubuntu_dists_xenial-security_restricted_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/security.ubuntu.com_ubuntu_dists_xenial-security_universe_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/lib/app-info/yaml/security.ubuntu.com_ubuntu_dists_xenial-security_multiverse_dep11_Components-amd64.yml.gz
    ** (appstreamcli:2227): DEBUG: Reading: /var/cache/app-info/xmls/fwupd.xml
    ** (appstreamcli:2227): DEBUG: Detected colliding ids: plan.desktop was already added with the same priority.
    ** (appstreamcli:2227): DEBUG: Detected colliding ids: flcheckers.desktop was already added with the same priority.
    ** (appstreamcli:2227): DEBUG: Detected colliding ids: flblocks.desktop was already added with the same priority.
    ** (appstreamcli:2227): DEBUG: Detected colliding ids: flsudoku.desktop was already added with the same priority.
    ** (appstreamcli:2227): DEBUG: zathura-pdf-poppler.desktop extends zathura.desktop, but zathura.desktop was not found.
    ** (appstreamcli:2227): DEBUG: WARNING: Skipped component 'com.steelseries.rival-legacy.firmware': The component is invalid.
    ** (appstreamcli:2227): DEBUG: Removing old rebuild-dir from previous database rebuild.
    AppStream cache update completed, but some metadata was ignored due to errors.

I have found this to be present on all Ubuntu 16.04 flavours which I have tried, I have also been informed that this is likely to be a server-side issue. You can also see from this https://askubuntu.com/q/761884/364819 that many are experiencing it.

description: updated
Matthias Klumpp (ximion) wrote :

The AppStream component 'com.steelseries.rival-legacy.firmware' in `/usr/share/app-info/xmls/org.freedesktop.fwupd.xml` must have a <name/> and <summary/> tag to be valid.
Adding fwupd, because this should be fixed there. Upstream said he will commit a fix to fwupd tomorrow.

The ID collisions are issues in the metadata Ubuntu provides, and something which can only be fixed server-side, or basically in the packages providing:
 * plan.desktop
 * flcheckers.desktop
 * flblocks.desktop
 * flsudoku.desktop
If two packages providing the same .desktop file is justified, one should be ignored using X-AppStream-Ignore, so it is clear which one is the primary component to be used by AppStream.

The issue "zathura-pdf-poppler.desktop extends zathura.desktop, but zathura.desktop was not found." needs to be investigated, looks like there is some package/file missing in the archive, or a value isn't set correctly.

In any case, fixing the fwupd issue will make the warning message go away, so I'm marking this as invalid on AppStream for now.

Changed in appstream (Ubuntu):
status: New → Invalid
Matthias Klumpp (ximion) wrote :

Btw, the linked Debian bug is valid, because it complains about not being able to take action on this message, which is something that could be improved.
But since this will usually highlight issues which can only be fixed server-side, this message is primarily for distributors and PPA-maintainers, to know that something is wrong and needs fixing (details are show in verbose mode, because the issues can be plenty - see the Debian bug report for that).

I have marked this bug as 'Confirmed' due to the fact that I have spoken to many people who have the same bug (you can also see lots of people on the AskUbuntu question).

Changed in ubuntu-gnome:
status: New → Confirmed
Changed in fwupd (Ubuntu):
status: New → Confirmed
Changed in appstream:
status: Unknown → New
Mario Limonciello (superm1) wrote :

I've added these fields upstream (https://github.com/hughsie/fwupd/commit/f4e0e88f7cba833a4badc1a3d62f1a08dd1bfd96) and backported the fix as an SRU to -proposed.

description: updated
Changed in fwupd (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mario Limonciello (superm1)
Matthias Klumpp (ximion) on 2016-04-28
Changed in appstream:
importance: Unknown → Undecided
status: New → Invalid
Richard Hughes (richard-hughes) wrote :

If it helps, I can roll a new fwupd tomorrow.

Mario Limonciello (superm1) wrote :

Shouldn't be necessary to do a new release just for this. SRU's are best to be small changes with no impact.
I've uploaded a backport of just that patch to xenial-proposed. The release team will need to ack it and release it and go through the SRU process (https://wiki.ubuntu.com/StableReleaseUpdates)

Hello Nikita, or anyone else affected,

Accepted fwupd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fwupd/0.7.0-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

no longer affects: appstream (Ubuntu Xenial)
Changed in fwupd (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in fwupd (Ubuntu):
importance: Undecided → High
Changed in fwupd (Ubuntu Xenial):
importance: Undecided → High
Changed in appstream (Ubuntu):
importance: Undecided → High
Matthias Klumpp (ximion) on 2016-05-05
Changed in appstream (Ubuntu):
importance: High → Medium
Changed in fwupd (Ubuntu):
importance: High → Medium

Just for the record: running "sudo apt update" gave me the same error, even though original askubuntu post suggested otherwise.

Mario Limonciello (superm1) wrote :

@Orzerch can you please try the fix in -proposed? See the comment in https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1575248/comments/8

We're waiting for confirmation from someone other than me ( the uploader) that it fixes the problem.

Bruce Pieterse (octoquad) wrote :

Looks good:

$ fwupdmgr refresh

$ sudo apt update

Get:1 http://za.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Hit:2 http://za.archive.ubuntu.com/ubuntu xenial-updates InRelease
Get:3 http://za.archive.ubuntu.com/ubuntu xenial-backports InRelease [82.2 kB]
Ign:4 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 InRelease
Hit:5 http://ppa.launchpad.net/darkxst/ppa/ubuntu xenial InRelease
Hit:6 http://security.ubuntu.com/ubuntu xenial-security InRelease
Fetched 329 kB in 3s (90.5 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
10 packages can be upgraded. Run 'apt list --upgradable' to see them.
tanagra ~ » apt-cache policy fwupd
fwupd:
  Installed: 0.7.0-0ubuntu4.1
  Candidate: 0.7.0-0ubuntu4.1
  Version table:
 *** 0.7.0-0ubuntu4.1 100
        100 /var/lib/dpkg/status
     0.7.0-0ubuntu4 500
        500 http://za.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

I have also tested it now and it appears to fix the problem everywhere where I could reproduce it before.

Martin Pitt (pitti) wrote :

Releasing to xenial-updates is blocked by fixing this in yakkety.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwupd - 0.7.0-0ubuntu5

---------------
fwupd (0.7.0-0ubuntu5) yakkety; urgency=medium

  * Add name and summary to Rival Steelseries device (LP: #1575248)

 -- Mario Limonciello <email address hidden> Tue, 10 May 2016 09:39:57 -0500

Changed in fwupd (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwupd - 0.7.0-0ubuntu4.1

---------------
fwupd (0.7.0-0ubuntu4.1) xenial-proposed; urgency=medium

  * Add name and summary to Rival Steelseries device (LP: #1575248)

 -- Mario Limonciello <email address hidden> Thu, 28 Apr 2016 09:11:04 -0500

Changed in fwupd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for fwupd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Noticed that I was having this issue ~20 Nov 2016. This is the most recent mention that Google found. I will provide details if there is interest. (Or should I just post a new bug?)

I started seeing this message:
 AppStream cache update completed, but some metadata was ignored due to errors.
on one machine on the 23rd November 2016. I would expect this to be a seperate issue. I cannot reproduce it right now, if I am able to do so later I will try and raise a new bug.

The error message popped out again for me just now. I still cannot get it to reproduce reliably but I have raised Bugs1644498 to start diagnosis.

Changed in fwupd (Debian):
status: Unknown → Fix Released
Jay Anderson (tubadogs) wrote :

Yesterday was the second time that I had noticed this issue, so I started searching and ran across this. Unsure when it actually started and how many times it has occurred.

Nikita Rotsky (rotzke) wrote :

I confirm the issue on 0.7.0-0ubuntu4.3.

Keri Alleyne (keri.alleyne) wrote :

I'm having a similar issue here with "AppStream cache update completed, but some metadata was ignored due to errors." following the use of sudo apt update && sudo apt full-upgrade.

sudo apt policy fwupd
fwupd:
  Installed: 0.7.0-0ubuntu4.3
  Candidate: 0.7.0-0ubuntu4.3
  Version table:
 *** 0.7.0-0ubuntu4.3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.7.0-0ubuntu4 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

Krino Hoogestraat (krino) wrote :

same here.

JanCeuleers (jan-ceuleers) wrote :

# fwupdmgr refresh
Failed to download https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz.asc: SSL handshake failed

Yet that link works in a browser.

Related?

paz (mozit) wrote :

I confirm the issue on 0.7.0-0ubuntu4.3.

sergey (zwezda-11) wrote :

uname -a
 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

I have
"AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done"
errors.
-----------------
appstreamcli status
AppStream Status:
Version: 0.9.4

Distribution metadata:
 /usr/share/app-info
  - XML: 1
  - No icons.

 /var/lib/app-info
  - YAML: 12
  - Iconsets:
     ubuntu-xenial-security-main
     ubuntu-xenial-security-universe
     ubuntu-xenial-security-multiverse
     ubuntu-xenial-main
     ubuntu-xenial-universe
     ubuntu-xenial-multiverse
     ubuntu-xenial-updates-main
     ubuntu-xenial-updates-universe
     ubuntu-xenial-updates-multiverse

 /var/cache/app-info
  - XML: 1
  - No icons.

Upstream metadata:
  - Found 44 components in legacy paths.

Summary:
The system metadata cache exists.
We have information on 1764 software components.
--------------------------------------------

Make

1) sudo appstreamcli refresh --force
2) sudo appstreamcli refresh --force --verbose
show
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'gnome-calculator.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'software-properties-gnome.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'ubuntu-mate-welcome.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'update-manager.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'virt-manager.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'unity-keyboard-panel.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'unity-mouse-panel.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'org.gnome.Maps.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'unity-universal-access-panel.desktop': The component is invalid.
** (appstreamcli:4311): DEBUG: WARNING: Skipped component 'CMake.desktop': The component is invalid.
and undere
3) sudo rm -rf /var/lib/apt/lists/* - hasn't helped
4) sudo apt install -reinstall fwupd - hasn't helped
5) sudo fwupdmgr refresh - hasn't helped

I have one not original REPO
 google-earth
has removed him.
The mistake has left so far, but also didn't receive updates.
It is necessary to wait still

tt8811 (tt8811) wrote :

Confirmed here also. Just began very recently appearing:

AppStream cache update completed, but some metadata was ignored due to errors.

Miroslav Zaťko (mirec-z) wrote :

same here as of Friday(25th November 2016) update

If this bug affects you please also remember to mark it as "Yes, it affects me" using the little pencil button next to the text under the title which reads "This bug affects -- people. Does this bug affect you?" ("--" replaced by the number of people). This adds 'heat' to the bug meaning that its urgency will be seen as greater on the site.

rolfinator (seb2) wrote :

Confirmed that the error is back on (X)Ubuntu 16.04.1 LTS and fwupd 0.7.0-0ubuntu4.3.

Matthias Klumpp (ximion) wrote :

Please remember that this bug is solved - you are likely running into LP #1644498 though, which is a new and different issue.

Changed in ubuntu-gnome:
status: Confirmed → Invalid
Krino Hoogestraat (krino) wrote :

Bug still persists after update: 20161128 18:00 GMT.

Ok. Does that joepardize the instalaltion or not?

-----Message d'origine-----
De : <email address hidden> [mailto:<email address hidden>] De la part de Krino Hoogestraat
Envoyé : lundi 28 novembre 2016 19:27
À : <email address hidden>
Objet : [Bug 1575248] Re: "AppStream cache update completed, but some metadata was ignored due to errors." on "sudo apt-get update"

Bug still persists after update: 20161128 18:00 GMT.

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1575248

Title:
  "AppStream cache update completed, but some metadata was ignored due
  to errors." on "sudo apt-get update"

To manage notifications about this bug go to:
https://bugs.launchpad.net/appstream/+bug/1575248/+subscriptions

Warning still persists as per today 22:07GMT.

fwupd version 0.7.0-0ubuntu4.3 on Xenial.

Mathew Hodson (mathew-hodson) wrote :

There is a fix for the warning message in bug #1644498.

You can follow the instructions in that bug to test the fix. You can also follow the progress in that bug and wait for the fix to be released for Xenial.

no longer affects: appstream (Ubuntu)
affects: ubuntu-gnome → ubuntu-translations
no longer affects: ubuntu-translations
affects: appstream → ubuntu-translations
no longer affects: ubuntu-translations
summary: - "AppStream cache update completed, but some metadata was ignored due to
- errors." on "sudo apt-get update"
+ fwupd: Error message due to invalid AppStream file
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.