fwts: checksum test reports incorrect checksum

Bug #869018 reported by Colin Ian King on 2011-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fwts (Ubuntu)
Medium
Colin Ian King

Bug Description

When fwts checksum test finds an incorrect checksum it reports what the correct checksum value should be. Unfortunately this has been computed incorrectly for the generic ACPI header case and for the RSDP extended checksum cases too.

Related branches

Colin Ian King (colin-king) wrote :

Fix committed, commit 0055666aa135effbe13eb382c4b0d1fa548f2d25, will appear in V0.24.04 (-devel) and V0.23.25, Oneiric)

Changed in fwts (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Colin King (colin-king)
status: New → In Progress
status: In Progress → Fix Committed
Colin Ian King (colin-king) wrote :

A newer version 0.23.25 of fwts is available which fixes this bug and a few other minor fixes the Oneiric release.

Version V0.23.25 can be found in my PPA:

https://launchpad.net/~colin-king/+archive/test/+packages

Can this be uploaded this to Oneiric universe? I anticipate this is the last minor bugfix upload for fwts for this cycle.

This has been soaked tested against hundreds of firmware and kernel log snapshots to check for any regressions and against a test suite to check for regressions in fwts.

This new version includes the following major bug fixes since V0.23.23:

    acpi: checksum: output correct checksum value (LP: #869018)
    acpi: method: relax _BIF, _BIX tests.
    acpi: method: Check _BST charging + discharging more thoroughly (LP: #862153)
    acpi: acpitables: fix spurious advice infomation (LP: #862170)
    pci: maxreadreq: add more helpful advice (LP: #859651)

Attached: diff between V0.23.23 and V0.23.25.

Stefano Rivera (stefanor) wrote :

Uploaded, pending review. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwts - 0.23.25

---------------
fwts (0.23.25) oneiric; urgency=low

  * acpi: checksum: output correct checksum value (LP: #869018)
  * framework: -T option should be -t, (LP: #868226)

fwts (0.23.24) oneiric; urgency=low

  * acpi: method: relax _BIF, _BIX tests.
  * acpi: method: Check _BST charging + discharging more thoroughly (LP: #862153)
  * acpi: acpitables: fix spurious advice infomation (LP: #862170)
  * pci: maxreadreq: add more helpful advice (LP: #859651)
 -- Colin King <email address hidden> Thu, 6 Oct 2011 15:11:00 +0100

Changed in fwts (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers