microcode test fails because intel-microcode.dat does not exist

Bug #1120240 reported by dino99 on 2013-02-09
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fwts (Ubuntu)
High
Colin Ian King

Bug Description

Running fwts 0.26.05 on that RR i386 system (fully updated) and browsing the result.log details, i'm seeing:

Check if system is using latest microcode.
----------------------------------------------------------------------------------------------------
Cannot read microcode file /usr/share/misc/intel-microcode.dat.
Aborted test, initialisation failed.

As per /usr/share/doc/intel-microcode/README.Debian.gz , that dat file should exist.
So i've purged the intel* packages, then reinstalled intel-microcode, iucode-tool from synaptic; but that dat file is not created.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: intel-microcode 1.20120606.v2.2
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.8-0ubuntu4
Architecture: i386
Date: Sat Feb 9 11:35:56 2013
MarkForUpload: True
SourcePackage: intel-microcode
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
dino99 (9d9) wrote :

oem@oem-desktop:~$ dmesg | grep microcode
[ 1.146534] microcode: CPU0 sig=0x10677, pf=0x10, revision=0x703
[ 1.148006] microcode: CPU0 updated to revision 0x70a, date = 2010-09-29
[ 1.153353] microcode: CPU1 sig=0x10677, pf=0x10, revision=0x703
[ 1.156840] microcode: CPU1 updated to revision 0x70a, date = 2010-09-29
[ 1.159648] microcode: CPU2 sig=0x10677, pf=0x10, revision=0x703
[ 1.163761] microcode: CPU2 updated to revision 0x70a, date = 2010-09-29
[ 1.165950] microcode: CPU3 sig=0x10677, pf=0x10, revision=0x703
[ 1.169889] microcode: CPU3 updated to revision 0x70a, date = 2010-09-29
[ 1.172245] microcode: Microcode Update Driver: v2.00 <email address hidden>, Peter Oruba

The related packages into RR archive seem to be also outdated

http://www.linuxquestions.org/questions/linux-from-scratch-13/updating-cpu-microcode-in-lfs-4175433777/

dino99 (9d9) wrote :

Digging around intel-microcode into recent ubuntu:

- found that /etc/firmware no more exist
- raring use /lib/firmware/intel-ucode

so i'm changing the affected package to fwts (0.26.5-0ubuntu1), as it still complaint about deprecated config, and ignore the new ones.

affects: intel-microcode (Ubuntu) → fwts (Ubuntu)
Changed in fwts (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Colin King (colin-king)
milestone: none → ubuntu-13.10
dino99 (9d9) wrote :

New test on the same system, but with Saucy i386 : get the same error.

Colin Ian King (colin-king) wrote :

Thanks for reporting this. I'm working on a fix for this as we speak.

Colin Ian King (colin-king) wrote :

Re-worked so it no longer has to load or depend on microcode loading. Patch sent to fwts-devel mailing list for review. Hopefully will make it into next fwts Saucy release.

summary: - intel-microcode.dat does not exist
+ microcode test fails because intel-microcode.dat does not exist
Colin Ian King (colin-king) wrote :

Fix committed, 8afc65a378909b59f79b915d9e513452cd401277, will appear in version V13.06.00 of fwts

Changed in fwts (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package fwts - 13.06.00-0ubuntu1

---------------
fwts (13.06.00-0ubuntu1) saucy; urgency=low

  [Alex Hung]
  * bios: mtrr: add uncached string for DEFAULT type
  * pci: maxreadreq: Audio device to chipset devices.
  * data: klog.json: remove a redudent line break

  [Colin Ian King]
  * debian: control: fix typo
  * lib: fwts_uefi: make vars work on recent kernels (LP: #1171617)
  * cpufreq: use qsort to sort frequencies
  * lib: fwts_uefi: cast to __SWORD_TYPE 32 bit builds
  * apic: apicedge: minor code tidy-up
  * cmos: cmosdump: remove unused commented out code
  * cmos: cmosdump: minor code tidy up, formatting
  * cpu: maxfreq: remove unused fwts_cpuinfo typedef
  * cpu: maxfreq: use number of cpus as number of items in calloc()
  * cpu: maxfreq: use doubles for cpu freqs rather than int
  * doc/fwts.1 add in names of contributors to fwts
  * copy-acpica.sh: update to use the correct ACPICA git repo
  * uefi: uefidump: don't recurse forever on zero lengths (LP: #1174947)
  * acpica: update to ACPICA version 20130418.
  * cpu: cpufreq: fix leak of file if fgets returns NULL
  * cpu: cpufreq: fix leak of dir before we return
  * cpu: maxfreq: fix leak of cpuinfo
  * lib: fwts_microcode: fix leak of allocated microcode buffer
  * lib: fwts_memorymap: free klog on error
  * lib: fwts_keymap: free keymap_list on error
  * lib: fwts_cpu: free cpu on error
  * hotkey: close fd on error
  * cpu: nx: free fwts_nx_cpuinfo on error
  * bios: mtrr: free mtrr_list on file open error
  * cpu: maxfreq: free cpufreq on error
  * acpi: dmar: free klog list on error
  * acpi: fan: fix resource leak bugs
  * acpi: lid: free gpe resources on error
  * acpi: s3: free quirks and command resources
  * acpi: s3power: free quirks and command resources
  * lib: fwts_cpu: initialize variable, stop coverity warning
  * lib: fwts_uefi: fix check of empty d_name
  * lib: fwts_uefi: only close fp if it was successfully opened
  * lib: fwts_memorymap: handle the case where str maybe NULL
  * cpu: cpufreq: avoid division by zero
  * uefi: uefidump: fix missing break in switch statement
  * uefi: uefidump: missing va_end on str == NULL return path
  * dmi: dmi_decode: remove redundant snprintf
  * acpi: cstates: set state->present[nr] if nr < MAX_CSTATE
  * utilities: kernelscan: fix memory leak
  * lib: fwts_dump: check error return on mkdir
  * lib: fwts_acpid: check fcntl return rather than assuming it works
  * hotkey: check lstat() return value rather
  * acpi: ac_adapter: initialize matching and not_matching
  * acpi: acpidump: fix overflow before widening bug
  * lib: fwts_args: free long_options on error
  * lib: fwts_framework: free resources on error
  * lib: fwts_log: free filenames on error condition
  * acpica: fwts_acpica: clear sa_mask fields
  * bios: hdaaudio: free list items and not list
  * lib: fwts_framework: free just items in list and not list descriptor
  * acpi: lid: Fix nesting bug
  * acpi: battery: Fix nesting bug
  * lib: fwts_release: check *str rather than str
  * acpica: fwts_acpica: missing unlock on error path
  * cpu: virt: correctly return true if SVM is enabled
  * lib: fwts_framework: ensure we don't trunc...

Read more...

Changed in fwts (Ubuntu):
status: Fix Committed → Fix Released
Thomas Mayer (thomas303) wrote :

This is still not fixed for ubuntu 12.04.4:

$sudo apt-get install intel-microcode
[...]
microcode.ctl (1.17-13.1ubuntu2) wird eingerichtet ...
Traceback (most recent call last):
  File "/usr/sbin/update-intel-microcode", line 41, in <module>
    tar = tarfile.open(mode='r:gz', fileobj=StringIO(src.read()))
  File "/usr/lib/python2.7/tarfile.py", line 1678, in open
    return func(name, filemode, fileobj, **kwargs)
  File "/usr/lib/python2.7/tarfile.py", line 1729, in gzopen
    raise ReadError("not a gzip file")
tarfile.ReadError: not a gzip file
update-rc.d: warning: microcode.ctl start runlevel arguments (S) do not match LSB Default-Start values (2 3 4 5)
update-rc.d: warning: microcode.ctl stop runlevel arguments (none) do not match LSB Default-Stop values (0 1 6)
Applying Intel IA32 Microcode update... done.
intel-microcode (0.20130808-p-1ubuntu1) wird eingerichtet ...
Applying Intel IA32 Microcode update... done.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers