friends-dispatcher crashed with TypeError in /usr/lib/python3/dist-packages/friends/main.py: threads_init() takes 0 positional arguments but 1 was given

Bug #1177047 reported by Logan Rosen on 2013-05-06
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
friends (Ubuntu)
Medium
Unassigned

Bug Description

This occurred after running friends-dispatcher from Terminal.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: friends-dispatcher 0.1.3daily13.04.17.1~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-0.4-generic 3.9.0
Uname: Linux 3.9.0-0-generic x86_64
ApportVersion: 2.10-0ubuntu1
Architecture: amd64
Date: Mon May 6 14:33:26 2013
ExecutablePath: /usr/bin/friends-dispatcher
InstallationDate: Installed on 2012-08-21 (258 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120821)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/friends-dispatcher
PythonArgs: ['/usr/bin/friends-dispatcher']
SourcePackage: friends
Title: friends-dispatcher crashed with TypeError in /usr/lib/python3/dist-packages/friends/main.py: threads_init() takes 0 positional arguments but 1 was given
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Related branches

Logan Rosen (logan) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in friends (Ubuntu):
status: New → Confirmed
Janus (reslayer-mail) wrote :

At least, after this replacement of «gwibber» with «friends» I see no way to use the application any more: if I start it with all accounts disabled, it starts but says I should set the accounts up, while having any enabled makes it fail.

Robert Bruce Park (robru) wrote :

The stack trace as reported has a one-line fix. The only reason I haven't done it yet is because I haven't had a chance to upgrade to saucy myself to confirm the issue. Also need to test the fix against raring to make sure we're not breaking the whole world.

tags: removed: need-duplicate-check
Changed in friends (Ubuntu):
importance: Undecided → Medium
Janus (reslayer-mail) wrote :

Wanna test. How do I get the fix? Where?

Robert Bruce Park (robru) wrote :

Ever used bzr? You'll wanna run some commands like this:

$ bzr branch lp:~robru/friends/fix-threads-init
$ cd fix-threads-init
$ bzr bd

Then look in ../build-area directory for the new .deb files, install those, and try things out. Should be working fine, there's very little to actually test here.

If that's too much effort, you can wait for the new package to hit Saucy, that should be soon-ish (just a bit of work updating the daily release tooling to release into saucy, and start doing it).

Janus (reslayer-mail) wrote :

Cloned lp:~robru/friends/fix-threads-init, ran tests, ran dispatcher.sh, ran tools/debug_live.py twitter send "test", it worked. Does that counts a workable fix?

Janus (reslayer-mail) wrote :

Oh, never used bzr before. +Took some time to install also bzr-builddeb (and all the deps is asked for) to build a deb from bazaar.
It fails to build a package:
debsign: gpg error occurred! Aborting....

Janus (reslayer-mail) wrote :

Wants me to sign tarball with your asc.

Robert Bruce Park (robru) wrote :

Yes, well it would be expected that you don't have my private key. The package built fine, it's just not signed.

Janus (reslayer-mail) wrote :

Yes, how do I avoid signing or any other way test the app?

Robert Bruce Park (robru) wrote :

Just install the unsigned packages that you already built.

Changed in friends (Ubuntu):
status: Confirmed → Fix Committed
Janus (reslayer-mail) wrote :

Did not notice the ../build-area/; yes, seems to fix that.

Janus (reslayer-mail) wrote :

Apropos, like «gwibber-poster» will be there any shortcut to make use of it instantly? On Awesome, noticed no way yet to post a thing quickly, actually quickly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friends - 0.2.0daily13.05.07.1-0ubuntu1

---------------
friends (0.2.0daily13.05.07.1-0ubuntu1) saucy; urgency=low

  [ Robert Bruce Park ]
  * Version bump for the next development series.
  * Fix LP: #1154520
  * Running «friends-app» from terminal gives a segfault. (LP: #1176991)
  * friends-dispatcher crashed with TypeError in /usr/lib/python3/dist-
    packages/friends/main.py: threads_init() takes 0 positional
    arguments but 1 was given (LP: #1177047)
  * Friends-dispatcher fails with "TypeError" at launch. (LP: #1176500)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 202

friends (0.1.3daily13.04.30ubuntu.unity.next-0ubuntu1) raring; urgency=low

  * Automatic snapshot from revision 199 (ubuntu-unity/next)
 -- Ubuntu daily release <email address hidden> Tue, 07 May 2013 17:53:19 +0000

Changed in friends (Ubuntu):
status: Fix Committed → Fix Released
Robert Bruce Park (robru) wrote :

Well, all the QML code is quite new. I'm not sure what it would take to implement that, but you should file a bug against lp:friends-app asking for it.

Stuart Bishop (stub) wrote :

Apport sent me here, with this crash happening first login after an upgrade to Saucy.

Robert Bruce Park (robru) wrote :

Stuart, please make sure all your packages are updated and then try again. If the problem persists, please report a new bug. It is just impossible that this bug can still exist, we are not even calling threads_init anymore, anywhere, ever.

Luca Comellini (lucacome) wrote :

I was sent here too after upgrading to saucy

Robert Bruce Park (robru) wrote :

Stuart and Luca, please run this command in a terminal (Ctrl+Shift+T):

apt-cache policy friends

And then please paste the output onto this bug. It should look like this:

friends:
  Installed: 0.2.0+13.10.20130926-0ubuntu1
  Candidate: 0.2.0+13.10.20130926-0ubuntu1
  Version table:
     0.2.0+13.10.20130926-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
 *** 0.2.0+13.10.20130926-0ubuntu1 0
        100 /var/lib/dpkg/status

You guys might have a version less than 0.2.0daily13.05.07.1-0ubuntu1. Either that or you are experiencing an entirely different bug that needs to be reported separately, and apport is sending you here by mistake.

Mark Bennison (mark-bennison) wrote :

I got redirected here too. Here's the info you requested.

friends:
  Installed: 0.2.0+13.10.20130926-0ubuntu1
  Candidate: 0.2.0+13.10.20130926-0ubuntu1
  Version table:
 *** 0.2.0+13.10.20130926-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

Jaime Pérez (jaime-91) wrote :

I had this problem when starting unity

Martin Pitt (pitti) wrote :

Did all people who ran into this recently just upgrade to saucy? Most likely the crash happened while you still had the raring (13.04) packages installed.

Mark Bennison (mark-bennison) wrote :

Martin, yes, I had just updated to Saucy. This error occurred after re-boot, so I would have expected it to have all the saucy packages installed? In my message (#21) it states saucy as the package repository.

Robert Bruce Park (robru) wrote :

Hmmmmm. Mark, did you ever have this error more than once? Martin and I are fairly certain that this is just some kind of one-off fluke, it really can only be explained by stale packages... there is just no way that this can possibly be happening in Saucy. Seriously, take a look at the file referenced by the error message (open it with your favorite text editor):

/usr/lib/python3/dist-packages/friends/main.py

There just isn't a call to threads_init in this file! And there hasn't been one since **May 7th**, either.

The only other explanation might be that you are actually experiencing some different bug, and apport is sending you to this one by mistake, but I'm not sure how that would happen, either.

Mark Bennison (mark-bennison) wrote :

Seems to be. I haven't had the error since so I guess there's something awry on initial run that sorts itself out. I confirm when I looked in the file you linked to and there's no reference to threads_init.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1177047

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers