friends-dispatcher crashed with friends.errors.AuthorizationError in _login_cb(): Timeout was reached (account: 1)

Bug #1159552 reported by Michael Moroni on 2013-03-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
friends (Ubuntu)
High
Robert Bruce Park

Bug Description

don't know what I did

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: friends-dispatcher 0.1.3daily13.03.22-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
Uname: Linux 3.8.0-14-generic x86_64
ApportVersion: 2.9.2-0ubuntu2
Architecture: amd64
Date: Sun Mar 24 21:11:08 2013
ExecutablePath: /usr/bin/friends-dispatcher
ExecutableTimestamp: 1363928836
InstallationDate: Installed on 2013-02-15 (37 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/friends-dispatcher -o
ProcCwd: /
PythonArgs: ['/usr/bin/friends-dispatcher', '-o']
SourcePackage: friends
Title: friends-dispatcher crashed with friends.errors.AuthorizationError in _login_cb(): Timeout was reached (account: 1)
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python3/dist-packages/friends/utils/authentication.py", line 74, in _login_cb
     raise exception
 friends.errors.AuthorizationError: Timeout was reached (account: 1)
UpgradeStatus: Upgraded to raring on 2013-02-20 (32 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Michael Moroni (airon90) wrote :

This crash has the same stack trace characteristics as bug #1135038. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
Changed in friends (Ubuntu):
importance: Undecided → Medium
tags: added: regression-retracer
information type: Private → Public
Robert Bruce Park (robru) wrote :

The error message here indicates a that a timeout was reached. Has this happened to you since? Seems like it might be a one-off error with your internet connection or perhaps even a temporary server issue with Facebook. I haven't been able to reproduce this so I'm not sure how to fix it.

Changed in friends (Ubuntu):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

that bug is ranked 3 on the current raring daily reports from errors.ubuntu.com, if that's not a bug can you try to catch the exception so users don't get apport telling them than an issue happened?

Changed in friends (Ubuntu):
importance: Medium → High
Robert Bruce Park (robru) wrote :

Ok Seb, took me quite a while to track this one down but I think I got it.

What happens is that we need this exception to get raised in order to block the dispatcher from trying to make API calls to social networks after failing to log in to them, but it turns out that the callback that is raising this exception is actually running inside the MainThread, not from inside subthreads where exceptions like this are safely caught and logged.

Changed in friends (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Robert Bruce Park (robru)
Changed in friends (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friends - 0.1.3daily13.04.17.1~13.04-0ubuntu1

---------------
friends (0.1.3daily13.04.17.1~13.04-0ubuntu1) raring; urgency=low

  [ Ken VanDine ]
  * Initiate a refresh after a new account gets created

  [ Robert Bruce Park ]
  * friends-dispatcher crashed with friends.errors.AuthorizationError in
    _login_cb(): Timeout was reached (account: 1) (LP: #1159552)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 198
 -- Ubuntu daily release <email address hidden> Wed, 17 Apr 2013 20:30:54 +0000

Changed in friends (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers