Ubuntu

[FFe] replace gwibber-service with Friends

Reported by Ken VanDine on 2013-03-19
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
friends (Ubuntu)
Medium
Unassigned
gwibber (Ubuntu)
Medium
Unassigned
libfriends (Ubuntu)
Medium
Unassigned
libunity (Ubuntu)
Undecided
Unassigned
qml-friends (Ubuntu)
Medium
Unassigned
unity-lens-friends (Ubuntu)
Medium
Unassigned

Bug Description

During the Quantal cycle, in an effort to port gwibber-service from python2 to python3 we determined it would be better to just rewrite it to make it more robust and testable.

That has been rewritten under the "friends" package, it is very well tested and we should utilize that for raring. The old codebase brings with it lots of baggage, from bugs to code that is hard to test. The new codebase has an extensive test suite.

Changed in friends (Ubuntu):
importance: Undecided → Medium
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
Changed in libfriends (Ubuntu):
importance: Undecided → Medium
Changed in qml-friends (Ubuntu):
importance: Undecided → Medium
Changed in unity-lens-friends (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in friends (Ubuntu):
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in libfriends (Ubuntu):
status: New → Confirmed
Changed in qml-friends (Ubuntu):
status: New → Confirmed
Changed in unity-lens-friends (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Why did this miss Feature Freeze?

Can you outline how this would land? Uploading ppa:super-friends/ppa to Ubuntu? Any chances to other packages / seeds?

What if it goes badly - how could we revert?

Is this linked to your other FFes or is it independent?

Ken VanDine (ken-vandine) wrote :

It missed because it was lower priority than some other work.

Landing would be uploading friends, libfriends, unity-lens-friends, qml-friends and gwibber. Most of which would depend on MIRs too, which I wanted to get the FFe approved before requesting.

Reverting would mean changing the desktop seed back from friends to gwibber-service and tweaking the gwibber version number and uploading what is currently in the 3.6 branch.

This does depend on the FFe in bug 1156941 as well as bug 1157191, both of which are very low risk.

Since the new Unity stack is sabdfl'ed into raring, you might as well do this
too then.

Iain Lane (laney) on 2013-03-20
Changed in unity-lens-friends (Ubuntu):
status: Confirmed → Triaged
Changed in qml-friends (Ubuntu):
status: Confirmed → Triaged
Changed in libfriends (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in friends (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friends - 0.1.3daily13.03.20-0ubuntu1

---------------
friends (0.1.3daily13.03.20-0ubuntu1) raring; urgency=low

  [ Robert Bruce Park ]
  * Keep the Dispatcher alive for 30s beyond the return of the final
    method invocation.
  * Stop deduplicating messages across protocols, simplifying model
    schema (LP: #1156941)
  * Add schema columns for latitude, longitude, and location name.
  * Fix 'likes' column from gdouble to guint64.
  * Add geotagging support from foursquare, facebook, flickr.
  * Implement since= for Facebook, reducing bandwidth usage.
  * Automatically prepend the required @mention to Twitter
    replies (LP: #1156829)
  * Automatically linkify URLs that get published to the model.
  * Fix the publishing of Facebook Stories (LP: #1155785)

  [ Ken VanDine ]
  * [FFe] replace gwibber-service with Friends (LP: #1156979)
  * friends-dispatcher crashed with friends.errors.AuthorizationError in
    _login_cb():
    GDBus.Error:com.google.code.AccountsSSO.SingleSignOn.Error.UserInter
    action: userActionFinished error: 10 (account: 1) (LP: #1135038)

  [ Robert Bruce Park <email address hidden>, Ken VanDine ]
  * [FFe] replace gwibber-service with Friends (LP: #1156979)
  * friends-dispatcher crashed with friends.errors.AuthorizationError in
    _login_cb():
    GDBus.Error:com.google.code.AccountsSSO.SingleSignOn.Error.UserInter
    action: userActionFinished error: 10 (account: 1) (LP: #1135038)

  [ Robert Bruce Park ]
  * friends-dispatcher crashed with friends.errors.AuthorizationError in
    _login_cb():
    GDBus.Error:com.google.code.AccountsSSO.SingleSignOn.Error.UserInter
    action: userActionFinished error: 10 (account: 1) (LP: #1135038)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 164
 -- Ubuntu daily release <email address hidden> Wed, 20 Mar 2013 14:30:42 +0000

Changed in friends (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Michael Terry (mterry) on 2013-04-02
affects: unity (Ubuntu) → libunity (Ubuntu)
Changed in libunity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.90.2daily13.04.05-0ubuntu1

---------------
libunity (6.90.2daily13.04.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * [FFe] replace gwibber-service with Friends (LP: #1156979)

  [ Didier Roche ]
  * Unity/Libunity unit tests broken by latest glib (LP: #1159677)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 215
 -- Ubuntu daily release <email address hidden> Fri, 05 Apr 2013 04:02:08 +0000

Changed in libunity (Ubuntu):
status: New → Fix Released
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Changed in libfriends (Ubuntu):
status: Triaged → Fix Released
Changed in qml-friends (Ubuntu):
status: Triaged → Fix Released
Changed in unity-lens-friends (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers