Ubuntu

Recovery Mode starts in read-only, does not mount home folder, and hangs when trying to do something

Reported by Paddy Landau on 2012-05-08
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
friendly-recovery
New
Undecided
Unassigned
friendly-recovery (Ubuntu)
Undecided
Unassigned

Bug Description

Starting with 12.04, when I boot into Recovery Mode:

1. The file-system is read-only.

2. The home folder is not mounted (if on a separate partition).

3. Choosing to check all disks or to start in low-res graphics mode asks to mount read-write but then appears to hang; Ctrl-C is required to get back to the menu.

4. I also notice that on 11.04, Recovery Mode uses smaller text (taking advantage of the monitor's resolution), whereas 12.04 uses large text.

What should happen:

1. File-system read-write, or at least a *working* option to change to read-write.

2. The home folder is mounted.

3. Check all disks or start low-res graphics should do just that, instead of hanging.

4. The text should use the available resolution of the monitor.

It is as if the Recovery Mode has not been tested at all.

(I cannot use ubuntu-bug to report the error, as it wants a specific package, which of course does not apply here.)

System: Ubuntu 12.04 LTS 64-bit, fully updated.
Related thread: http://ubuntuforums.org/showthread.php?t=1975474

alan pfeil (apfeil-9) wrote :

I have had similar difficulties with 12.04 LTS Recovery mode;

Check all disks appeared to work but reported nothing, but at least it did not hang more than 60 secs.

Safe mode low-res hangs but Ctrl+c gives a black screen followed by the Unity GUI login screen in Hi-res.

Drop to Root terminal requests a Root Password, which has not been set, and will not accept the normal user login/sudo password. The alternative requested, 'Ctrl+d' returned to the recovery menu making the use of this boot option pointless and unproductive.

May 8th 2012. bogan Alan Pfeil.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/996454/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Paddy Landau (paddy-landau) wrote :

@automated message:
I need help finding out which package to report against. I have no relevant experience in understanding how to do this for Recovery Mode.

affects: ubuntu → friendly-recovery (Ubuntu)
Erick Brunzell (lbsolost) wrote :

I think the proper package is 'friendly-recovery' so I changed accordingly.

I ran into this recently while performing some DE conversion testing and I needed to change lightdm greeters. Simply selecting "root terminal" was not sufficient to run "/usr/lib/lightdm/lightdm-set-defaults -g unity-greeter" as the file system was mounted as read only, but after enabling networking the file system was then mounted as read & write.

Paddy Landau (paddy-landau) wrote :

For my own record and for the convenience of everyone else, I am posting a work-around here.

When you boot into Recovery Mode, enter the following two commands before doing anything else:

mount --options remount,rw /
mount --all

These commands will set Recovery Mode to how it should have been.

Paddy Landau (paddy-landau) wrote :

12.10 Quantal Quetzal still has this error.

Steve Valliere (nurbles62) wrote :

I booted into 12.04's recovery mode yesterday to look for some lost disk space that might have been the files that were in the /home folder tree before I moved it to a separate drive. I (incorrectly) did not expect /home to be mounted and when I used the 'mount', 'cat /etc/mtab' and 'df -h' commands to get a few different ways of seeing what was mounted, they showed that only / was mounted, as I expected.

Unfortunately, /home actually *WAS* mounted, but none of the three commands listed above included it in their list. Yet when I ran 'mount -t ext4 /dev/sdb1 /mnt/b' and then ran 'mount' the new drive/mount point WAS listed. If I created a new file in /home, it was immediately visible in /mnt/b as well. This can only mean that /dev/sdb1 was actually mounted on /home as well as /mnt/b even though none of mount, mtab and df showed anything mounted on /home.

This is on a live mail server, but if necessary I can boot into recovery mode again and duplicate the problem, which I would consider to be rather critical. The system tools that report mounted drives should never fail to report something that is actually mounted!

Paddy Landau (paddy-landau) wrote :

Steve: Is your /home on a separate partition? If not, then what you saw was correct behaviour.

I am also a bit confused about what was your old folder and what is your current one. Looking at /etc/fstab will tell you what *should* have been mounted.

The workaround that I gave in comment #6 should automatically correct the situation whether or not your /home is on a separate partition, and even if you have different folders (such as /tmp and /boot) in separate partitions.

If your situation is worth looking at closer, start a new thread on Ubuntu Forums (so that we do not clutter this bug) and post the link here so that we can discuss it further. If the results are important to this bug, I'll attempt to replicate it and we can comment further here. Come to think of it, perhaps we should double-check what happens if /tmp and /boot are indeed on separate partitions.

Steve Valliere (nurbles62) wrote :

/ is on /dev/sda1
/home is on /dev/sdb1

If this happens elsewhere, it would be very important and if not, I'd love to know what I did to cause it to happen for me. So I posted a new forum thread at http://ubuntuforums.org/showthread.php?p=12129083#post12129083

The workaround is fine, but only AFTER one knows that it is needed. When one does not expect the drives to be mounted and they do not show as mounted, everything looks good so who would ever look for a "fix" to the expected and [apparently] correct conditions? That's why I agree about starting the new thread. I hope I wasn't too much bother here, this seemed very related to what I saw, just inverted, as it were.

Paddy Landau (paddy-landau) wrote :

Steve Valliere and I have been discussing Steve's problem on his related forum post:

http://ubuntuforums.org/showthread.php?t=2033085

I set up a test instance. Although I cannot duplicate Steve's full range of problems (which he can reliably duplicate), I can confirm that to some degree this bug causes more than mere inconvenience. Part of it is caused by an existing bug with the "mount" command, as Steve pointed out:

http://www.xss.co.at/sysinfo/mounts.html

Unfortunately, it does not seem that the Ubuntu team can solve that specific bug, at least not alone.

However, Ubuntu is definitely in the position to solve the regression mentioned in this bug. It needs to be done! Whatever was removed in the transition to 12.04 needs to be replaced.

HousieMousie2 (housiemousie2) wrote :

Paddy Landau (paddy-landau) wrote on 2012-07-24:

For my own record and for the convenience of everyone else, I am posting a work-around here.

When you boot into Recovery Mode, enter the following two commands before doing anything else:

mount --options remount,rw /
mount --all

These commands will set Recovery Mode to how it should have been.

-----------------

Thank you. Allowed me to install the proprietary nvidia driver... a must, since none of the non-proprietary drivers work for me.

Paddy Landau (paddy-landau) wrote :

I have realised that this bug will affect bug #806291.

Cavsfan (cavsfan) wrote :

I had installed gdm but, still kept lightdm as my display manager. However it would never boot into Precise 12.04 after I installed it because sudo dpkg-reconfigure lightdm only put "lightdm" in /etc/X11/default-display-manager instead of "/usr/sbin/lightdm" as it should have. Thus, lightdm would not startup at bootup.
If it weren't for Paddy Landau's workaround to gain r/w access in recovery mode I would have never been able to recover without doing another install.

I hope you fix this soon.

Cavsfan (cavsfan) wrote :

To add to the above, I have had 2 instances where I could not get into Precise because of the video driver.
In Recovery, basically nothing works: I select failsafe mode, it goes into read only mode and then nothing.
I select Network and it does nothing. All I can do is press the reset button and reboot.

Basically the only thing I can get to is Drop to Root shell.
Many people are complaining about this in the forum.

Once again I hope you fix this because for an LTS this is not right.

Paddy Landau (paddy-landau) wrote :

@Cavsfan: if you seeing comments on the forum, please invite them to visit this bug and add their votes (the green writing at the top left of this page).

This bug should be marked as a regression, because it used to work.

Ole Jon Bjørkum (oj88) wrote :

Just came over this bug today. Pretty ridiculous that something this simple is still present in an LTS release over one year after release.

Enabling networking seems to be the simplest solution because it remounts read+write.

Graeme Hewson (ghewson) wrote :

I've updated https://wiki.ubuntu.com/RecoveryMode assuming this isn't a bug, so at least the documentation matches the behaviour.

Paddy Landau (paddy-landau) wrote :

@ghewson — Thank you, that's great!

May I suggest that you add a point 9, something like:

If you have /home, /boot, /tmp, or any other mount point on a separate partition, to mount them you need to enter the command:
mount --all

Graeme Hewson (ghewson) wrote :

OK, I've updated the article again.

Paddy Landau (paddy-landau) wrote :

@ghewson — Excellent, thank you.

don (ceodongreen) on 2013-09-10
Changed in friendly-recovery (Ubuntu):
assignee: nobody → don (ceodongreen)
status: Confirmed → Invalid
assignee: don (ceodongreen) → nobody
Gary Brainin (brainin) wrote :

I do not think it was appropriate to change this bug's status to invalid. It is an easily duplicated problem that has been confirmed for months, and nothing has changed that I'm aware of.

Paddy Landau (paddy-landau) wrote :

@ceodongreen

May I ask why this has been changed to invalid?

There is no comment or explanation, and this bug remains a problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers