boot to rescue mode in Oneiric

Bug #854967 reported by josef on 2011-09-20
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Alberto Milone
fglrx-installer-updates (Ubuntu)
High
Alberto Milone
friendly-recovery (Ubuntu)
Undecided
Stéphane Graber
grub2 (Ubuntu)
High
Colin Watson
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-173 (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-173-updates (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-96 (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-96-updates (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-updates (Ubuntu)
High
Alberto Milone

Bug Description

Boot to rescue mode in Oneiric couple day failure. This mode boot start normally login screen. I use Kubuntu/Ubuntu from alternate cd.

Steve Langasek (vorlon) on 2011-09-22
Changed in friendly-recovery (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

Hi!

Can you give me a bit more details on your setup?
I'm mostly interested in the output of "dpkg -l" and /boot/grub/grub.cfg

Thanks

Changed in friendly-recovery (Ubuntu):
status: New → Incomplete
josef (ok1dtm) wrote :
josef (ok1dtm) wrote :
Stéphane Graber (stgraber) wrote :

your dpkg -l got cut off, almost half of it seems missing.

Your grub.cfg looks good and contains what should be needed to trigger the recovery mode.

Would be good to have your full "dpkg -l" and the result of "cat /proc/cmdline" when booting in rescue mode.

Thanks

josef (ok1dtm) wrote :

New dpkg -l

josef (ok1dtm) wrote :

cmdline

josef (ok1dtm) wrote :

Hi
the same result with clear new installation of Kubuntu alternate CD beta 2. Blue screen with:
Loading Linux 3.0.0-11
Inital Loading ramdisk
Now Kubuntu stoped. Must pressing enter and follow normal login screen.

Stéphane Graber (stgraber) wrote :

Ah, ok, so the fact that you need to press enter before the boot sequence resumes actually tells me that friendly-recovery started properly.

The first option in friendly-recovery is "resume", so pressing enter selected it and the boot continued.

Now the problem is why don't you actually see the menu...

Could you attach the output of "lspci -nnn" and "dmesg"?

I'm starting to think it might be hardware related or some race condition.

josef (ok1dtm) wrote :
josef (ok1dtm) wrote :
jolo (joop-loep) wrote :

This bug affects me too. Both on an old en new PC. The bug had also affected my Lenovo R61i laptop. But was fixed by friendly-recovery i386 0.2.17. This update did not fixes de bug for the old en new PC.

josef (ok1dtm) wrote :

I testing only amd64 from Alternate cd. But friendly-recovery amd64 0.2.17 no fixed this problem. Archive Kubuntu 64bit from fsarchiver with version friendly-recovery 0.2.12 worked ok.

Stéphane Graber (stgraber) wrote :

Do you have nvidia graphics on all affected machines?

josef (ok1dtm) wrote :

Yes I have nvidia GF 7600GT . Fsarchive version from 14 september is ok.

josef (ok1dtm) wrote :

I test/mistake now archive with lock update. When is lock only grub-common v 1.99-12 ubuntu2 and grub-pc-bin v 1.99-12 ubuntu2 rescue mode booting. When is update this fies to ubuntu4 rescue boot is with affects.

Stéphane Graber (stgraber) wrote :

Reproduced the issue on nvidia hardware here.

Stéphane Graber (stgraber) wrote :

At Colin Watson's suggestion, changing the gfxpayload call in grub to "set gfxpayload=text" fixes it here. Would have to check for potential side effects of doing that for everyone.

josef (ok1dtm) wrote :

Thanks worked now with "set gfxpayload=text" in grub.cfg. But in recovery mode is only
Resume
Fsck
Remount
Root
but no find NET root for wowk with APT.

here rescue mode also is broken after installing kde-desktop (installed kubuntu boot logo) on an amd64 installation with ati hd 3200 graphics.

I must admit that i did not use rescue mode for a while, maybe rescue mode was broken before but i suspect kubuntu :-; due to many other problems with kdm and akonadi.

josef (ok1dtm) wrote :

I testing Kubuntu, Xubuntu and Ubuntu alternate 64bit cd with the same result.

Chris Halse Rogers (raof) wrote :

I can confirm this on my GeForce 9300 netbook. With nouveau, the recovery menu shows as expected. With nvidia-current, the framebuffer is the empty purple left over from grub until the X driver kicks in.

Stéphane Graber (stgraber) wrote :

josef: You need to select "Remount" first as netroot requires write access to your system. Netroot is also pretty limited at the moment, there's another bug report specifically for that which I'll work on for 12.04 (don't feel like rewritting netroot entirely 2 weeks before release).

Stéphane Graber (stgraber) wrote :

Adding a task for each of the nvidia binary source packages. I'd suggest the gfxpayload blacklist shipped in each of these be updated to blacklist the nvidia chipsets (the blacklist currently shipped in these packages is empty).

Changed in friendly-recovery (Ubuntu):
status: Incomplete → Invalid
Stéphane Graber (stgraber) wrote :

Marking the bug as invalid on friendly-recovery's side as it's not something I can fix in friendly-recovery itself.

Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-173 (Ubuntu):
milestone: none → ubuntu-11.10
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
milestone: none → ubuntu-11.10
bugbot (bugbot) on 2011-09-29
tags: added: kubuntu
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-173 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-96 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu):
milestone: none → ubuntu-11.10
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
milestone: none → ubuntu-11.10
Changed in nvidia-graphics-drivers (Ubuntu):
milestone: none → ubuntu-11.10
Changed in nvidia-graphics-drivers-updates (Ubuntu):
milestone: none → ubuntu-11.10
Changed in fglrx-installer (Ubuntu):
status: New → In Progress
Changed in fglrx-installer-updates (Ubuntu):
status: New → In Progress
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → High
Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
milestone: none → ubuntu-11.10
Changed in fglrx-installer-updates (Ubuntu):
milestone: none → ubuntu-11.10
Changed in friendly-recovery (Ubuntu):
milestone: none → ubuntu-11.10
milestone: ubuntu-11.10 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96-updates - 96.43.20-0ubuntu4

---------------
nvidia-graphics-drivers-96-updates (96.43.20-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 11:01:45 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.20-0ubuntu5

---------------
nvidia-graphics-drivers-96 (96.43.20-0ubuntu5) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 10:51:27 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173-updates - 173.14.30-0ubuntu4

---------------
nvidia-graphics-drivers-173-updates (173.14.30-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 10:12:49 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173 - 173.14.30-0ubuntu7

---------------
nvidia-graphics-drivers-173 (173.14.30-0ubuntu7) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 10:06:11 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-updates - 280.13-0ubuntu4

---------------
nvidia-graphics-drivers-updates (280.13-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
    - Make it possible to add card ids to the modaliases by
      adding ids in debian/additional_card_ids.
  * debian/additional_card_ids:
    - Add support for card id 0dfc.
  * debian/nvidia-$flavour.README.Debian.in:
    - Document how to use the additional_card_ids file.
 -- Alberto Milone <email address hidden> Thu, 29 Sep 2011 17:39:14 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 280.13-0ubuntu4

---------------
nvidia-graphics-drivers (280.13-0ubuntu4) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
    - Make it possible to add card ids to the modaliases by
      adding ids in debian/additional_card_ids.
  * debian/additional_card_ids:
    - Add support for card id 0dfc.
  * debian/nvidia-$flavour.README.Debian.in:
    - Document how to use the additional_card_ids file.
 -- Alberto Milone <email address hidden> Thu, 29 Sep 2011 18:16:35 +0200

Changed in nvidia-graphics-drivers (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:8.881-0ubuntu5

---------------
fglrx-installer-updates (2:8.881-0ubuntu5) oneiric; urgency=low

  * debian/rules, debian/modaliases/fglrx_supported:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all AMD cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 15:36:28 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.881-0ubuntu3

---------------
fglrx-installer (2:8.881-0ubuntu3) oneiric; urgency=low

  * debian/rules, debian/modaliases/fglrx_supported:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all AMD cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden> Fri, 30 Sep 2011 15:36:00 +0200

Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Fix Released
Steve Langasek (vorlon) wrote :

Alberto, please revert these blacklists. Blacklisting the cards in grub causes a significant regression to the user experience when NOT booting in recovery mode - systems that had a perfectly working flicker-free boot from grub to plymouth even when using the binary nvidia drivers now have a text mode boot everywhere (bug #863719). We should *NOT* regress the standard boot experience in the last weeks before release to improve the recovery mode experience.

I believe a better solution here is to adjust /etc/grub.d/10_linux to always pass =text instead of =keep for recovery mode. Half the time when you're booting to recovery mode you'll get this anyway because the previous boot didn't succeed, so having grub always do this will be more consistent - and handle possible problems with the video handoff across *all* video hardware.

Changed in fglrx-installer (Ubuntu):
status: Fix Released → Triaged
Changed in fglrx-installer-updates (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers (Ubuntu):
status: Fix Released → Triaged
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: Fix Released → Triaged
Steve Langasek (vorlon) wrote :

Also, note that this issue is NOT specific to binary drivers! I can reproduce the problem on a system with an intel video card when gfxpayload=keep. The issue is that during a normal boot, plymouth handles the transition from graphics mode to text mode for the VT (plymouth show-splash / hide-splash), but when booting into recovery mode, plymouthd is never run except for certain edge cases (i.e., when cryptsetup is installed and plymouth is started from the initramfs before friendly-recovery runs).

So these blacklists definitely need to be reverted, and grub definitely needs to be changed to avoid use of =keep on recovery mode.

Changed in grub2 (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → High
milestone: none → ubuntu-11.10
status: New → Triaged
Colin Watson (cjwatson) wrote :

I committed this before noticing that Steve had assigned the bug to himself :-)

Changed in grub2 (Ubuntu):
assignee: Steve Langasek (vorlon) → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99-12ubuntu5

---------------
grub2 (1.99-12ubuntu5) oneiric; urgency=low

  * Never use 'set gfxpayload=keep' in recovery mode (LP: #854967).
 -- Colin Watson <email address hidden> Sat, 01 Oct 2011 10:30:39 +0100

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

The attachment "patch for bugs 864149 and 854967" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 280.13-0ubuntu5

---------------
nvidia-graphics-drivers (280.13-0ubuntu5) oneiric; urgency=low

  * Drop /usr/share/grub-gfxpayload-lists/blacklist handling; there's
    nothing about binary drivers in particular that requires blacklisting,
    we just need recovery mode to not start the console in graphics mode.
    LP: #854967.
  * Drop the initramfs hook in favor of 'alias nouveau/lbm_nouveau off',
    so that initramfs framebuffer handling will still work. LP: #864149.
 -- Steve Langasek <email address hidden> Sat, 01 Oct 2011 23:06:02 +0000

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Released
Alberto Milone (albertomilone) wrote :

Hi Steve, sorry for my late reply (I was at a sprint). I agree with your conclusions but I'd like to partially revert your changes.

You removed a feature which allowed packagers to blacklist single card ids to prevent them from using the boot splash in case of nasty interactions with the NVIDIA driver.

While the result is the same (i.e. the framebuffer is on by default), I restored the feature by putting back the relevant slave link which would simply point to a blacklist file that only shows how to disable nvidia cards (it's all commented out).

Changed in fglrx-installer (Ubuntu):
status: Triaged → Fix Released
Changed in fglrx-installer-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-96-updates (Ubuntu):
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers