Booting into recovery mode and selecting resume normal boot brings you to a text login

Bug #651782 reported by komputes on 2010-09-30
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: friendly-recovery

In 8.04 I could boot into recovery mode, perform administrative tasks, then resume to normal boot (gdm). There is a regression in 10.04 where GDM doesn't run when I select "Resume normal boot". I now have to reboot to get the login screen.

I have tried "telinit 2" from the root shell as well as "sudo telinit 2" after going through the text login. Both do nothing.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: friendly-recovery 0.2.10
ProcVersionSignature: Ubuntu 2.6.32-25.44-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Thu Sep 30 01:11:19 2010
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: friendly-recovery

komputes (komputes) wrote :
Justin Uptmor (skeeby) wrote :

are there any error logs you can post to this? try loggin in at the text login, and run "sudo startx" . if you dont have a log file already, that should generate one if it doesnt start the xserver for u.

Changed in friendly-recovery (Ubuntu):
status: New → Incomplete
komputes (komputes) wrote :

Hi Justin, nothing interesting in xorg logs because this is not an xorg issue.

running "sudo startx" gets me to gnome as the root user, when what I wish to have is gdm.

I can login and run "sudo service gdm start" which gets me to gdm, leaving an open shell available in vt1. However this bug is about a regression where the "Resume normal boot" option in the recovery menu should get you to gdm directly (without logging in and/or typing a command).

You did not mention if you are able to reproduce this bug. Please try the following:

1) Open a terminal and type "sudo telinit 1". Can you describe what you see.

2) Restart your computer in recovery mode (accessible through pressing shift at boot), select "root shell" and run the command "sudo telinit 2". Do you see the GDM login window?

Changed in friendly-recovery (Ubuntu):
status: Incomplete → New
Justin Uptmor (skeeby) wrote :

Currently running on 10.10
Running "sudo telinit 1" places me in the recovery mode menu.
Choosing to reboot as normal and running "sudo telinit 2" from the root shell both fail to bring up the GDM login window. (tried both separately)

Justin Uptmor (skeeby) on 2010-09-30
Changed in friendly-recovery (Ubuntu):
status: New → Confirmed
Emmet Hikory (persia) on 2010-09-30
Changed in friendly-recovery (Ubuntu):
importance: Undecided → Medium
summary: - booting into recovery mode and selecting resume normal boot brings you
+ Booting into recovery mode and selecting resume normal boot brings you
to a text login
tags: added: regression-release
Fabián Rodríguez (magicfab) wrote :

I've tested this in 9.04 and it worked as expected. I tested again in 9.10 and that seems to be when it broke.

achevrier (a-chevrier-pro) wrote :

Hi,
As mentions in bug #690084, I've similar problem using recovery mode using Lucid Lynx.
Booting into recovery mode and selecting resume normal boot jumps me to a text login, from where I enter my login and my password. Then I can start graphic mode entering and running startx command from there, but it brings me to a pass word menu for which I do not know what to do.

jhansonxi (jhansonxi) wrote :

This bug is a duplicate of bug #436936 (see the third comment). Everyone here should go to that bug and adjust the "Does this bug affect you?" status at the top of that bug accordingly.

komputes (komputes) wrote :

I think title/description of Bug #436936 needs to be humanized so that users can understand what is affected and we can confirm the bug merge. Looks too technical at the moment.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friendly-recovery - 0.2.13

---------------
friendly-recovery (0.2.13) oneiric; urgency=low

  * Move everything to /lib/recovery-mode/ (LP: #234409)
  * Don't use the fullpath to whiptail
  * Add new init script starting on recovery-mode (LP: #459376)
  * If whiptail can't be found, just start sulogin
  * Add a script to start mountall (remount everything read/write)
    (LP: #575469, LP: #651782)
  * Export READONLY to all scripts so they can test on the read/write state
  * Disable most scripts when the system is read only
  * Change file system check to happen when remount is called
  * Wait after all scripts returning output so the user can read it
  * Add postinst script to move any existing script to /lib/recovery-mode
    and make /usr/share/recovery-mode a symlink
  * Mark as breaking on older grub2, upstart and initramfs-tools
  * Small packaging refresh:
    - Bump standard to 3.9.2, no change needed
    - Drop simple patchsys (no patches)
    - No need to depend on bash (essential package)
    - Add ${misc:Depends} to dependencies
 -- Stephane Graber <email address hidden> Wed, 07 Sep 2011 20:18:53 -0400

Changed in friendly-recovery (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers