17.10 recovery root session networking failure

Bug #1726852 reported by Hadmut Danisch on 2017-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I just freshly installed a machine with the new 17.10 desktop, and after having trouble tried to fix that in a recovery root shell. When that did not help to fix the problem ( #1726842 ), I reinstalled with Lubuntu, which solved that problem for the moment.

But with both, Ubuntu and Lubuntu, I ran into the problem that the recovery root shell is not working properly, it is not able to get the network running properly. It took me severe manual manipulation in /etc/network/interfaces and /etc/resolv.conf, to get the machine online. I've identified three problems.

1. The machine tries to start the network through network-manager, which did not properly interact with systemd and it's nameserver at that state of boot process. Although the machine got an IP-address through DHCP, the configuration was not finished properly and aborted, due to some problem setting the DNS nameservers as passed from the DHCP server.

2. There's error messages that a grep would not work on /etc/resolv.conf, but I am not sure, where that error message came from. However, the /etc/resolv.conf is a link to ../run/systemd/resolve/stub-resolv.conf at that time, and the target does not exist at that time, so the link is dangling and every attempt to read, grep, write must fail.

3. Another problem (and possibly the reason for 1 and 2) is that some startup scripts complain about the missing ifconfig command. Indeed, ifconfig is missing and not installed, I had to use ip to check the interface configuration. Probably someone has taken ifconfig out of standard installation, since ip is a full replacement and ifconfig outdated, but there's still scripts and programs that want to use ifconfig. Maybe that's why things go wrong.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1726852/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → friendly-recovery (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers