Using fsck in Recovery Menu fails for encrypted/LVM root

Bug #1438860 reported by Brian Murray on 2015-03-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Medium
Martin Pitt

Bug Description

Using vivid with systemd the entry for "fsck ... Check all file systems" fails to do anything.

Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

tags: added: systemd-boot vivd
Martin Pitt (pitti) wrote :

fsck does work here. I do confirm the confusing error message about not being able to talk to polkit, but fsck does get started (see attached screen shot). How does it look for you?

(Mine is a current vivid amd64 QEMU installation)

Changed in friendly-recovery (Ubuntu):
status: New → Incomplete
Brian Murray (brian-murray) wrote :

In friendly-recovery I never see the "Started Remount Root and Kernel File Systems" message. Perhaps this is due to my root partition being encrypted and lvm.

Martin Pitt (pitti) on 2015-04-09
summary: - Using fsck in Recovery Menu fails
+ Using fsck in Recovery Menu fails for encrypted/LVM root
Changed in friendly-recovery (Ubuntu):
status: Incomplete → New
Martin Pitt (pitti) wrote :

Confirmed in a VM with standard LVM+cryptsetup.

Changed in friendly-recovery (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

The problem here is that at that point the fsck and mouting rw already happened.

Changed in friendly-recovery (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) on 2015-04-19
Changed in friendly-recovery (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friendly-recovery - 0.2.30

---------------
friendly-recovery (0.2.30) vivid; urgency=medium

  * Implement fsck by ourselves instead of letting the boot sequence already
    do that for us. (LP: #1438860)
  * dpkg: Quiesce "file not found" errors in apt cleanup. (LP: #887589)
  * Mount all file systems after fsck (like with mountall under upstart), to
    also cover separate /boot partitions for grub. (LP: #1438862)
 -- Martin Pitt <email address hidden> Sun, 19 Apr 2015 12:49:11 +0100

Changed in friendly-recovery (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers