Enabling Network mode in friendly-recovery mode fails

Bug #1436336 reported by dz0ny on 2015-03-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Medium
Martin Pitt
Vivid
Medium
Martin Pitt

Bug Description

dist: latest vivid+systemd

Booting via grub recovery mode and enabling network fails because it expect upstart as services manager.

affects: systemd (Ubuntu) → friendly-recovery (Ubuntu)
Martin Pitt (pitti) on 2015-03-30
Changed in friendly-recovery (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: vivid
summary: - Enabling Network mode in grub recover mode fails
+ Enabling Network mode in friendly-recovery mode fails
Martin Pitt (pitti) on 2015-04-09
Changed in friendly-recovery (Ubuntu Vivid):
status: Triaged → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friendly-recovery - 0.2.28

---------------
friendly-recovery (0.2.28) vivid; urgency=medium

  * network: Temporarily start D-Bus and NetworkManager manually, instead of
    calling the upstart scripts. We run even before local-fs-pre.target and
    can't rely on any dependencies or NM to even work, so just do this
    opportunistically. (LP: #1436336)
 -- Martin Pitt <email address hidden> Thu, 09 Apr 2015 16:07:48 +0200

Changed in friendly-recovery (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers