The firendly-recovery systemd service file has an error

Bug #1354937 reported by Tom H on 2014-08-10
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
friendly-recovery (Ubuntu)
Critical
Martin Pitt

Bug Description

The firendly-recovery systemd service file has an error:

ExecStartPre=-dmesg --console-off
should be
ExecStartPre=-/bin/dmesg --console-off

From journalctl:

[/lib/systemd/system/friendly-recovery.service:14] Executable path is not absolute, ignoring: dmesg --console-off

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: friendly-recovery 0.2.26
ProcVersionSignature: Ubuntu 3.16.0-6.11-generic 3.16.0-rc7
Uname: Linux 3.16.0-6-generic x86_64
ApportVersion: 2.14.5-0ubuntu4
Architecture: amd64
Date: Sun Aug 10 16:34:09 2014
InstallationDate: Installed on 2014-08-05 (5 days ago)
InstallationMedia: Ubuntu-Server 14.10 "Utopic Unicorn" - Alpha amd64 (20140731)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: friendly-recovery
UpgradeStatus: No upgrade log present (probably fresh install)

Tom H (tomh0665) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in friendly-recovery (Ubuntu):
status: New → Confirmed
Sam (litle-sam) wrote :

Same as the above.

Please:
- Specify the consequences of this bug.
- Then set its status back to "confirmed".

Changed in friendly-recovery (Ubuntu):
status: Confirmed → Incomplete
Fran Diéguez (frandieguez) wrote :

Basically, the system doesn't boot and it doesn't continues with the rest of service activation process

tags: added: systemd-boot
Tom H (tomh0665) wrote :

#4 is such a stupid request that I regret reporting this bug.

"friendly-recovery.service" is broken as currently shipped.

If you want "dmesg --console-off" to run, prepend "/bin/".

If you don't want "dmesg --console-off" to run, delete "ExecStartPre=-dmesg --console-off".

Changed in friendly-recovery (Ubuntu):
status: Incomplete → Confirmed

@ Fran Diéguez:
Thank you :-)

@ Tom H:
<http://tinyurl.com/7yaoc62>

Changed in friendly-recovery (Ubuntu):
importance: Undecided → Critical
Martin Pitt (pitti) wrote :

Thanks Tom, nice catch! (sorry for the pointless bureaucracy -- your initial report was quite fine!)

Changed in friendly-recovery (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) on 2014-12-03
Changed in friendly-recovery (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friendly-recovery - 0.2.27

---------------
friendly-recovery (0.2.27) vivid; urgency=medium

  * debian/friendly-recovery.service: Fix dmesg path. (LP: #1354937)
 -- Martin Pitt <email address hidden> Wed, 03 Dec 2014 13:01:36 +0100

Changed in friendly-recovery (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers