Current package is not thread-safe

Bug #1376331 reported by Rodger Combs on 2014-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fribidi (Ubuntu)
Undecided
Unassigned

Bug Description

The current fribidi release (fribidi-0.19.6) is not thread-safe unless configured with `--enable-malloc`. This can cause crashes when using fribidi in multiple libraries concurrently.
This option is removed, and thread-safe allocation enabled by default, in this commit: http://cgit.freedesktop.org/fribidi/fribidi/commit/?id=54b4496e9c2368c53f1cff57347c1f395328a142
The maintainer has not yet produced a release containing this change, so for now, package maintainers should either switch to a git version or pass the `--enable-malloc` switch at configure-time.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fribidi - 0.19.6-3

---------------
fribidi (0.19.6-3) unstable; urgency=medium

  * debian/control: Bumped Standards-Version to 3.9.6
  * debian/copyright: Switched to machine readable format.
  * Pass --enable-malloc to configure to avoid crashes when using fribidi in
    multiple libraries concurrently.
    (LP: #1376331)
  * Update my email address.

 -- أحمد المحمودي (Ahmed El-Mahmoudy) <email address hidden> Fri, 31 Oct 2014 08:30:53 +0200

Changed in fribidi (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers