frescobaldi crashed with SIGABRT in __assert_fail_base()

Bug #939196 reported by Joseph Wakeling
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
frescobaldi (Ubuntu)
Medium
Unassigned
python-poppler-qt4 (Ubuntu)
Medium
Andrew Starr-Bochicchio

Bug Description

Frescobaldi (running under Ubuntu 12.04, Unity) crashes when it tries to open a PDF file for viewing in the preview pane. This means that crashes occur e.g.:

* when you open a .ly source file for which a corresponding PDF file already exists (if no such PDF exists, the .ly file is opened without trouble)

* after you compile a .ly source file within Frescobaldi

Cf. corresponding GitHub discussion: https://github.com/wbsoft/frescobaldi/issues/33

System info:

 * Ubuntu 12.04 (Unity desktop)
 * Frescobaldi 2.0.0-1

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: frescobaldi 2.0.0-1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Thu Feb 23 02:18:58 2012
ExecutablePath: /usr/bin/frescobaldi
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120214)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/frescobaldi
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: frescobaldi
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/python2.7/dist-packages/sip.so
Title: frescobaldi crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Joseph Wakeling (webdrake) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=0x7f9a6665d058 "(((td)->td_flags & 0x0007) == 0x0000)", file=0x7f9a6665ceb0 "/build/buildd/sip4-4.13.2/siplib/siplib.c", line=<optimized out>, function=<optimized out>) at assert.c:94
 __GI___assert_fail (assertion=0x7f9a6665d058 "(((td)->td_flags & 0x0007) == 0x0000)", file=0x7f9a6665ceb0 "/build/buildd/sip4-4.13.2/siplib/siplib.c", line=8164, function=0x7f9a6665c7f0 "sip_api_convert_from_new_type") at assert.c:103
 sip_api_convert_from_new_type (cpp=0x2cb8320, td=0x7f9a665f63b0, transferObj=0x0) at /build/buildd/sip4-4.13.2/siplib/siplib.c:8164
 meth_Poppler_LinkBrowse_url (sipSelf=<LinkBrowse at remote 0x285fb00>, sipArgs=<optimized out>) at build/temp.linux-x86_64-2.7/sippopplerqt4PopplerLinkBrowse.cpp:91
 PyEval_EvalFrameEx ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in frescobaldi (Ubuntu):
importance: Undecided → Medium
summary: - frescobaldi crashed with SIGABRT in raise()
+ frescobaldi crashed with SIGABRT in __assert_fail_base()
tags: removed: need-amd64-retrace
visibility: private → public
Revision history for this message
Joseph Wakeling (webdrake) wrote :

Looks like this may be a problem with the python-poppler-qt4 bindings, so adding this package.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in frescobaldi (Ubuntu):
status: New → Confirmed
Changed in python-poppler-qt4 (Ubuntu):
status: New → Confirmed
description: updated
Revision history for this message
Wilbert Berendsen (wbsoft) wrote :

I upgraded to Ubuntu 12.04 and got the same bug. But then I recompiled python-poppler-qt4 manually and the problem went away.

So the bug is probably that the ubuntu build of python-poppler-qt4 somehow is compiled for the wrong pyqt4 or sip library version.

Revision history for this message
Wilbert Berendsen (wbsoft) wrote :

I dont know the ins and outs of Debian/Ubuntu packaging, but I noticed that python-poppler-qt4 does not depend on python-sip nor the sip-api package, which PyQt4 does. Maybe this is the cause of the crash, because the binding is generated by SIP and heavily depends on macros in the header files of SIP.

Revision history for this message
Hotteterre (luca-rossetto) wrote :

Dear Wilbert, would be possible to have a Frescobaldi PPA with the correclty compiled python-poppler-qt4 package? Thank you!

Revision history for this message
Joseph Wakeling (webdrake) wrote :

@Hotteterre: the package maintainer has provided a rebuilt python-poppler-qt4 package at:
https://launchpad.net/~ryanakca/+archive/frescobaldi

Note that the version in this PPA is technically superseded by the version in the official Ubuntu repositories, so you'll have to specifically ask for the PPA version to be installed via apt-get/aptitude:

sudo aptitude install python-poppler-qt=0.16.2-1~precise1~ppa1

It removed the crash for me, does it work for you as well?

Revision history for this message
Hotteterre (luca-rossetto) wrote :

It works perfectly! I now hope this rebuilt package will become official...

Changed in python-poppler-qt4 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in frescobaldi (Ubuntu):
status: Confirmed → Triaged
Changed in python-poppler-qt4 (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-poppler-qt4 - 0.16.2-1build1

---------------
python-poppler-qt4 (0.16.2-1build1) precise; urgency=low

  * No changes rebuild to use correct SIP bindings. (LP: #939196)
 -- Ryan Kavanagh <email address hidden> Tue, 27 Mar 2012 16:13:56 -0400

Changed in python-poppler-qt4 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Joseph Wakeling (webdrake) wrote :

Thanks to Ryan and Andrew. I've just upgraded to the new package and can confirm all is working correctly.

Revision history for this message
Joseph Wakeling (webdrake) wrote :

... and of course to Wilbert, who I've already thanked on the Frescobaldi GitHub pages, but who deserves a big round of applause for taking the time to test and track down the source of the problem.

Revision history for this message
Ryan Kavanagh (ryanakca) wrote :

This was a bug with python-poppler-qt4 affecting Frescobaldi. It has been fixed by the latest no-changes rebuild of python-poppler-qt4.

Changed in frescobaldi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers