Rendering regression in freetype 2.4.2

Bug #654010 reported by ghepeu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freetype (Ubuntu)
Fix Released
Medium
Unassigned
Maverick
Won't Fix
Medium
Unassigned

Bug Description

An improved algorithm for flattening splines (commit http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=7fb3ef64a24489189113f693696eaf935f500c3f) first released in freetype 2.4.0 causes serious rendering issues with the 'S' character in a number of fonts, including Helvetica, Calluna and Tallys.

The bug was reported to the freetype-devel mailing list in August and fixed in git a few weeks ago, so the fix will be in the next release, freetype 2.4.3, which is not yet scheduled. Maverick is the first Ubuntu release affected by this bug and should include the fix in its freetype 2.4.2 package.

You can find an example of the problem in the pdf documents attached to this email: http://article.gmane.org/gmane.comp.fonts.freetype.devel/6809 . I'll attach to this bug report a PNG screenshot.

The fix is in commit http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=e0a9a93330d3057ddf532205709ba4e1423b2557 with another type corrected in the following commit http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=0e6fc09134c0c39016f681802918b92db2ab2155

== Regression details ==
Discovered in version: 2.4.2-2 (10.10)
Last known good version: 2.3.11-1ubuntu2.4 (10.04)

Related branches

Revision history for this message
ghepeu (ghepeu) wrote :
Revision history for this message
ghepeu (ghepeu) wrote :

This is a screenshot of the same text after the fix. Notice that the curves of the 'S' are not composed by segments anymore.

Revision history for this message
ghepeu (ghepeu) wrote :

Freetype 2.4.3, which includes this fix, has just been released.

http://sourceforge.net/projects/freetype/files/freetype2/2.4.3/NEWS/view

Revision history for this message
Marcel Stimberg (marcelstimberg) wrote :

Thanks for your bug report. The issue is still present in Natty (which still has 2.4.2), confirming. I'm also marking it as a regression.

Changed in freetype (Ubuntu):
status: New → Confirmed
tags: added: maverick regression-release
description: updated
Changed in freetype (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Changed in freetype (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: upgrade-software-version
Steve Langasek (vorlon)
Changed in freetype (Ubuntu):
status: Triaged → Fix Released
Changed in freetype (Ubuntu Maverick):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers