Update freetype to 2.8.1

Bug #1728329 reported by Jeremy Bicha on 2017-10-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
freetype (Ubuntu)
Wishlist
Unassigned

Bug Description

We should merge freetype 2.8.1 from Debian Testing.

freetype (2.8.1-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream release (Closes: #876132)
    - Refresh debian/patches-ft2demos/compiler_hardening_fixes.patch,
      partially fixed upstream
    - debian/libfreetype6.symbols: Add newly export symbol

However, there is a regression in Electron apps. It looks like we'll need to wait for Electron 1.9 for the regression to be fixed.

https://bugs.chromium.org/p/skia/issues/detail?id=6663
https://github.com/Microsoft/vscode/issues/35675
https://github.com/atom/atom/issues/15737

https://github.com/electron/electron/pull/10213

Jeremy Bicha (jbicha) on 2017-10-29
tags: added: block-proposed
Adolfo Jayme (fitojb) wrote :
Changed in freetype (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Triaged
Jeremy Bicha (jbicha) on 2017-12-15
Changed in freetype (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2017-12-15
description: updated
Jeremy Bicha (jbicha) wrote :

Electron backported the fix to Electron 1.7.10 (1.7.11 is current stable).

https://github.com/electron/electron/releases/tag/v1.7.10

Therefore I'm closing this bug. Note that freetype 2.8.1 is stuck in bionic-proposed because of a regression in libfont-freetype-perl's autopkgtests.

Changed in freetype (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers