trying to overwrite shared '/usr/share/man/man1/freetype-config.1.gz', which is different from other instances of package libfreetype6-dev:i386

Bug #1390767 reported by Benedikt Bär on 2014-11-08
108
This bug affects 19 people
Affects Status Importance Assigned to Milestone
freetype (Ubuntu)
High
Unassigned

Bug Description

When installing libfreetype6-dev:i386 on a 64-bit machine:

Unpacking libfreetype6-dev:i386 (2.5.2-2ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libfreetype6-dev_2.5.2-2ubuntu1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/man/man1/freetype-config.1.gz', which is different from other instances of package libfreetype6-dev:i386
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Moving the /usr/share/man/man1/freetype-config.1.gz out of the way allows the package to install sucessfully. This is only a manual page conflict, as it seems.

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: libfreetype6-dev 2.5.2-2ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
AptOrdering:
 libpng12-dev: Install
 libfreetype6-dev: Install
 libpng12-dev: Configure
 libfreetype6-dev: Configure
Architecture: amd64
Date: Sat Nov 8 17:45:08 2014
DuplicateSignature: package:libfreetype6-dev:2.5.2-2ubuntu1:trying to overwrite shared '/usr/share/man/man1/freetype-config.1.gz', which is different from other instances of package libfreetype6-dev:i386
ErrorMessage: trying to overwrite shared '/usr/share/man/man1/freetype-config.1.gz', which is different from other instances of package libfreetype6-dev:i386
InstallationDate: Installed on 2013-11-03 (369 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: freetype
Title: package libfreetype6-dev 2.5.2-2ubuntu1 failed to install/upgrade: trying to overwrite shared '/usr/share/man/man1/freetype-config.1.gz', which is different from other instances of package libfreetype6-dev:i386
UpgradeStatus: Upgraded to utopic on 2014-11-05 (2 days ago)

Related branches

Benedikt Bär (beniwtv) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freetype (Ubuntu):
status: New → Confirmed
Changed in freetype (Ubuntu):
importance: Undecided → High
mandruis (mandruis) wrote :

Plz can you fix this bug is because i cant compile wine

SuperThin (nhomkcbt) wrote :

My Ubuntu 15.10 beta (64bit).

Which command? sudo apt-get install libfreetype6-dev:i386 (to install packages to build Wine1.7)

Angelo (spansjh) wrote :

Here's a workaround, but I'm pretty sure this breaks the manpages in one way or another:

$ sudo mv /usr/share/man/man1/freetype-config.1.gz /usr/share/man/man1/freetype-config.1.amd64.gz

Steve Langasek (vorlon) on 2015-09-12
Changed in freetype (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freetype - 2.6.1-0.1ubuntu1

---------------
freetype (2.6.1-0.1ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Make libfreetype6-dev M-A: same.
    - Error out on the use of the freetype-config --libtool option.
    - Don't add multiarch libdirs for freetype-config --libs.
    - Install the freetype2/freetype/config headers into the multiarch
      include path and provide symlinks in /usr/include.
  * Dropped patches, included upstream:
    - debian/patches-freetype/multi-thread-violations.patch
    - debian/patches-freetype/savannah-bug-41309.patch
    - debian/patches-freetype/savannah-bug-41590.patch
  * debian/patches-freetype/revert_scalable_fonts_metric.patch: dropped,
    can no longer reproduce the issue originally reported in precise, and
    upstream doesn't think this is an appropriate fix.

freetype (2.6.1-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream release (Closes: #804050)

freetype (2.6-2) unstable; urgency=medium

  * Adjust symbols references for private symbols to sort to a higher (fake)
    version number instead of a lower, so that when linking against
    libfreetype without using its symbols, we don't get a wrong dependency on
    libfreetype6 (>= 1.PRIVATE.1). Closes: #799445.
  * Pass --without-harfbuzz in debian/rules, to avoid opportunistically
    picking this up as a dependency if libharfbuzz-dev is installed.

freetype (2.6-1) unstable; urgency=medium

  * New upstream release. Closes: #793751.
    * Includes a fix for a spurious error in FT_Get_SubGlyph_Info.
      Closes: #778493.
    * Includes a fix for an infinite loop in T1 font loading.
      Closes: #798620.
    * Includes a fix for an uninitialized memory bug in font parsers.
      Closes: #798619.
    * Includes fix for an out-of-bounds rate in the Adobe CFF implementation
      (which was not previously enabled in the package build).
      Closes: #773084.
    * Includes a fix for a crasher in xdvi. Closes: #733894.
    * Fixes support for compressed pcf fonts. Closes: #780340.
    * Drop various cherrypicked upstream patches from the package.
    * Ship upstream freetype-config manpage in place of our own.
      Closes LP: #1390767.
  * Update symbols file. Includes dropping various private symbols that
    don't appear to have ever been part of the API.
  * Fix exclusion of redundant license file (txt -> TXT)
  * Re-enable the CFF driver, now that most related fonts have been fixed.
    Closes: #795653.
  * Enable stage1 build without X library dependencies for bootstrapping.
    Closes: #752270, #752271.

 -- Marc Deslauriers <email address hidden> Wed, 17 Feb 2016 10:13:11 -0500

Changed in freetype (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers