Inconsistent include paths in libfreetype6-dev between 14.04 and previous releases

Bug #1319642 reported by Martin Schaller on 2014-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freetype (Debian)
Fix Released
Unknown
freetype (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

the include path of libfreetype6-dev has changed between 14.04 and previous releases.

On 13.10:
$ pkg-config --cflags freetype2
-I/usr/include/freetype2
$ ls /usr/include/freetype2
freetype

so the application used to include <freetype/freetype.h>

On 14.04:
$ pkg-config --cflags freetype2
-I/usr/include/freetype2
(same result)
$ ls /usr/include/freetype2
config ftbzip2.h ftglyph.h ftmac.h ...
(so the stuff used to be in the freetype subdirectory is now in the include path given by pkg-config)

so the application needs now to include <freetype.h>, but this makes it incompatible to previous versions.

Of course one could change to add a second search path to the c compiler including freetype and change the application to include <freetype.h> only, but this isn't exactly nice, and I think the current layout is a mistake.

Best regards,

Martin Schaller

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libfreetype6-dev 2.5.2-1ubuntu2.1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
ApportVersion: 2.14.1-0ubuntu3.1
Architecture: i386
Date: Wed May 14 22:08:20 2014
InstallationDate: Installed on 2014-04-24 (20 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: freetype
UpgradeStatus: No upgrade log present (probably fresh install)

Martin Schaller (cp15) wrote :
Steve Langasek (vorlon) wrote :

As per <http://www.freetype.org/freetype2/docs/tutorial/step1.html>, the API for freetype requires you to do:

#include <ft2build.h>
#include FT_FREETYPE_H

As this is the only supported interface, and this interface has not changed in 2.5.1 (it worked before and works after, with no modifications), we don't intend to provide compatibility symlinks for the path.

Changed in freetype (Ubuntu):
status: New → Won't Fix
Changed in freetype (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.